profile
viewpoint

aruncgowda/Awesome-Ethical-Hacking-Resources 0

🔗 All the resources I could find for learning Ethical Hacking and Penetration Testing.

aruncgowda/gtirb 0

Intermediate Representation for Binary analysis and transformation

aruncgowda/mcsema 0

Framework for lifting x86, amd64, and aarch64 program binaries to LLVM bitcode

aruncgowda/pymlir 0

Python interface for MLIR - the Multi-Level Intermediate Representation

aruncgowda/pyvex 0

Python bindings for Valgrind's VEX IR.

aruncgowda/uroboros_python 0

Infrastructure for Reassembleable Disassembling and Transformation

issue commentocaml/opam-repository

opam init issue in docker

@kit-ty-kate
This is the image of ubuntu 14.04 .I am trying to install opam for ubuntu 14.04

aruncgowda

comment created time in a month

issue openedocaml/opam-repository

opam init issue in docker

@avsm @tel @andreas i am gettig this error in docker

opam init --comp 4.05.0 default Downloading https://opam.ocaml.org/urls.txt Downloading https://opam.ocaml.org/repo Updating ~/.opam/repo/compiler-index ... Updating ~/.opam/compilers/ ... Updating ~/.opam/repo/package-index ... Updating ~/.opam/packages/ ... Cannot find /root/.opam/compilers/4.05.0/4.05.0/4.05.0.comp: 4.05.0 is not a valid compiler name.

created time in 2 months

issue openedtensorflow/mlir

installation steps

created time in 2 months

startedspcl/pymlir

started time in 2 months

fork aruncgowda/pymlir

Python interface for MLIR - the Multi-Level Intermediate Representation

fork in 2 months

issue commentspcl/pymlir

installation procedure

Thank u @tbennun i think i have installed mlir

llvm-project/build$ cmake --build . --target check-mlir [0/1] Running the MLIR regression tests llvm-lit: /home/a/llvm-project/build/bin/../../llvm/utils/lit/lit/llvm/subst.py:127: note: Did not find PYTHON in :/home/a/llvm-project/build/./bin

Testing Time: 95.64s Unsupported: 22 Passed : 547

aruncgowda

comment created time in 2 months

issue commentspcl/pymlir

installation procedure

thank you @tbennun

i am getting this now

pymlir-master$ mlir-opt toy.mlir --mlir-print-op-generic > output.mlir mlir-opt: command not found

aruncgowda

comment created time in 2 months

startedLetsUpgrade/Cyber-Security-Essentials

started time in 2 months

issue commentspcl/pymlir

installation procedure

@tbennun thank you i am facing this error

a@a:~$ pip install pymlir Collecting pymlir Could not find a version that satisfies the requirement pymlir (from versions: ) No matching distribution found for pymlir

aruncgowda

comment created time in 3 months

issue openedspcl/pymlir

installation procedure

can i get the steps to install mlir python version what are the dependencies i shouhld install

created time in 3 months

more