profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/jlambert121/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Justin Lambert jlambert121 StitchFix

jamtur01/puppet-hipchat 40

A Puppet report processor that announces failed runs to HipChat

IndigoDomotics/google-voice-sms 2

A plugin that allows users to send and receive SMS messages using a Google Voice account. Abandoned by the original developer.

jlambert121/acidprime-r10k 1

Setup and configure r10k for use with git based environments in puppet

jlambert121/ec2-boot-init 1

Tool to help boot EC2 instances via user and meta data

jlambert121/alpine-pgbouncer 0

Minimalistic Alpine Linux pgBouncer container

jlambert121/angular-datepicker 0

Angularjs directive that generates a datepicker calendar on your input element.

jlambert121/angular-pickadate 0

A simple and fluid inline datepicker for AngularJS with no extra dependencies.

jlambert121/anthracite 0

an event / change logging/managament app

jlambert121/App-GitHubPullRequest 0

Command-line tool to query GitHub pull requests

jlambert121/automated_sysadmin_screen_test 0

Automated SysAdmin Screen Test - write interview test in **Rspec** and provision a problem environment using **Puppet**

PR opened pyinsteon/pyinsteon

Bump isort from 5.8.0 to 5.9.1

Bumps isort from 5.8.0 to 5.9.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/pycqa/isort/releases">isort's releases</a>.</em></p> <blockquote> <h3>5.9.1 June 21st 2021 [hotfix]</h3> <ul> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1758">#1758</a>: projects with many files and skip_ignore set can lead to a command-line overload.</li> </ul> <h3>5.9.0 June 21st 2021</h3> <ul> <li>Improved CLI startup time.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1697">#1697</a>: Provisional support for PEP 582: skip <code>pypackages</code> directories by default.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1705">#1705</a>: More intuitive handling of isort:skip_file comments on streams.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1737">#1737</a>: Support for using action comments to avoid adding imports to individual files.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1750">#1750</a>: Ability to customize output format lines.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1732">#1732</a>: Support for custom sort functions.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1722">#1722</a>: Improved behavior for running isort in atomic mode over Cython source files.</li> <li>Fixed (<a href="https://github-redirect.dependabot.com/PyCQA/isort/pull/1695">PyCQA/isort#1695</a>): added imports being added to doc string in some cases.</li> <li>Fixed (<a href="https://github-redirect.dependabot.com/PyCQA/isort/pull/1714">PyCQA/isort#1714</a>): in rare cases line continuation combined with tabs can output invalid code.</li> <li>Fixed (<a href="https://github-redirect.dependabot.com/PyCQA/isort/pull/1726">PyCQA/isort#1726</a>): isort ignores reverse_sort when force_sort_within_sections is true.</li> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1741">#1741</a>: comments in hanging indent modes can lead to invalid code.</li> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1744">#1744</a>: repeat noqa comments dropped when * import and non * imports exist from the same package.</li> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1721">#1721</a>: repeat noqa comments on separate from lines with force-single-line set, sometimes get dropped.</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/PyCQA/isort/blob/main/CHANGELOG.md">isort's changelog</a>.</em></p> <blockquote> <h3>5.9.1 June 21st 2021 [hotfix]</h3> <ul> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1758">#1758</a>: projects with many files and skip_ignore set can lead to a command-line overload.</li> </ul> <h3>5.9.0 June 21st 2021</h3> <ul> <li>Improved CLI startup time.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1697">#1697</a>: Provisional support for PEP 582: skip <code>pypackages</code> directories by default.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1705">#1705</a>: More intuitive handling of isort:skip_file comments on streams.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1737">#1737</a>: Support for using action comments to avoid adding imports to individual files.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1750">#1750</a>: Ability to customize output format lines.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1732">#1732</a>: Support for custom sort functions.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1722">#1722</a>: Improved behavior for running isort in atomic mode over Cython source files.</li> <li>Fixed (<a href="https://github-redirect.dependabot.com/PyCQA/isort/pull/1695">PyCQA/isort#1695</a>): added imports being added to doc string in some cases.</li> <li>Fixed (<a href="https://github-redirect.dependabot.com/PyCQA/isort/pull/1714">PyCQA/isort#1714</a>): in rare cases line continuation combined with tabs can output invalid code.</li> <li>Fixed (<a href="https://github-redirect.dependabot.com/PyCQA/isort/pull/1726">PyCQA/isort#1726</a>): isort ignores reverse_sort when force_sort_within_sections is true.</li> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1741">#1741</a>: comments in hanging indent modes can lead to invalid code.</li> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1744">#1744</a>: repeat noqa comments dropped when * import and non * imports exist from the same package.</li> <li>Fixed <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1721">#1721</a>: repeat noqa comments on separate from lines with force-single-line set, sometimes get dropped.</li> </ul> <h4>Goal Zero (Tickets related to aspirational goal of achieving 0 regressions for remaining 5.0.0 lifespan):</h4> <ul> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1394">#1394</a>: 100% branch coverage (in addition to line coverage) enforced.</li> <li>Implemented <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1751">#1751</a>: Strict typing enforcement (turned on mypy strict mode).</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/PyCQA/isort/commit/1d7e37c3ff2536abf4359f73c46c418cfec12ada"><code>1d7e37c</code></a> Bump version to 5.9.1 (hotfix)</li> <li><a href="https://github.com/PyCQA/isort/commit/8e1b2a4f1fe7997ae7d240d32a6ef4da077858d8"><code>8e1b2a4</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/pycqa/isort/issues/1759">#1759</a> from mjpieters/issues/1758</li> <li><a href="https://github.com/PyCQA/isort/commit/84664a6820dc62488c46a0500376da1f12bccaa0"><code>84664a6</code></a> Use escape_decode to address windows based usage</li> <li><a href="https://github.com/PyCQA/isort/commit/761aff4493aacfb0fab1c2ad747d009279e7824d"><code>761aff4</code></a> Use a pipe to pass filenames to git check-ignore</li> <li><a href="https://github.com/PyCQA/isort/commit/0ccefec5a394a77a8a03e6c2f517b484765abcda"><code>0ccefec</code></a> Fix remaining broken links</li> <li><a href="https://github.com/PyCQA/isort/commit/6f42a66401457dcd913c9d4be60aeff665c9b983"><code>6f42a66</code></a> Fix links</li> <li><a href="https://github.com/PyCQA/isort/commit/ee53d09e037ddc33f5618d3d07f4da6a1fce26a3"><code>ee53d09</code></a> Re-run integration tests</li> <li><a href="https://github.com/PyCQA/isort/commit/3d7d1319402853301a6d8bbe4632f947b66a93c7"><code>3d7d131</code></a> Regenerate options</li> <li><a href="https://github.com/PyCQA/isort/commit/9f39d7e121f910450688d685bbede66dd929dc08"><code>9f39d7e</code></a> Add recent contributors</li> <li><a href="https://github.com/PyCQA/isort/commit/bacec68bcdad6eb872bb884ea77e02bd959129fe"><code>bacec68</code></a> Bump version to 5.9.0</li> <li>Additional commits viewable in <a href="https://github.com/pycqa/isort/compare/5.8.0...5.9.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

pr created time in a day

create barnchpyinsteon/pyinsteon

branch : dependabot/pip/isort-5.9.1

created branch time in a day

delete branch pyinsteon/pyinsteon

delete branch : dependabot/pip/black-21.5b2

delete time in 12 days

pull request commentpyinsteon/pyinsteon

Bump black from 21.5b1 to 21.5b2

Superseded by #104.

dependabot[bot]

comment created time in 12 days

PR closed pyinsteon/pyinsteon

Bump black from 21.5b1 to 21.5b2 dependencies

Bumps black from 21.5b1 to 21.5b2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/psf/black/releases">black's releases</a>.</em></p> <blockquote> <h2>21.5b2</h2> <h3><em>Black</em></h3> <ul> <li>A space is no longer inserted into empty docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2249">#2249</a>)</li> <li>Fix handling of .gitignore files containing non-ASCII characters on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2229">#2229</a>)</li> <li>Respect <code>.gitignore</code> files in all levels, not only <code>root/.gitignore</code> file (apply <code>.gitignore</code> rules like <code>git</code> does) (<a href="https://github-redirect.dependabot.com/psf/black/issues/2225">#2225</a>)</li> <li>Restored compatibility with Click 8.0 on Python 3.6 when LANG=C used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2227">#2227</a>)</li> <li>Add extra uvloop install + import support if in python env (<a href="https://github-redirect.dependabot.com/psf/black/issues/2258">#2258</a>)</li> <li>Fix --experimental-string-processing crash when matching parens are not found (<a href="https://github-redirect.dependabot.com/psf/black/issues/2283">#2283</a>)</li> <li>Make sure to split lines that start with a string operator (<a href="https://github-redirect.dependabot.com/psf/black/issues/2286">#2286</a>)</li> <li>Fix regular expression that black uses to identify f-expressions (<a href="https://github-redirect.dependabot.com/psf/black/issues/2287">#2287</a>)</li> </ul> <h3><em>Blackd</em></h3> <ul> <li>Add a lower bound for the <code>aiohttp-cors</code> dependency. Only 0.4.0 or higher is supported. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2231">#2231</a>)</li> </ul> <h3><em>Packaging</em></h3> <ul> <li>Release self-contained x86_64 MacOS binaries as part of the GitHub release pipeline (<a href="https://github-redirect.dependabot.com/psf/black/issues/2198">#2198</a>)</li> <li>Always build binaries with the latest available Python (<a href="https://github-redirect.dependabot.com/psf/black/issues/2260">#2260</a>)</li> </ul> <h3>Documentation</h3> <ul> <li>Add discussion of magic comments to FAQ page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2272">#2272</a>)</li> <li><code>--experimental-string-processing</code> will be enabled by default in the future (<a href="https://github-redirect.dependabot.com/psf/black/issues/2273">#2273</a>)</li> <li>Fix typos discovered by codespell (<a href="https://github-redirect.dependabot.com/psf/black/issues/2228">#2228</a>)</li> <li>Fix Vim plugin installation instructions. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2235">#2235</a>)</li> <li>Add new Frequently Asked Questions page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2247">#2247</a>)</li> <li>Fix encoding + symlink issues preventing proper build on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2262">#2262</a>)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/psf/black/blob/main/CHANGES.md">black's changelog</a>.</em></p> <blockquote> <h2>21.5b2</h2> <h3><em>Black</em></h3> <ul> <li>A space is no longer inserted into empty docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2249">#2249</a>)</li> <li>Fix handling of .gitignore files containing non-ASCII characters on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2229">#2229</a>)</li> <li>Respect <code>.gitignore</code> files in all levels, not only <code>root/.gitignore</code> file (apply <code>.gitignore</code> rules like <code>git</code> does) (<a href="https://github-redirect.dependabot.com/psf/black/issues/2225">#2225</a>)</li> <li>Restored compatibility with Click 8.0 on Python 3.6 when LANG=C used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2227">#2227</a>)</li> <li>Add extra uvloop install + import support if in python env (<a href="https://github-redirect.dependabot.com/psf/black/issues/2258">#2258</a>)</li> <li>Fix --experimental-string-processing crash when matching parens are not found (<a href="https://github-redirect.dependabot.com/psf/black/issues/2283">#2283</a>)</li> <li>Make sure to split lines that start with a string operator (<a href="https://github-redirect.dependabot.com/psf/black/issues/2286">#2286</a>)</li> <li>Fix regular expression that black uses to identify f-expressions (<a href="https://github-redirect.dependabot.com/psf/black/issues/2287">#2287</a>)</li> </ul> <h3><em>Blackd</em></h3> <ul> <li>Add a lower bound for the <code>aiohttp-cors</code> dependency. Only 0.4.0 or higher is supported. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2231">#2231</a>)</li> </ul> <h3>Integrations</h3> <ul> <li>The official Black action now supports choosing what version to use, and supports the major 3 OSes. (<a href="https://github-redirect.dependabot.com/psf/black/issues/1940">#1940</a>)</li> </ul> <h3>Packaging</h3> <ul> <li>Release self-contained x86_64 MacOS binaries as part of the GitHub release pipeline (<a href="https://github-redirect.dependabot.com/psf/black/issues/2198">#2198</a>)</li> <li>Always build binaries with the latest available Python (<a href="https://github-redirect.dependabot.com/psf/black/issues/2260">#2260</a>)</li> </ul> <h3>Documentation</h3> <ul> <li>Add discussion of magic comments to FAQ page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2272">#2272</a>)</li> <li><code>--experimental-string-processing</code> will be enabled by default in the future (<a href="https://github-redirect.dependabot.com/psf/black/issues/2273">#2273</a>)</li> <li>Fix typos discovered by codespell (<a href="https://github-redirect.dependabot.com/psf/black/issues/2228">#2228</a>)</li> <li>Fix Vim plugin installation instructions. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2235">#2235</a>)</li> <li>Add new Frequently Asked Questions page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2247">#2247</a>)</li> <li>Fix encoding + symlink issues preventing proper build on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2262">#2262</a>)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li>See full diff in <a href="https://github.com/psf/black/commits">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

1 comment

1 changed file

dependabot[bot]

pr closed time in 12 days

PR opened pyinsteon/pyinsteon

Bump black from 21.5b1 to 21.6b0

Bumps black from 21.5b1 to 21.6b0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/psf/black/releases">black's releases</a>.</em></p> <blockquote> <h2>21.6b0</h2> <h2><em>Black</em></h2> <ul> <li>Fix failure caused by <code>fmt: skip</code> and indentation (<a href="https://github-redirect.dependabot.com/psf/black/issues/2281">#2281</a>)</li> <li>Account for += assignment when deciding whether to split string (<a href="https://github-redirect.dependabot.com/psf/black/issues/2312">#2312</a>)</li> <li>Correct max string length calculation when there are string operators (<a href="https://github-redirect.dependabot.com/psf/black/issues/2292">#2292</a>)</li> <li>Fixed option usage when using the <code>--code</code> flag (<a href="https://github-redirect.dependabot.com/psf/black/issues/2259">#2259</a>)</li> <li>Do not call <code>uvloop.install()</code> when <em>Black</em> is used as a library (<a href="https://github-redirect.dependabot.com/psf/black/issues/2303">#2303</a>)</li> <li>Added <code>--required-version</code> option to require a specific version to be running (<a href="https://github-redirect.dependabot.com/psf/black/issues/2300">#2300</a>)</li> <li>Fix incorrect custom breakpoint indices when string group contains fake f-strings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2311">#2311</a>)</li> <li>Fix regression where <code>R</code> prefixes would be lowercased for docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2285">#2285</a>)</li> <li>Fix handling of named escapes (<code>\N{...}</code>) when <code>--experimental-string-processing</code> is used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2319">#2319</a>)</li> </ul> <h2>21.5b2</h2> <h3><em>Black</em></h3> <ul> <li>A space is no longer inserted into empty docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2249">#2249</a>)</li> <li>Fix handling of .gitignore files containing non-ASCII characters on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2229">#2229</a>)</li> <li>Respect <code>.gitignore</code> files in all levels, not only <code>root/.gitignore</code> file (apply <code>.gitignore</code> rules like <code>git</code> does) (<a href="https://github-redirect.dependabot.com/psf/black/issues/2225">#2225</a>)</li> <li>Restored compatibility with Click 8.0 on Python 3.6 when LANG=C used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2227">#2227</a>)</li> <li>Add extra uvloop install + import support if in python env (<a href="https://github-redirect.dependabot.com/psf/black/issues/2258">#2258</a>)</li> <li>Fix --experimental-string-processing crash when matching parens are not found (<a href="https://github-redirect.dependabot.com/psf/black/issues/2283">#2283</a>)</li> <li>Make sure to split lines that start with a string operator (<a href="https://github-redirect.dependabot.com/psf/black/issues/2286">#2286</a>)</li> <li>Fix regular expression that black uses to identify f-expressions (<a href="https://github-redirect.dependabot.com/psf/black/issues/2287">#2287</a>)</li> </ul> <h3><em>Blackd</em></h3> <ul> <li>Add a lower bound for the <code>aiohttp-cors</code> dependency. Only 0.4.0 or higher is supported. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2231">#2231</a>)</li> </ul> <h3><em>Packaging</em></h3> <ul> <li>Release self-contained x86_64 MacOS binaries as part of the GitHub release pipeline (<a href="https://github-redirect.dependabot.com/psf/black/issues/2198">#2198</a>)</li> <li>Always build binaries with the latest available Python (<a href="https://github-redirect.dependabot.com/psf/black/issues/2260">#2260</a>)</li> </ul> <h3>Documentation</h3> <ul> <li>Add discussion of magic comments to FAQ page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2272">#2272</a>)</li> <li><code>--experimental-string-processing</code> will be enabled by default in the future (<a href="https://github-redirect.dependabot.com/psf/black/issues/2273">#2273</a>)</li> <li>Fix typos discovered by codespell (<a href="https://github-redirect.dependabot.com/psf/black/issues/2228">#2228</a>)</li> <li>Fix Vim plugin installation instructions. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2235">#2235</a>)</li> <li>Add new Frequently Asked Questions page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2247">#2247</a>)</li> <li>Fix encoding + symlink issues preventing proper build on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2262">#2262</a>)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/psf/black/blob/main/CHANGES.md">black's changelog</a>.</em></p> <blockquote> <h2>21.6b0</h2> <h3><em>Black</em></h3> <ul> <li>Fix failure caused by <code>fmt: skip</code> and indentation (<a href="https://github-redirect.dependabot.com/psf/black/issues/2281">#2281</a>)</li> <li>Account for += assignment when deciding whether to split string (<a href="https://github-redirect.dependabot.com/psf/black/issues/2312">#2312</a>)</li> <li>Correct max string length calculation when there are string operators (<a href="https://github-redirect.dependabot.com/psf/black/issues/2292">#2292</a>)</li> <li>Fixed option usage when using the <code>--code</code> flag (<a href="https://github-redirect.dependabot.com/psf/black/issues/2259">#2259</a>)</li> <li>Do not call <code>uvloop.install()</code> when <em>Black</em> is used as a library (<a href="https://github-redirect.dependabot.com/psf/black/issues/2303">#2303</a>)</li> <li>Added <code>--required-version</code> option to require a specific version to be running (<a href="https://github-redirect.dependabot.com/psf/black/issues/2300">#2300</a>)</li> <li>Fix incorrect custom breakpoint indices when string group contains fake f-strings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2311">#2311</a>)</li> <li>Fix regression where <code>R</code> prefixes would be lowercased for docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2285">#2285</a>)</li> <li>Fix handling of named escapes (<code>\N{...}</code>) when <code>--experimental-string-processing</code> is used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2319">#2319</a>)</li> </ul> <h2>21.5b2</h2> <h3><em>Black</em></h3> <ul> <li>A space is no longer inserted into empty docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2249">#2249</a>)</li> <li>Fix handling of .gitignore files containing non-ASCII characters on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2229">#2229</a>)</li> <li>Respect <code>.gitignore</code> files in all levels, not only <code>root/.gitignore</code> file (apply <code>.gitignore</code> rules like <code>git</code> does) (<a href="https://github-redirect.dependabot.com/psf/black/issues/2225">#2225</a>)</li> <li>Restored compatibility with Click 8.0 on Python 3.6 when LANG=C used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2227">#2227</a>)</li> <li>Add extra uvloop install + import support if in python env (<a href="https://github-redirect.dependabot.com/psf/black/issues/2258">#2258</a>)</li> <li>Fix --experimental-string-processing crash when matching parens are not found (<a href="https://github-redirect.dependabot.com/psf/black/issues/2283">#2283</a>)</li> <li>Make sure to split lines that start with a string operator (<a href="https://github-redirect.dependabot.com/psf/black/issues/2286">#2286</a>)</li> <li>Fix regular expression that black uses to identify f-expressions (<a href="https://github-redirect.dependabot.com/psf/black/issues/2287">#2287</a>)</li> </ul> <h3><em>Blackd</em></h3> <ul> <li>Add a lower bound for the <code>aiohttp-cors</code> dependency. Only 0.4.0 or higher is supported. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2231">#2231</a>)</li> </ul> <h3>Integrations</h3> <ul> <li>The official Black action now supports choosing what version to use, and supports the major 3 OSes. (<a href="https://github-redirect.dependabot.com/psf/black/issues/1940">#1940</a>)</li> </ul> <h3>Packaging</h3> <ul> <li>Release self-contained x86_64 MacOS binaries as part of the GitHub release pipeline (<a href="https://github-redirect.dependabot.com/psf/black/issues/2198">#2198</a>)</li> <li>Always build binaries with the latest available Python (<a href="https://github-redirect.dependabot.com/psf/black/issues/2260">#2260</a>)</li> </ul> <h3>Documentation</h3> <ul> <li>Add discussion of magic comments to FAQ page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2272">#2272</a>)</li> <li><code>--experimental-string-processing</code> will be enabled by default in the future (<a href="https://github-redirect.dependabot.com/psf/black/issues/2273">#2273</a>)</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li>See full diff in <a href="https://github.com/psf/black/commits">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

pr created time in 12 days

create barnchpyinsteon/pyinsteon

branch : dependabot/pip/black-21.6b0

created branch time in 12 days

PR opened pyinsteon/pyinsteon

Enhance all linking
+218 -20

0 comment

5 changed files

pr created time in 22 days

PR opened pyinsteon/pyinsteon

Bump black from 21.5b1 to 21.5b2

Bumps black from 21.5b1 to 21.5b2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/psf/black/releases">black's releases</a>.</em></p> <blockquote> <h2>21.5b2</h2> <h3><em>Black</em></h3> <ul> <li>A space is no longer inserted into empty docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2249">#2249</a>)</li> <li>Fix handling of .gitignore files containing non-ASCII characters on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2229">#2229</a>)</li> <li>Respect <code>.gitignore</code> files in all levels, not only <code>root/.gitignore</code> file (apply <code>.gitignore</code> rules like <code>git</code> does) (<a href="https://github-redirect.dependabot.com/psf/black/issues/2225">#2225</a>)</li> <li>Restored compatibility with Click 8.0 on Python 3.6 when LANG=C used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2227">#2227</a>)</li> <li>Add extra uvloop install + import support if in python env (<a href="https://github-redirect.dependabot.com/psf/black/issues/2258">#2258</a>)</li> <li>Fix --experimental-string-processing crash when matching parens are not found (<a href="https://github-redirect.dependabot.com/psf/black/issues/2283">#2283</a>)</li> <li>Make sure to split lines that start with a string operator (<a href="https://github-redirect.dependabot.com/psf/black/issues/2286">#2286</a>)</li> <li>Fix regular expression that black uses to identify f-expressions (<a href="https://github-redirect.dependabot.com/psf/black/issues/2287">#2287</a>)</li> </ul> <h3><em>Blackd</em></h3> <ul> <li>Add a lower bound for the <code>aiohttp-cors</code> dependency. Only 0.4.0 or higher is supported. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2231">#2231</a>)</li> </ul> <h3><em>Packaging</em></h3> <ul> <li>Release self-contained x86_64 MacOS binaries as part of the GitHub release pipeline (<a href="https://github-redirect.dependabot.com/psf/black/issues/2198">#2198</a>)</li> <li>Always build binaries with the latest available Python (<a href="https://github-redirect.dependabot.com/psf/black/issues/2260">#2260</a>)</li> </ul> <h3>Documentation</h3> <ul> <li>Add discussion of magic comments to FAQ page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2272">#2272</a>)</li> <li><code>--experimental-string-processing</code> will be enabled by default in the future (<a href="https://github-redirect.dependabot.com/psf/black/issues/2273">#2273</a>)</li> <li>Fix typos discovered by codespell (<a href="https://github-redirect.dependabot.com/psf/black/issues/2228">#2228</a>)</li> <li>Fix Vim plugin installation instructions. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2235">#2235</a>)</li> <li>Add new Frequently Asked Questions page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2247">#2247</a>)</li> <li>Fix encoding + symlink issues preventing proper build on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2262">#2262</a>)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/psf/black/blob/main/CHANGES.md">black's changelog</a>.</em></p> <blockquote> <h2>21.5b2</h2> <h3><em>Black</em></h3> <ul> <li>A space is no longer inserted into empty docstrings (<a href="https://github-redirect.dependabot.com/psf/black/issues/2249">#2249</a>)</li> <li>Fix handling of .gitignore files containing non-ASCII characters on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2229">#2229</a>)</li> <li>Respect <code>.gitignore</code> files in all levels, not only <code>root/.gitignore</code> file (apply <code>.gitignore</code> rules like <code>git</code> does) (<a href="https://github-redirect.dependabot.com/psf/black/issues/2225">#2225</a>)</li> <li>Restored compatibility with Click 8.0 on Python 3.6 when LANG=C used (<a href="https://github-redirect.dependabot.com/psf/black/issues/2227">#2227</a>)</li> <li>Add extra uvloop install + import support if in python env (<a href="https://github-redirect.dependabot.com/psf/black/issues/2258">#2258</a>)</li> <li>Fix --experimental-string-processing crash when matching parens are not found (<a href="https://github-redirect.dependabot.com/psf/black/issues/2283">#2283</a>)</li> <li>Make sure to split lines that start with a string operator (<a href="https://github-redirect.dependabot.com/psf/black/issues/2286">#2286</a>)</li> <li>Fix regular expression that black uses to identify f-expressions (<a href="https://github-redirect.dependabot.com/psf/black/issues/2287">#2287</a>)</li> </ul> <h3><em>Blackd</em></h3> <ul> <li>Add a lower bound for the <code>aiohttp-cors</code> dependency. Only 0.4.0 or higher is supported. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2231">#2231</a>)</li> </ul> <h3>Integrations</h3> <ul> <li>The official Black action now supports choosing what version to use, and supports the major 3 OSes. (<a href="https://github-redirect.dependabot.com/psf/black/issues/1940">#1940</a>)</li> </ul> <h3>Packaging</h3> <ul> <li>Release self-contained x86_64 MacOS binaries as part of the GitHub release pipeline (<a href="https://github-redirect.dependabot.com/psf/black/issues/2198">#2198</a>)</li> <li>Always build binaries with the latest available Python (<a href="https://github-redirect.dependabot.com/psf/black/issues/2260">#2260</a>)</li> </ul> <h3>Documentation</h3> <ul> <li>Add discussion of magic comments to FAQ page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2272">#2272</a>)</li> <li><code>--experimental-string-processing</code> will be enabled by default in the future (<a href="https://github-redirect.dependabot.com/psf/black/issues/2273">#2273</a>)</li> <li>Fix typos discovered by codespell (<a href="https://github-redirect.dependabot.com/psf/black/issues/2228">#2228</a>)</li> <li>Fix Vim plugin installation instructions. (<a href="https://github-redirect.dependabot.com/psf/black/issues/2235">#2235</a>)</li> <li>Add new Frequently Asked Questions page (<a href="https://github-redirect.dependabot.com/psf/black/issues/2247">#2247</a>)</li> <li>Fix encoding + symlink issues preventing proper build on Windows (<a href="https://github-redirect.dependabot.com/psf/black/issues/2262">#2262</a>)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li>See full diff in <a href="https://github.com/psf/black/commits">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

pr created time in 22 days

create barnchpyinsteon/pyinsteon

branch : dependabot/pip/black-21.5b2

created branch time in 22 days

PR opened pyinsteon/pyinsteon

Bump pylint from 2.8.2 to 2.8.3

Bumps pylint from 2.8.2 to 2.8.3. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/PyCQA/pylint/blob/master/ChangeLog">pylint's changelog</a>.</em></p> <blockquote> <h1>What's New in Pylint 2.8.3?</h1> <p>Release date: 2021-05-31</p> <ul> <li>Astroid has been pinned to 2.5.6 for the 2.8 branch see <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4527">#4527</a>.</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/PyCQA/pylint/commit/735c958d3b36fb5d343b7bcb81b1055a430cb042"><code>735c958</code></a> Pin astroid to 2.5.6 for pylint 2.8.3</li> <li>See full diff in <a href="https://github.com/PyCQA/pylint/compare/v2.8.2...v2.8.3">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

pr created time in 22 days

create barnchpyinsteon/pyinsteon

branch : dependabot/pip/pylint-2.8.3

created branch time in 22 days

push eventpyinsteon/pyinsteon

Tom Harris

commit sha 7025cb6f3beb42f43c6a13799eff0a6b77e38e69

Refactor response handling (#100) Simplify the response handling process to remove the process logic from the decorators and place the logic into the classes.

view details

push time in a month

PR opened pyinsteon/pyinsteon

Refactor response handling
+304 -513

0 comment

71 changed files

pr created time in a month

PR opened stitchfix/example_tech_radar

Bump nokogiri from 1.10.8 to 1.11.4

Bumps nokogiri from 1.10.8 to 1.11.4. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/sparklemotion/nokogiri/releases">nokogiri's releases</a>.</em></p> <blockquote> <h2>1.11.4 / 2021-05-14</h2> <h3>Security</h3> <p>[CRuby] Vendored libxml2 upgraded to v2.9.12 which addresses:</p> <ul> <li><a href="https://security.archlinux.org/CVE-2019-20388">CVE-2019-20388</a></li> <li><a href="https://security.archlinux.org/CVE-2020-24977">CVE-2020-24977</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3517">CVE-2021-3517</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3518">CVE-2021-3518</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3537">CVE-2021-3537</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3541">CVE-2021-3541</a></li> </ul> <p>Note that two additional CVEs were addressed upstream but are not relevant to this release. <a href="https://security.archlinux.org/CVE-2021-3516">CVE-2021-3516</a> via <code>xmllint</code> is not present in Nokogiri, and <a href="https://security.archlinux.org/CVE-2020-7595">CVE-2020-7595</a> has been patched in Nokogiri since v1.10.8 (see <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1992">#1992</a>).</p> <p>Please see <a href="https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-7rrm-v45f-jp64">nokogiri/GHSA-7rrm-v45f-jp64 </a> or <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2233">#2233</a> for a more complete analysis of these CVEs and patches.</p> <h3>Dependencies</h3> <ul> <li>[CRuby] vendored libxml2 is updated from 2.9.10 to 2.9.12. (Note that 2.9.11 was skipped because it was superseded by 2.9.12 a few hours after its release.)</li> </ul> <h2>1.11.3 / 2021-04-07</h2> <h3>Fixed</h3> <ul> <li>[CRuby] Passing non-<code>Node</code> objects to <code>Document#root=</code> now raises an <code>ArgumentError</code> exception. Previously this likely segfaulted. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1900">#1900</a>]</li> <li>[JRuby] Passing non-<code>Node</code> objects to <code>Document#root=</code> now raises an <code>ArgumentError</code> exception. Previously this raised a <code>TypeError</code> exception.</li> <li>[CRuby] arm64/aarch64 systems (like Apple's M1) can now compile libxml2 and libxslt from source (though we continue to strongly advise users to install the native gems for the best possible experience)</li> </ul> <h2>1.11.2 / 2021-03-11</h2> <h3>Fixed</h3> <ul> <li>[CRuby] <code>NodeSet</code> may now safely contain <code>Node</code> objects from multiple documents. Previously the GC lifecycle of the parent <code>Document</code> objects could lead to nodes being GCed while still in scope. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1952#issuecomment-770856928">#1952</a>]</li> <li>[CRuby] Patch libxml2 to avoid "huge input lookup" errors on large CDATA elements. (See upstream <a href="https://gitlab.gnome.org/GNOME/libxml2/-/issues/200">GNOME/libxml2#200</a> and <a href="https://gitlab.gnome.org/GNOME/libxml2/-/merge_requests/100">GNOME/libxml2!100</a>.) [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2132">#2132</a>].</li> <li>[CRuby+Windows] Enable Nokogumbo (and other downstream gems) to compile and link against <code>nokogiri.so</code> by including <code>LDFLAGS</code> in <code>Nokogiri::VERSION_INFO</code>. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2167">#2167</a>]</li> <li>[CRuby] <code>{XML,HTML}::Document.parse</code> now invokes <code>#initialize</code> exactly once. Previously <code>#initialize</code> was invoked twice on each object.</li> <li>[JRuby] <code>{XML,HTML}::Document.parse</code> now invokes <code>#initialize</code> exactly once. Previously <code>#initialize</code> was not called, which was a problem for subclassing such as done by <code>Loofah</code>.</li> </ul> <h3>Improved</h3> <ul> <li>Reduce the number of object allocations needed when parsing an HTML::DocumentFragment. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2087">#2087</a>] (Thanks, <a href="https://github.com/ashmaroli"><code>@​ashmaroli</code></a>!)</li> <li>[JRuby] Update the algorithm used to calculate <code>Node#line</code> to be wrong less-often. The underlying parser, Xerces, does not track line numbers, and so we've always used a hacky solution for this method. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1223">#1223</a>, <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2177">#2177</a>]</li> <li>Introduce <code>--enable-system-libraries</code> and <code>--disable-system-libraries</code> flags to <code>extconf.rb</code>. These flags provide the same functionality as <code>--use-system-libraries</code> and the <code>NOKOGIRI_USE_SYSTEM_LIBRARIES</code> environment variable, but are more idiomatic. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2193">#2193</a>] (Thanks, <a href="https://github.com/eregon"><code>@​eregon</code></a>!)</li> <li>[TruffleRuby] <code>--disable-static</code> is now the default on TruffleRuby when the packaged libraries are used. This is more flexible and compiles faster. (Note, though, that the default on TR is still to use system libraries.) [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2191#issuecomment-780724627">#2191</a>, <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2193">#2193</a>] (Thanks, <a href="https://github.com/eregon"><code>@​eregon</code></a>!)</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/sparklemotion/nokogiri/blob/main/CHANGELOG.md">nokogiri's changelog</a>.</em></p> <blockquote> <h2>1.11.4 / 2021-05-14</h2> <h3>Security</h3> <p>[CRuby] Vendored libxml2 upgraded to v2.9.12 which addresses:</p> <ul> <li><a href="https://security.archlinux.org/CVE-2019-20388">CVE-2019-20388</a></li> <li><a href="https://security.archlinux.org/CVE-2020-24977">CVE-2020-24977</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3517">CVE-2021-3517</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3518">CVE-2021-3518</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3537">CVE-2021-3537</a></li> <li><a href="https://security.archlinux.org/CVE-2021-3541">CVE-2021-3541</a></li> </ul> <p>Note that two additional CVEs were addressed upstream but are not relevant to this release. <a href="https://security.archlinux.org/CVE-2021-3516">CVE-2021-3516</a> via <code>xmllint</code> is not present in Nokogiri, and <a href="https://security.archlinux.org/CVE-2020-7595">CVE-2020-7595</a> has been patched in Nokogiri since v1.10.8 (see <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1992">#1992</a>).</p> <p>Please see <a href="https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-7rrm-v45f-jp64">nokogiri/GHSA-7rrm-v45f-jp64 </a> or <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2233">#2233</a> for a more complete analysis of these CVEs and patches.</p> <h3>Dependencies</h3> <ul> <li>[CRuby] vendored libxml2 is updated from 2.9.10 to 2.9.12. (Note that 2.9.11 was skipped because it was superseded by 2.9.12 a few hours after its release.)</li> </ul> <h2>1.11.3 / 2021-04-07</h2> <h3>Fixed</h3> <ul> <li>[CRuby] Passing non-<code>Node</code> objects to <code>Document#root=</code> now raises an <code>ArgumentError</code> exception. Previously this likely segfaulted. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1900">#1900</a>]</li> <li>[JRuby] Passing non-<code>Node</code> objects to <code>Document#root=</code> now raises an <code>ArgumentError</code> exception. Previously this raised a <code>TypeError</code> exception.</li> <li>[CRuby] arm64/aarch64 systems (like Apple's M1) can now compile libxml2 and libxslt from source (though we continue to strongly advise users to install the native gems for the best possible experience)</li> </ul> <h2>1.11.2 / 2021-03-11</h2> <h3>Fixed</h3> <ul> <li>[CRuby] <code>NodeSet</code> may now safely contain <code>Node</code> objects from multiple documents. Previously the GC lifecycle of the parent <code>Document</code> objects could lead to nodes being GCed while still in scope. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1952#issuecomment-770856928">#1952</a>]</li> <li>[CRuby] Patch libxml2 to avoid "huge input lookup" errors on large CDATA elements. (See upstream <a href="https://gitlab.gnome.org/GNOME/libxml2/-/issues/200">GNOME/libxml2#200</a> and <a href="https://gitlab.gnome.org/GNOME/libxml2/-/merge_requests/100">GNOME/libxml2!100</a>.) [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2132">#2132</a>].</li> <li>[CRuby+Windows] Enable Nokogumbo (and other downstream gems) to compile and link against <code>nokogiri.so</code> by including <code>LDFLAGS</code> in <code>Nokogiri::VERSION_INFO</code>. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2167">#2167</a>]</li> <li>[CRuby] <code>{XML,HTML}::Document.parse</code> now invokes <code>#initialize</code> exactly once. Previously <code>#initialize</code> was invoked twice on each object.</li> <li>[JRuby] <code>{XML,HTML}::Document.parse</code> now invokes <code>#initialize</code> exactly once. Previously <code>#initialize</code> was not called, which was a problem for subclassing such as done by <code>Loofah</code>.</li> </ul> <h3>Improved</h3> <ul> <li>Reduce the number of object allocations needed when parsing an <code>HTML::DocumentFragment</code>. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2087">#2087</a>] (Thanks, <a href="https://github.com/ashmaroli"><code>@​ashmaroli</code></a>!)</li> <li>[JRuby] Update the algorithm used to calculate <code>Node#line</code> to be wrong less-often. The underlying parser, Xerces, does not track line numbers, and so we've always used a hacky solution for this method. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1223">#1223</a>, <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2177">#2177</a>]</li> <li>Introduce <code>--enable-system-libraries</code> and <code>--disable-system-libraries</code> flags to <code>extconf.rb</code>. These flags provide the same functionality as <code>--use-system-libraries</code> and the <code>NOKOGIRI_USE_SYSTEM_LIBRARIES</code> environment variable, but are more idiomatic. [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2193">#2193</a>] (Thanks, <a href="https://github.com/eregon"><code>@​eregon</code></a>!)</li> <li>[TruffleRuby] <code>--disable-static</code> is now the default on TruffleRuby when the packaged libraries are used. This is more flexible and compiles faster. (Note, though, that the default on TR is still to use system libraries.) [<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2191#issuecomment-780724627">#2191</a>, <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2193">#2193</a>] (Thanks, <a href="https://github.com/eregon"><code>@​eregon</code></a>!)</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/sparklemotion/nokogiri/commit/9d69b44ed3357b8069856083d39ee418cd10109b"><code>9d69b44</code></a> version bump to v1.11.4</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/058e87fdfda2cc2f309df098d18fe8856e785fcc"><code>058e87f</code></a> update CHANGELOG with complete CVE information</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/92852514a0d4621961deb6ce249441ff5140358f"><code>9285251</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/2234">#2234</a> from sparklemotion/2233-upgrade-to-libxml-2-9-12</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/5436f6120f883e9f185d48b992f39118a4897760"><code>5436f61</code></a> update CHANGELOG</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/761d320af2872c61b91f7b147cf57481566e3c67"><code>761d320</code></a> patch: renumber libxml2 patches</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/889ee2a9cb1e190bfa664cbf3552585f4d0a09a7"><code>889ee2a</code></a> test: update behavior of namespaces in HTML</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/9751d852c005606447dac7bb17f1a56593014583"><code>9751d85</code></a> test: remove low-value HTML::SAX::PushParser encoding test</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/9fcb7d25eabfab5e701d882e72ecab3b2ea6b13c"><code>9fcb7d2</code></a> test: adjust xpath gc test to libxml2's max recursion depth</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/1c99019f5f1bee23e4bff6cf72871f470097f7b2"><code>1c99019</code></a> patch: backport libxslt configure.ac change for libxml2 config</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/82a253fe7c5bdfab5fbe4c1b0c536b5ce4c72ac3"><code>82a253f</code></a> patch: fix isnan/isinf patch to apply cleanly to libxml 2.9.12</li> <li>Additional commits viewable in <a href="https://github.com/sparklemotion/nokogiri/compare/v1.10.8...v1.11.4">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+8 -4

0 comment

1 changed file

pr created time in a month

PR opened pyinsteon/pyinsteon

Bump flake8-comprehensions from 3.4.0 to 3.5.0

Bumps flake8-comprehensions from 3.4.0 to 3.5.0. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/adamchainz/flake8-comprehensions/blob/main/HISTORY.rst">flake8-comprehensions's changelog</a>.</em></p> <blockquote> <h2>3.5.0 (2021-05-10)</h2> <ul> <li> <p>Support Python 3.10.</p> </li> <li> <p>Stop distributing tests to reduce package size. Tests are not intended to be run outside of the tox setup in the repository. Repackagers can use GitHub's tarballs per tag.</p> </li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/bdce56c1820fb289a3b0bada5b3ee8d8163bcc06"><code>bdce56c</code></a> Version 3.5.0</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/2bfeb635e982e484d88bf0e1603cba2e0c95944c"><code>2bfeb63</code></a> Support Python 3.10. (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/329">#329</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/746fe92166c1c8c31e48bd61777bd412ba096545"><code>746fe92</code></a> Upgrade requirements (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/328">#328</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/260ebee1926fff34e52b99c564d666e8bdb6c07c"><code>260ebee</code></a> [pre-commit.ci] pre-commit autoupdate (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/327">#327</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/b1ea5178ce895f46f7f36ca34e542f5e86b4234d"><code>b1ea517</code></a> Sync flake8 config with Black recommendation (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/326">#326</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/285c1c2a13673fc7f74ad726ce428524e11cde92"><code>285c1c2</code></a> [pre-commit.ci] pre-commit autoupdate (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/325">#325</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/3d7566d1f72cc4c06fae455dcfb203224ea1c6e9"><code>3d7566d</code></a> Upgrade requirements (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/324">#324</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/167274dab0c94d74278d316ee3c48fba91cb9bf6"><code>167274d</code></a> Upgrade requirements (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/323">#323</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/30c1b198bf087649196b50b524247fab4351cd6b"><code>30c1b19</code></a> [pre-commit.ci] pre-commit autoupdate (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/322">#322</a>)</li> <li><a href="https://github.com/adamchainz/flake8-comprehensions/commit/34786ecea7a2e8cfc29115654fabd6d2c523737e"><code>34786ec</code></a> Ensure wheel installed on CI (<a href="https://github-redirect.dependabot.com/adamchainz/flake8-comprehensions/issues/321">#321</a>)</li> <li>Additional commits viewable in <a href="https://github.com/adamchainz/flake8-comprehensions/compare/3.4.0...3.5.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually

</details>

+1 -1

0 comment

1 changed file

pr created time in a month

create barnchpyinsteon/pyinsteon

branch : dependabot/pip/flake8-comprehensions-3.5.0

created branch time in a month

create barnchpyinsteon/pyinsteon

branch : dependabot/pip/pydocstyle-6.1.1

created branch time in a month

PR opened pyinsteon/pyinsteon

Bump pydocstyle from 6.0.0 to 6.1.1

Bumps pydocstyle from 6.0.0 to 6.1.1. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/PyCQA/pydocstyle/blob/master/docs/release_notes.rst">pydocstyle's changelog</a>.</em></p> <blockquote> <h2>6.1.1 - May 17th, 2021</h2> <p>Bug Fixes</p> <ul> <li>Split <code>--source</code> by lines instead of by characters (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/536">#536</a>).</li> </ul> <h2>6.1.0 - May 17th, 2021</h2> <p>New Features</p> <ul> <li>Enable full toml configuration and pyproject.toml (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/534">#534</a>).</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/PyCQA/pydocstyle/commit/faeaa735d5c9387ab2f02c5bf9d4f07d0e7b6841"><code>faeaa73</code></a> Bump version: 6.1.1rc → 6.1.1</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/c82b0d473a32862e9fcfcf11d1cf7af2803455e7"><code>c82b0d4</code></a> Release notes for 6.1.1</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/6a4fed9c8fa71dedd1bc260090a593f36a9c772f"><code>6a4fed9</code></a> Fix <code>--source</code> flag (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/536">#536</a>)</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/cf29c320beb2bc2f63f6b3e1577291d20839bc33"><code>cf29c32</code></a> Fix CI for python 3.6 (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/541">#541</a>)</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/f710d32431fa5662e8c08c305d699e506c240f0b"><code>f710d32</code></a> Drop support for python 3.6 (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/539">#539</a>)</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/2a58918bcecc1c530f4043de04984676fe67ad2a"><code>2a58918</code></a> Bump version: 6.1.0rc → 6.1.0</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/9943669d7696f5b9ad86179662ce051713d71605"><code>9943669</code></a> Bump version: 6.0.1rc → 6.1.0rc</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/a982031b67eb42b6d23ed89968cae549c05ec118"><code>a982031</code></a> Release notes for 6.1.0</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/6bb03556c5518acf2fed53020ea6f6e3b60154ef"><code>6bb0355</code></a> Fix tests (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/538">#538</a>)</li> <li><a href="https://github.com/PyCQA/pydocstyle/commit/8d8b319e6423d2e55fa1b0c9d456b4cf5d66d552"><code>8d8b319</code></a> Enable full <code>toml</code> configuration and <code>pyproject.toml</code> (<a href="https://github-redirect.dependabot.com/PyCQA/pydocstyle/issues/534">#534</a>)</li> <li>Additional commits viewable in <a href="https://github.com/PyCQA/pydocstyle/compare/6.0.0...6.1.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually

</details>

+1 -1

0 comment

1 changed file

pr created time in a month

delete branch pyinsteon/pyinsteon

delete branch : dependabot/pip/pylint-2.8.2

delete time in a month

pull request commentpyinsteon/pyinsteon

Bump pylint from 2.4.4 to 2.8.2

OK, I won't notify you again about this release, but will get in touch when a new version is available.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot-preview[bot]

comment created time in a month

PR closed pyinsteon/pyinsteon

Bump pylint from 2.4.4 to 2.8.2 dependencies

⚠️ Dependabot Preview has been deactivated ⚠️

This pull request was created by Dependabot Preview, and you've upgraded to Dependabot. This means it won't respond to dependabot commands nor will it be automatically closed if a new version is found.

If you close this pull request, Dependabot will re-create it the next time it checks for updates and everything will work as expected.


Bumps pylint from 2.4.4 to 2.8.2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/PyCQA/pylint/releases">pylint's releases</a>.</em></p> <blockquote> <h2>pylint-2.8.1</h2> <ul> <li> <p>Add numversion back (temporarily) in <code>pkginfo</code> because it broke Pylama and revert the unnecessary <code>pylint.version</code> breaking change.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4399">#4399</a></p> </li> </ul> <h2>pylint-2.8.0</h2> <ul> <li> <p>New refactoring message <code>consider-using-with</code>. This message is emitted if resource-allocating functions or methods of the standard library (like <code>open()</code> or <code>threading.Lock.acquire()</code>) that can be used as a context manager are called without a <code>with</code> block.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/3413">#3413</a></p> </li> <li> <p>Resolve false positives on unused variables in decorator functions</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4252">#4252</a></p> </li> <li> <p>Add new extension <code>ConfusingConsecutiveElifChecker</code>. This optional checker emits a refactoring message (R5601 <code>confusing-consecutive-elif</code>) if if/elif statements with different indentation levels follow directly one after the other.</p> </li> <li> <p>New option <code>--output=<file></code> to output result to a file rather than printing to stdout.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/1070">#1070</a></p> </li> <li> <p>Use a prescriptive message for <code>unidiomatic-typecheck</code></p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/3891">#3891</a></p> </li> <li> <p>Apply <code>const-naming-style</code> to module constants annotated with <code>typing.Final</code></p> </li> <li> <p>The packaging is now done via setuptools exclusively. <code>doc</code>, <code>tests</code>, <code>man</code>, <code>elisp</code> and <code>Changelog</code> are not packaged anymore - reducing the size of the package by 75%.</p> </li> <li> <p>Debian packaging is now (officially) done in <a href="https://salsa.debian.org/python-team/packages/pylint">https://salsa.debian.org/python-team/packages/pylint</a>.</p> </li> <li> <p>The 'doc' extra-require has been removed.</p> </li> <li> <p><code>pkginfo</code> now only contain <code>version</code> (also accessible with <code>pylint.version</code>), other meta-information are still accessible with <code>import importlib;metadata.metadata('pylint')</code>.</p> </li> <li> <p>COPYING has been renamed to LICENSE for standardization.</p> </li> <li> <p>Fix false-positive <code>used-before-assignment</code> in function returns.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4301">#4301</a></p> </li> <li> <p>Updated <code>astroid</code> to 2.5.3</p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/PyCQA/pylint/blob/master/ChangeLog">pylint's changelog</a>.</em></p> <blockquote> <h1>What's New in Pylint 2.8.2?</h1> <p>Release date: 2021-04-26</p> <p>.. Put new features and bugfixes here and also in 'doc/whatsnew/2.9.rst'</p> <ul> <li> <p>Keep <code>pkginfo.numversion</code> a tuple to avoid breaking pylint-django.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4405">#4405</a></p> </li> <li> <p>scm_setuptools has been added to the packaging.</p> </li> <li> <p>Pylint's tags are now the standard form <code>vX.Y.Z</code> and not <code>pylint-X.Y.Z</code> anymore.</p> </li> </ul> <h1>What's New in Pylint 2.8.1?</h1> <p>Release date: 2021-04-25</p> <p>.. Put new features and bugfixes here and also in 'doc/whatsnew/2.9.rst'</p> <ul> <li> <p>Add numversion back (temporarily) in <code>pkginfo</code> because it broke Pylama and revert the unnecessary <code>pylint.version</code> breaking change.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4399">#4399</a></p> </li> </ul> <h1>What's New in Pylint 2.8.0?</h1> <p>Release date: 2021-04-24</p> <ul> <li> <p>New refactoring message <code>consider-using-with</code>. This message is emitted if resource-allocating functions or methods of the standard library (like <code>open()</code> or <code>threading.Lock.acquire()</code>) that can be used as a context manager are called without a <code>with</code> block.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/3413">#3413</a></p> </li> <li> <p>Resolve false positives on unused variables in decorator functions</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/4252">#4252</a></p> </li> <li> <p>Add new extension <code>ConfusingConsecutiveElifChecker</code>. This optional checker emits a refactoring message (R5601 <code>confusing-consecutive-elif</code>) if if/elif statements with different indentation levels follow directly one after the other.</p> </li> <li> <p>New option <code>--output=<file></code> to output result to a file rather than printing to stdout.</p> <p>Closes <a href="https://github-redirect.dependabot.com/PyCQA/pylint/issues/1070">#1070</a></p> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/PyCQA/pylint/commit/091cb92314dc701f10390136da78fbbb362e892e"><code>091cb92</code></a> Update copyrite notice</li> <li><a href="https://github.com/PyCQA/pylint/commit/f9245c5ccbbe6817604113b0b53b2630ed4069ae"><code>f9245c5</code></a> Release with standard version tag</li> <li><a href="https://github.com/PyCQA/pylint/commit/c234b3efe19db81d0d03d46c4afa6886129bd25c"><code>c234b3e</code></a> Update documentation and changelog</li> <li><a href="https://github.com/PyCQA/pylint/commit/76a232e0cd3abb0f2d395cd2fe035046daef80fb"><code>76a232e</code></a> Add scm_setuptools for packaging</li> <li><a href="https://github.com/PyCQA/pylint/commit/a4fac223dfeb36952088ed361e27ee57c2ae45b8"><code>a4fac22</code></a> Changes after black update</li> <li><a href="https://github.com/PyCQA/pylint/commit/316af5f4936686337e12ba3ca8a7d077a855bdfb"><code>316af5f</code></a> Update black to 21.4b0</li> <li><a href="https://github.com/PyCQA/pylint/commit/9e2394d211cf81ca1864de58c36461bf885500bb"><code>9e2394d</code></a> Add changelog entry</li> <li><a href="https://github.com/PyCQA/pylint/commit/ea8a6eb6b956d139bb142eb45788a8314789b0c9"><code>ea8a6eb</code></a> Keep <strong>pkginfo</strong>.numversion a tuple</li> <li><a href="https://github.com/PyCQA/pylint/commit/530909cd0baf9cb17c6bd2ae36687df96107c091"><code>530909c</code></a> Bump black from 20.8b1 to 21.4b0</li> <li><a href="https://github.com/PyCQA/pylint/commit/a74259190d2d3266130baf5eac201e944a48e14e"><code>a742591</code></a> Fix image link in readme</li> <li>Additional commits viewable in <a href="https://github.com/PyCQA/pylint/compare/pylint-2.4.4...v2.8.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+1 -1

0 comment

1 changed file

dependabot-preview[bot]

pr closed time in a month

delete branch pyinsteon/pyinsteon

delete branch : dependabot/pip/flake8-3.9.2

delete time in a month

pull request commentpyinsteon/pyinsteon

Bump flake8 from 3.7.8 to 3.9.2

OK, I won't notify you again about this release, but will get in touch when a new version is available.

If you change your mind, just re-open this PR and I'll resolve any conflicts on it.

dependabot-preview[bot]

comment created time in a month

PR closed pyinsteon/pyinsteon

Bump flake8 from 3.7.8 to 3.9.2 dependencies

⚠️ Dependabot Preview has been deactivated ⚠️

This pull request was created by Dependabot Preview, and you've upgraded to Dependabot. This means it won't respond to dependabot commands nor will it be automatically closed if a new version is found.

If you close this pull request, Dependabot will re-create it the next time it checks for updates and everything will work as expected.


Bumps flake8 from 3.7.8 to 3.9.2. <details> <summary>Commits</summary> <ul> <li><a href="https://gitlab.com/pycqa/flake8/commit/c6e0d27593a45342ffa96a18bba708a5aab32fdf"><code>c6e0d27</code></a> Release 3.9.2</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/c428c55503911190f7e9d4d9c05d418594c20c6b"><code>c428c55</code></a> Merge pull request <a href="https://gitlab.com/pycqa/flake8/issues/1328">#1328</a> from PyCQA/fix_indent_size_str</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/f7bda9296329cd0ad22cc38fe51b9fd679eed296"><code>f7bda92</code></a> Release 3.9.1</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/e3313e0949472c1c3e9a6618615c9dc0c46291b2"><code>e3313e0</code></a> Fix bug for plugins using extend_default_ignore</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/434c108f7491b589362752b12979741598bb2dff"><code>434c108</code></a> Release 3.9.0</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/7c96c1e901fed326465316324e2c20bc1d7bc45a"><code>7c96c1e</code></a> Merge branch 'pycodestyle_2_7_0' into 'master'</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/40aba49d0d0833edf65ee9d3c3a2b511bac6f2dd"><code>40aba49</code></a> upgrade pycodestyle to 2.7.0</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/ac9c66e80bed84e78fbb803e6dd9e33cc4c741ca"><code>ac9c66e</code></a> Add indent-size option</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/fd71b8650988d1ac74fd262ed96d11da1966c412"><code>fd71b86</code></a> Merge branch 'pyflakes_3_3' into 'master'</li> <li><a href="https://gitlab.com/pycqa/flake8/commit/1eccf9a55f4385578bff87d6ee6d3bbe6e165195"><code>1eccf9a</code></a> upgrade pyflakes to 2.3.x</li> <li>Additional commits viewable in <a href="https://gitlab.com/pycqa/flake8/compare/3.7.8...3.9.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+1 -1

0 comment

1 changed file

dependabot-preview[bot]

pr closed time in a month

push eventpyinsteon/pyinsteon

Tom Harris

commit sha a6996e79191fcc7906b16e9b80c9c93035125dc7

Upgrade and improve linters and code formatters (#97) * Improve code checks * Make isort black compatable * Update code for new checks * Resolve circular refs * Rename commands to device_commands * Resolve circular ref with IPDB * Move protocol commands up * Reformat to proper JSON

view details

push time in a month

PR merged pyinsteon/pyinsteon

Upgrade and improve linters and code formatters
+1580 -558

0 comment

138 changed files

teharris1

pr closed time in a month

PR opened pyinsteon/pyinsteon

Upgrade and improve linters and code formatters
+1580 -558

0 comment

138 changed files

pr created time in a month