profile
viewpoint

Ask questionsImportError: cannot import name 'check_scalar'

ImportError Traceback (most recent call last) <ipython-input-11-9b6ccb88fd0a> in <module>()

----> 3 import sklearn 4 from sklearn.cluster import KMeans as km 5 from sklearn.preprocessing import StandardScaler

./anaconda3/envs/py35/lib/python3.5/site-packages/sklearn/init.py in <module>() 74 else: 75 from . import __check_build ---> 76 from .base import clone 77 from .utils._show_versions import show_versions 78

./anaconda3/envs/py35/lib/python3.5/site-packages/sklearn/base.py in <module>() 14 15 from . import version ---> 16 from .utils import _IS_32BIT 17 18 _DEFAULT_TAGS = {

./anaconda3/envs/py35/lib/python3.5/site-packages/sklearn/utils/init.py in <module>() 18 from ..exceptions import DataConversionWarning 19 from .deprecation import deprecated ---> 20 from .validation import (as_float_array, 21 assert_all_finite, 22 check_random_state, column_or_1d, check_array,

ImportError: cannot import name 'check_scalar'

tensorflow/community

Answer questions mayou36

Hi Ksenia, it seems that this is about scikit learn and neither about TensorFlow nor about community proposals for TensorFlow. Please post an issue at the right place.

useful!

Related questions

Import Error: cannot import name 'model_utils' hot 2
Where is tf.contrib.training.HParams ? hot 1
WARNING: The TensorFlow contrib module will not be included in TensorFlow 2.0. For more information, please see: * https://github.com/tensorflow/community/blob/master/rfcs/20180907-contrib-sunset.md * https://github.com/tensorflow/addons If you depend on functionality not listed there, please file an issue. hot 1
Github User Rank List