profile
viewpoint

Ask questionsVersion 0.13 breaks running packager from VS Code from different folder

Actual Behavior

  1. Open workspace with folder configured to other than current directory
  2. Choose Start Packager
  3. [Error] Failed to start the React Native packager (error code 106)

Expected Behavior

  1. Packager to run

Software versions

  • React-Native VS Code extension version: 0.13
  • VSCode version: 1.39.2
  • OS platform and version: Ubuntu 19.10
  • NodeJS version: 12.13.0
  • React Native version: 0.60
Stack: Error: Failed to start the React Native packager (error code 106): Couldn't find react-native package in node_modules. Please, run "npm install" inside your project to install it. (error code 606)
	at Function.getWrappedError (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/src/common/error/internalError.js:35:16)
	at Function.wrapError (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/src/common/error/errorHelper.js:17:44)
	at resultOfCode.done.reason (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/src/common/entryPointHandler.js:43:72)
	at _rejected (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:844:24)
	at /home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:870:30
	at Promise.when (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:1122:31)
	at Promise.promise.promiseDispatch (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:788:41)
	at /home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:604:44
	at runSingle (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:137:13)
	at flush (/home/greger/.vscode/extensions/msjsdiag.vscode-react-native-0.13.0/node_modules/q/q.js:125:13)
	at process._tickCallback (internal/process/next_tick.js:61:11)

Downgrading to 0.12.1 works.

microsoft/vscode-react-native

Answer questions RedMickey

Hi @gregersn, the new version 0.13.1 of React Native Tools extension has been released, please try it out and let us know if you face any problems.

useful!

Related questions

[Error] TypeError: ConfigUtils(...).configFilenameAsync is not a function hot 134
Can't attach packager for debugging hot 106
Error while executing command 'react-native.cmd run-android --no-packager' (error code 101) hot 99
/bin/sh: 1: adb: not found on Linux hot 55
Cannot bind listener: operation not permitted hot 49
Error while executing command 'react-native run-ios --simulator --no-packager' hot 39
Error while executing command 'react-native.cmd run-android --no-packager': Error while executing command 'react-native.cmd run-android --no-packager' (error code 101) hot 33
Cannot read property 'getCurrentUserAsync' of undefined hot 26
Cannot bind listener: operation not permitted hot 23
Current workspace does not contain React Native projects hot 22
Unable to resolve module `../Components/AccessibilityInfo/AccessibilityInfo` message hot 21
Could not debug - error code 604 hot 13
Not all success patterns were matched. (error code 712) hot 12
Current workspace does not contain React Native projects hot 11
Expo app doesn't connect to packager hot 10
Github User Rank List