profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/hardtmad/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Madeleine Hardt hardtmad github.com/hardtmad Grinnell College Alum.

blakecreasey/BackerUpperProject 0

Final CS 213 Operating Systems Project.

deweytyl/mhctd-JSON 0

A JSON Parsing Tool

DHatUC/twitter-w2v 0

A program to build Gensim Word2Vec models on json twitter data and run interactive queries.

hardtmad/bst 0

A simple and partial implementation of binary search trees

hardtmad/cs50ai 0

Projects from Harvard's CS50AI class

hardtmad/csc207-hw2 0

Assignment2: Getting Started with Java and Testing

PR opened Grinnell-CSC195/hw1

2020101088
+4 -0

0 comment

3 changed files

pr created time in 23 days

PR opened Grinnell-CSC195/hw1

Create 2020101058
+1 -0

0 comment

1 changed file

pr created time in 23 days

PR opened CSC322-Grinnell/grantapp-v1

Bump nokogiri from 1.6.3.1 to 1.6.8.1

Bumps nokogiri from 1.6.3.1 to 1.6.8.1. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/sparklemotion/nokogiri/blob/main/CHANGELOG.md">nokogiri's changelog</a>.</em></p> <blockquote> <h2>1.6.8.1 / 2016-10-03</h2> <h3>Dependencies</h3> <p>Removes required dependency on the <code>pkg-config</code> gem. This dependency was introduced in v1.6.8 and, because it's distributed under LGPL, was objectionable to many Nokogiri users (<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1488">#1488</a>, <a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1496">#1496</a>).</p> <p>This version makes <code>pkg-config</code> an optional dependency. If it's installed, it's used; but otherwise Nokogiri will attempt to work around its absence.</p> <h2>1.6.8 / 2016-06-06</h2> <h3>Security</h3> <p>[MRI] Bundled libxml2 is upgraded to 2.9.4, which fixes many security issues. Many of these had previously been patched in the vendored libxml 2.9.2 in the 1.6.7.x branch, but some are newer.</p> <p>See these libxml2 email posts for more:</p> <ul> <li><a href="https://mail.gnome.org/archives/xml/2015-November/msg00012.html">https://mail.gnome.org/archives/xml/2015-November/msg00012.html</a></li> <li><a href="https://mail.gnome.org/archives/xml/2016-May/msg00023.html">https://mail.gnome.org/archives/xml/2016-May/msg00023.html</a></li> </ul> <p>For a more detailed analysis, you may care to read Canonical's take on these security issues:</p> <ul> <li><a href="http://www.ubuntu.com/usn/usn-2994-1">http://www.ubuntu.com/usn/usn-2994-1</a></li> </ul> <p>[MRI] Bundled libxslt is upgraded to 1.1.29, which fixes a security issue as well as many long-known outstanding bugs, some features, some portability improvements, and general cleanup.</p> <p>See this libxslt email post for more:</p> <ul> <li><a href="https://mail.gnome.org/archives/xslt/2016-May/msg00004.html">https://mail.gnome.org/archives/xslt/2016-May/msg00004.html</a></li> </ul> <h3>Added</h3> <p>Several changes were made to improve performance:</p> <ul> <li>[MRI] Simplify <code>NodeSet#to_a</code> with a minor speed-up. (<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1397">#1397</a>)</li> <li><code>XML::Node#ancestors</code> optimization. (<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1297">#1297</a>) (Thanks, Bruno Sutic!)</li> <li>Use <code>Symbol#to_proc</code> where we weren't previously. (<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1296">#1296</a>) (Thanks, Bruno Sutic!)</li> <li><code>XML::DTD#each</code> uses implicit block calls. (Thanks, <a href="https://github.com/glaucocustodio"><code>@​glaucocustodio</code></a>!)</li> <li>Fall back to the <code>pkg-config</code> gem if we're having trouble finding the system libxml2. This should help many FreeBSD users. (<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1417">#1417</a>)</li> <li>Set document encoding appropriately even on blank document. (<a href="https://github-redirect.dependabot.com/sparklemotion/nokogiri/issues/1043">#1043</a>) (Thanks, <a href="https://github.com/batter"><code>@​batter</code></a>!)</li> </ul> <h3>Fixed</h3> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/sparklemotion/nokogiri/commit/002e4d8481dcc15bbf23fb385cdf5ebfed892442"><code>002e4d8</code></a> version bump to v1.6.8.1</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/3b9ee4baa2879be181227ee076cf54a062b93933"><code>3b9ee4b</code></a> update CHANGELOG for pkg-config</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/f2dd07910d2b8b332ce94f7daa4184532a0d8b4e"><code>f2dd079</code></a> Make the pkg-config gem optional.</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/6b05c5a5d319575f14d1cfc924c92f0df19a52cd"><code>6b05c5a</code></a> update v1.6.8 date in CHANGELOG</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/1103a647ee84837c6f23c4fe21e554bc2d3708bf"><code>1103a64</code></a> version bump to v1.6.8 final</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/03d402212707bd5dfa0a21b7de5e91a7f9d90028"><code>03d4022</code></a> update CHANGELOG with libxml2 USN info</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/a7da0f9217c7d00d9bd22be9948e73934ee55117"><code>a7da0f9</code></a> make sure test_all will errexit</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/8d4ea8671035a59d13936bce263cc7edb031fda0"><code>8d4ea86</code></a> make sure test_all doesn't require libxml-ruby</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/80e800bdb7ab5c04d19fcffdd6cc6c877b3f4279"><code>80e800b</code></a> use eval_gemfile to load libxml-ruby</li> <li><a href="https://github.com/sparklemotion/nokogiri/commit/95ba49addfb6dbece66127287d119b5955c4d28b"><code>95ba49a</code></a> test_all uses Bundler 1.12.*</li> <li>Additional commits viewable in <a href="https://github.com/sparklemotion/nokogiri/compare/v1.6.3.1...v1.6.8.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language

You can disable automated security fix PRs for this repo from the Security Alerts page.

</details>

+3 -3

0 comment

1 changed file

pr created time in a month

PR opened Grinnell-CSC195/hw1

Create DXXCC8
+1 -0

0 comment

1 changed file

pr created time in 2 months

CommitCommentEvent