profile
viewpoint
Subhojit Paul subhojit777 @axelerant Kolkata, India http://subhojit777.in Programmer.

anandpathak/AnimeAvataar 32

creating Anime Avataar from a facial image

subhojit777/dc_ajax_add_cart 5

Drupal Commerce Ajax Add to Cart

naveenvalecha/twitter_block 0

Provides configurable blocks for a Twitter feed.

subhojit777/addressing 0

A PHP 5.5+ addressing library, powered by Google's dataset.

subhojit777/agnoster-zsh-theme 0

A ZSH theme designed to disclose information contextually, with a powerline aesthetic

subhojit777/agnoster777-ohmyzsh-theme 0

A ZSH theme based on Agnoster theme and Powerline Vim, and with more Git information

subhojit777/agnosterzak-ohmyzsh-theme 0

An oh-my-zsh theme based on Powerline Vim & Agnoster theme

subhojit777/apollo 0

:rocket: Open source tools for GraphQL. Central repo for discussion.

push eventsubhojit777/questionnaire-backend

Subhojit Paul

commit sha f71a81dd4b171213429eb09e70fd66529ab6361f

remove unnecessary docker files

view details

Subhojit Paul

commit sha 3a94df943a62031490f7751b91f3055c7c05beae

heroku init

view details

Subhojit Paul

commit sha 1d7011e5f04446d515b47ea75d85508a4705ac7b

fix - heroku app not starting

view details

Subhojit Paul

commit sha f4fb4275dd872845eaac4cc1d20dd58b16262bf1

add diesel support

view details

Subhojit Paul

commit sha b510c6ecfcb267ccff82eff3e35505b5296cf7cf

Revert "add diesel support" This reverts commit f4fb4275dd872845eaac4cc1d20dd58b16262bf1.

view details

Subhojit Paul

commit sha 640dd58684737b11f63d0423c75d512d7ef5bba5

fix - unable to run migration

view details

Subhojit Paul

commit sha 990d4424f3cbd30e8fe6cd49ec4be4b6324d6279

Revert "fix - unable to run migration" This reverts commit 640dd58684737b11f63d0423c75d512d7ef5bba5.

view details

Subhojit Paul

commit sha edf750a4d1041bf60980a4e3f175347f24937636

fix - heroku app not working

view details

push time in a day

issue closedsubhojit777/questionnaire-backend

Sync presenter and participant screen - part 2

Motivation

When participant has answered a question, the chart in presenter's screen should be updated automatically.

Tasks

  • [x] New enum called event
    • Values
      • [x] navigate
      • [x] answers.create
  • [x] Make room for the new communication event
    • trait implementation of the various communication event
      • [x] response method for attaching event specific data to the socket response
    • [x] Include an event in the existing WebSocketResponse
    • [x] Include an event in the existing WebSocketRequest
    • [x] Add event as navigate for the existing response
  • [x] Sync the screens
    • [x] New request type for answers.create
      • Update new_answer so that it returns the newly created answer
      • AnswersCreateRequest struct containing - option_id: i32, user_id: i32
    • [x] New response type for answers.create, maybe use trait
      • AnswersCreateResponse struct containing - data: Answer
    • [x] Send the answer as response when it is created

closed time in 10 days

subhojit777

delete branch subhojit777/questionnaire-frontend

delete branch : 3-sync-presenter-participant

delete time in 10 days

push eventsubhojit777/questionnaire-frontend

Subhojit Paul

commit sha d0cbb94b9c70b7ebdaa113c1a6c745a1a1efe6ff

Issue #3 - sync presenter participant (#6)

view details

push time in 10 days

issue closedsubhojit777/questionnaire-frontend

Sync presenter and participant screen

Dependencies:

  • #1
  • #2

Tasks:

  • [x] Participant should see the same question that the presenter is presenting
  • [x] Participant's screen should be updated automatically when presenter has clicked the navigation buttons
  • [ ] When participant has answered a question, the chart in presenter's screen should be updated automatically.

Note: Use web sockets for the implementation. Refer - https://blog.bitlabstudio.com/a-simple-chat-app-with-react-node-and-websocket-35d3c9835807

closed time in 10 days

subhojit777

delete branch subhojit777/questionnaire-backend

delete branch : 43-sync-screen-pt2

delete time in 10 days

push eventsubhojit777/questionnaire-backend

Subhojit Paul

commit sha 03d6060002fea007ead236940182a9dca0c5a426

Sync presenter and participant screen - part 2 (#44)

view details

push time in 10 days

startedhttp-rs/tide

started time in 12 days

push eventsubhojit777/questionnaire-frontend

Subhojit Paul

commit sha 59fb7aa2fc1746a4039b009c0efd5890f603602f

set user id in cookie session

view details

Subhojit Paul

commit sha 4ec6c89f202a16b1aeb06a9993989f6a6d9bb9ad

send ws request during submission

view details

Subhojit Paul

commit sha ada4f959cd27081b2dbebeb28f04dfe5bc86fd2f

update presenter based on response

view details

push time in 13 days

push eventsubhojit777/questionnaire-backend

Subhojit Paul

commit sha aafdf33b8eec508029397a4d7d19a46cb880f815

update login endpoint response

view details

push time in 13 days

issue closedcomposer/composer

Timeout occurs when trying to download package using composer 2

My composer.json:

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        },
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        },
        {
            "type": "package",
            "package": {
                "name": "jaypan/jquery_colorpicker",
                "version": "master",
                "dist": {
                    "url": "https://www.eyecon.ro/colorpicker/colorpicker.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/font",
                "version": "4.13.1",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/font/releases/font_4.13.1.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/lineheight",
                "version": "1.0.4",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/lineheight/releases/lineheight_1.0.4.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/indent",
                "version": "4.11.4",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/indent/releases/indent_4.11.4.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/indentblock",
                "version": "4.11.4",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/indentblock/releases/indentblock_4.11.4.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/font",
                "version": "4.13.1",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/font/releases/font_4.13.1.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
              "name": "ckeditor/dialogadvtab",
              "version": "4.8.0",
              "type": "drupal-library",
              "extra": {
                "installer-name": "ckeditor/plugins/dialogadvtab"
                },
              "dist": {
                "url": "https://download.ckeditor.com/dialogadvtab/releases/dialogadvtab_4.8.0.zip",
                "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "vakata/jstree",
                "version": "3.3.10",
                "type": "drupal-library",
                "dist": {
                    "url": "https://github.com/vakata/jstree/archive/3.3.10.zip",
                    "type": "zip"
                }
            }
        }
    ],
    "require": {
        "php": ">=7.3",
        "acquia/lightning": "^4.1",
        "bower-asset/jquery-simple-color": "1.2.2",
        "bower-asset/spectrum": "1.8.0",
        "ckeditor-plugin/font": "4.13.1",
        "ckeditor-plugin/indent": "4.11.4",
        "ckeditor-plugin/indentblock": "4.11.4",
        "ckeditor-plugin/lineheight": "1.0.4",
        "ckeditor/dialogadvtab": "4.8.0",
        "composer/installers": "1.9.0",
        "cweagans/composer-patches": "1.6.7",
        "drupal-composer/drupal-scaffold": "2.6.1",
        "drupal-pattern-lab/attach-library-twig-extension": "1.1.0",
        "drupal-pattern-lab/bem-twig-extension": "1.0.1",
        "drupal-pattern-lab/unified-twig-extensions": "0.1.0",
        "drupal/addtoany": "1.12.0",
        "drupal/admin_toolbar": "^2.3",
        "drupal/anchor_link": "1.6.0",
        "drupal/autosave_form": "1.1.0",
        "drupal/better_exposed_filters": "^4.0@alpha",
        "drupal/better_links": "1.0.0",
        "drupal/block_blacklist": "1.1.0",
        "drupal/blocktabs": "^1.0.0-beta3@beta",
        "drupal/cdn": "3.5.0",
        "drupal/ckeditor_advanced_tab": "1.0.0-rc3",
        "drupal/ckeditor_config": "2.3.0",
        "drupal/ckeditor_font": "1.1.0",
        "drupal/ckeditor_indentblock": "^1.0.0-beta2@beta",
        "drupal/ckeditor_lineheight": "1.1.0",
        "drupal/color_field": "2.3.0",
        "drupal/components": "1.1.0",
        "drupal/config_ignore": "2.2.0",
        "drupal/config_split": "1.4.0",
        "drupal/console": "1.9.4",
        "drupal/content_lock": "2.1.0",
        "drupal/copyright_block": "^1.0.0-rc3@RC",
        "drupal/cshs": "^1.2.0@beta",
        "drupal/devel": "2.1.0",
        "drupal/disqus": "^1.0@RC",
        "drupal/dropzonejs": "2.x-dev",
        "drupal/editor_advanced_link": "1.8.0",
        "drupal/entity_browser": "2.5.0",
        "drupal/entity_browser_block": "1.1.0",
        "drupal/entity_clone_entity_browser_block": "^1.0@beta",
        "drupal/entity_embed": "^1.0",
        "drupal/environment_indicator": "3.7.0",
        "drupal/eu_cookie_compliance": "1.9.0",
        "drupal/facebook_pixel": "^1.0.0-alpha4@alpha",
        "drupal/facets": "1.5.0",
        "drupal/field_group": "^3.1",
        "drupal/google_tag": "1.4.0",
        "drupal/header_and_footer_scripts": "2.2.0",
        "drupal/hotjar": "2.0-rc4",
        "drupal/hubspot_embed": "^1.0@RC",
        "drupal/hubspot_forms": "1.6.0",
        "drupal/jquery_colorpicker": "^2.0",
        "drupal/lightning_core": "5.2",
        "drupal/lightning_media": "^4.2",
        "drupal/linkedin_insights_tag": "1.0.0",
        "drupal/media_directories": "^2.0",
        "drupal/migrate_file": "1.1.0",
        "drupal/migrate_plus": "5.1.0",
        "drupal/migrate_tools": "4.5.0",
        "drupal/multiple_fields_remove_button": "^1.0@alpha",
        "drupal/node_read_time": "^1.2",
        "drupal/openapi_rest": "^2.0@RC",
        "drupal/paragraphs": "1.12.0",
        "drupal/paragraphs_features": "^1.11",
        "drupal/path_redirect_import": "^1.0@beta",
        "drupal/preview_link": "1.7.0",
        "drupal/publication_date": "^2.0@beta",
        "drupal/quick_node_clone": "1.12.0",
        "drupal/quicklink": "^1.3",
        "drupal/redirect": "1.6.0",
        "drupal/redis": "1.4.0",
        "drupal/response_code_condition": "1.0.0",
        "drupal/s3fs": "^3.0@alpha",
        "drupal/search_api_solr": "^4.1",
        "drupal/shield": "^1.4",
        "drupal/simple_sitemap": "^3.7",
        "drupal/slick": "^2.2",
        "drupal/slick_views": "2.3.0",
        "drupal/social_media_links_field": "2.6.0",
        "drupal/stage_file_proxy": "^1.0",
        "drupal/twig_field_value": "1.2.0",
        "drupal/twig_tweak": "2.6.0",
        "drupal/video_embed_field": "^2.0",
        "drupal/views_data_export": "^1.0@beta",
        "drupal/views_infinite_scroll": "^1.6",
        "drupal/views_slideshow": "4.7.0",
        "drupal/views_slideshow_cycle2": "1.x-dev",
        "drupal/yoast_seo": "^1.5",
        "drush/drush": "9.7.2",
        "mnsami/composer-custom-directory-installer": "1.1.1",
        "npm-asset/slick-slider": "1.8.2",
        "oomphinc/composer-installers-extender": "1.1.2",
        "platformsh/config-reader": "2.3.1",
        "symfony/event-dispatcher": "4.3.4 as 3.4.99",
        "vakata/jstree": "3.3.10",
        "vlucas/phpdotenv": "2.6.1",
        "webflo/drupal-finder": "1.2.0",
        "webmozart/path-util": "2.3.0",
        "zaporylie/composer-drupal-optimizations": "1.1.1"
    },
    "require-dev": {
        "axelerant/db-docker": "^1.0@beta",
        "axelerant/drupal-quality-checker": "^1.0",
        "friendsoftwig/twigcs": "^3.2",
        "squizlabs/php_codesniffer": "3.5.5"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ],
        "files": ["load.environment.php"]
    },
    "scripts": {
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles",
            "bash post-install.sh"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles",
            "bash post-install.sh"
        ]
    },
    "extra": {
        "enable-patching": true,
        "patches": {
            "drupal/lightning_media": {
                "Lightning Media bulk Media Upload should have option target media type": "web/modules/patch/lighting_media_bulk_upload.patch",
                "ligtning media Widget and entity browser not working with S3FS drupal 8": "https://www.drupal.org/files/issues/2020-08-20/3075986-14.patch"
            },
            "drupal/preview_link": {
                "Provide settings form for managing configuration with UI[https://www.drupal.org/project/preview_link/issues/3156692]": "https://www.drupal.org/files/issues/2020-09-27/preview-link-configure-expiry-days.patch"
            },
            "drupal/entity_browser": {
                "Entity browser file widget selection lost in paragraph when adding another paragraph[https://www.drupal.org/project/entity_browser/issues/2851580]": "https://www.drupal.org/files/issues/2020-06-05/2851580-88.patch"
            },
            "drupal/content_lock": {
                "Content Lock - Added content level lock, fixed Unlock button placement, Removed form operation condition breaking lock, Added lock message on layout page": "web/modules/patch/content-lock-custom.patch"
            },
            "drupal/paragraphs": {
                "Integrity constraint violation: 1048 Column 'langcode' cannot be null[https://www.drupal.org/project/paragraphs/issues/2901390]": "https://www.drupal.org/files/issues/2019-08-10/paragraphs-set_langcode_widgets-290139_updated.patch"
            },
            "drupal/disqus": {
                "Disqus migrate support is broken[https://www.drupal.org/project/disqus/issues/2879592]": "https://www.drupal.org/files/issues/disqus-migrate-support-2879592-14.patch"
            },
            "drupal/social_media_links": {
                "Mailto: Need to add Subject and Body values[https://www.drupal.org/project/social_media_links/issues/3102897]": "https://www.drupal.org/files/issues/2019-12-25/social_media_links_3102897.patch"
            },
            "drupal/core": {
                "Notice: Undefined property:[https://www.drupal.org/project/drupal/issues/3155815]": "https://www.drupal.org/files/issues/2020-06-30/Undefined_property_3155815.patch",
                "Undefined index: #parents FormState.php[https://www.drupal.org/project/drupal/issues/3027240]": "https://www.drupal.org/files/issues/2019-08-31/3027240-12.patch",
                "Notice: Undefined index: #type in processStates()[https://www.drupal.org/project/drupal/issues/2700667]": "https://www.drupal.org/files/issues/2020-03-11/2700667-104.patch",
                "'Negate' form value for condition plugins should be cast to boolean in validation.[https://www.drupal.org/project/drupal/issues/3114467]": "https://www.drupal.org/files/issues/2020-03-23/3114467-8.patch",
                "Argument 2 passed to Drupal\\jsonapi\\Routing\\Routes::Drupal\\jsonapi\\Routing\\{closure}()[https://www.drupal.org/project/drupal/issues/2996114]": "https://www.drupal.org/files/issues/2020-06-06/2996114-141.patch"
            },
            "drupal/block_blacklist": {
                "Error: Call to a member function label() on null[https://www.drupal.org/project/block_blacklist/issues/3168243]": "https://www.drupal.org/files/issues/2020-08-31/block_blacklist_3168243.patch"
            },
            "drupal/s3fs": {
                "Provide a module for serving agregated CSS and JSS from local public filesystem": "https://www.drupal.org/files/issues/2020-09-23/s3fs-serve-css-js-from-local-filesystem-3081756-5.patch"
            },
            "drupal/hotjar": {
                "Provide dynamic file stream wrapper validation on config form validation": "https://www.drupal.org/files/issues/2020-09-24/provide-dynamic-file-stream-wrapper-3172869-2.patch"
            }

        },
        "composer-exit-on-patch-failure": true,
        "patchLevel": {
            "drupal/core": "-p2"
        },
        "installer-types": [
            "npm-asset",
            "bower-asset"
        ],
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/ckeditor/plugins/{$name}": ["vendor:ckeditor-plugin"],
            "web/libraries/{$name}": [
                "type:bower-asset",
                "type:npm-asset",
                "type:drupal-library",
                "jaypan/jquery_colorpicker"
            ],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/Commands/{$name}": ["type:drupal-drush"]
        },
        "drupal-scaffold": {
            "initial": {
                ".editorconfig": "../.editorconfig",
                ".gitattributes": "../.gitattributes"
            }
        }
    }
}

Output of composer diagnose:

The "cweagans/composer-patches" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match yo
ur Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "oomphinc/composer-installers-extender" plugin was skipped because it requires a Plugin API version ("^1.0") that does
not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "drupal/console-extend-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match
 your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "zaporylie/composer-drupal-optimizations" plugin was skipped because it requires a Plugin API version ("^1.1") that doe
s not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "drupal-composer/drupal-scaffold" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not
match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "mnsami/composer-custom-directory-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that
does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "hirak/prestissimo" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not match your Com
poser installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Checking composer.json: WARNING
require.bower-asset/jquery-simple-color : exact version constraints (1.2.2) should be avoided if the package follows semant
ic versioning
require.bower-asset/spectrum : exact version constraints (1.8.0) should be avoided if the package follows semantic versioni
ng
require.ckeditor-plugin/font : exact version constraints (4.13.1) should be avoided if the package follows semantic version
ing
require.ckeditor-plugin/indent : exact version constraints (4.11.4) should be avoided if the package follows semantic versi
oning
require.ckeditor-plugin/indentblock : exact version constraints (4.11.4) should be avoided if the package follows semantic
versioning
require.ckeditor-plugin/lineheight : exact version constraints (1.0.4) should be avoided if the package follows semantic ve
rsioning
require.ckeditor/dialogadvtab : exact version constraints (4.8.0) should be avoided if the package follows semantic version
ing
require.composer/installers : exact version constraints (1.9.0) should be avoided if the package follows semantic versionin
g
require.cweagans/composer-patches : exact version constraints (1.6.7) should be avoided if the package follows semantic ver
sioning
require.drupal-composer/drupal-scaffold : exact version constraints (2.6.1) should be avoided if the package follows semant
ic versioning
require.drupal-pattern-lab/attach-library-twig-extension : exact version constraints (1.1.0) should be avoided if the packa
ge follows semantic versioning
require.drupal-pattern-lab/bem-twig-extension : exact version constraints (1.0.1) should be avoided if the package follows
semantic versioning
require.drupal/addtoany : exact version constraints (1.12.0) should be avoided if the package follows semantic versioning
require.drupal/anchor_link : exact version constraints (1.6.0) should be avoided if the package follows semantic versioning
require.drupal/autosave_form : exact version constraints (1.1.0) should be avoided if the package follows semantic versioni
ng
require.drupal/better_links : exact version constraints (1.0.0) should be avoided if the package follows semantic versionin
g
require.drupal/block_blacklist : exact version constraints (1.1.0) should be avoided if the package follows semantic versio
ning
require.drupal/cdn : exact version constraints (3.5.0) should be avoided if the package follows semantic versioning
require.drupal/ckeditor_advanced_tab : exact version constraints (1.0.0-rc3) should be avoided if the package follows semantic versioning
require.drupal/ckeditor_config : exact version constraints (2.3.0) should be avoided if the package follows semantic versio
ning
require.drupal/ckeditor_font : exact version constraints (1.1.0) should be avoided if the package follows semantic versioni
ng
require.drupal/ckeditor_lineheight : exact version constraints (1.1.0) should be avoided if the package follows semantic ve
rsioning
require.drupal/color_field : exact version constraints (2.3.0) should be avoided if the package follows semantic versioning
require.drupal/components : exact version constraints (1.1.0) should be avoided if the package follows semantic versioning
require.drupal/config_ignore : exact version constraints (2.2.0) should be avoided if the package follows semantic versioni
ng
require.drupal/config_split : exact version constraints (1.4.0) should be avoided if the package follows semantic versionin
g
require.drupal/console : exact version constraints (1.9.4) should be avoided if the package follows semantic versioning
require.drupal/content_lock : exact version constraints (2.1.0) should be avoided if the package follows semantic versionin
g
require.drupal/devel : exact version constraints (2.1.0) should be avoided if the package follows semantic versioning
require.drupal/dropzonejs : exact version constraints (2.x-dev) should be avoided if the package follows semantic versionin
g
require.drupal/editor_advanced_link : exact version constraints (1.8.0) should be avoided if the package follows semantic v
ersioning
require.drupal/entity_browser : exact version constraints (2.5.0) should be avoided if the package follows semantic version
ing
require.drupal/entity_browser_block : exact version constraints (1.1.0) should be avoided if the package follows semantic v
ersioning
require.drupal/environment_indicator : exact version constraints (3.7.0) should be avoided if the package follows semantic versioning
require.drupal/eu_cookie_compliance : exact version constraints (1.9.0) should be avoided if the package follows semantic v
ersioning
require.drupal/facets : exact version constraints (1.5.0) should be avoided if the package follows semantic versioning
require.drupal/google_tag : exact version constraints (1.4.0) should be avoided if the package follows semantic versioning
require.drupal/header_and_footer_scripts : exact version constraints (2.2.0) should be avoided if the package follows seman
tic versioning
require.drupal/hotjar : exact version constraints (2.0-rc4) should be avoided if the package follows semantic versioning
require.drupal/hubspot_forms : exact version constraints (1.6.0) should be avoided if the package follows semantic versioni
ng
require.drupal/lightning_core : exact version constraints (5.2) should be avoided if the package follows semantic versionin
g
require.drupal/linkedin_insights_tag : exact version constraints (1.0.0) should be avoided if the package follows semantic
versioning
require.drupal/migrate_file : exact version constraints (1.1.0) should be avoided if the package follows semantic versionin
g
require.drupal/migrate_plus : exact version constraints (5.1.0) should be avoided if the package follows semantic versionin
g
require.drupal/migrate_tools : exact version constraints (4.5.0) should be avoided if the package follows semantic versioni
ng
require.drupal/paragraphs : exact version constraints (1.12.0) should be avoided if the package follows semantic versioning
require.drupal/preview_link : exact version constraints (1.7.0) should be avoided if the package follows semantic versionin
g
require.drupal/quick_node_clone : exact version constraints (1.12.0) should be avoided if the package follows semantic vers
ioning
require.drupal/redirect : exact version constraints (1.6.0) should be avoided if the package follows semantic versioning
require.drupal/redis : exact version constraints (1.4.0) should be avoided if the package follows semantic versioning
require.drupal/response_code_condition : exact version constraints (1.0.0) should be avoided if the package follows semanti
c versioning
require.drupal/slick_views : exact version constraints (2.3.0) should be avoided if the package follows semantic versioning
require.drupal/social_media_links_field : exact version constraints (2.6.0) should be avoided if the package follows semant
ic versioning
require.drupal/twig_field_value : exact version constraints (1.2.0) should be avoided if the package follows semantic versi
oning
require.drupal/twig_tweak : exact version constraints (2.6.0) should be avoided if the package follows semantic versioning
require.drupal/views_slideshow : exact version constraints (4.7.0) should be avoided if the package follows semantic versio
ning
require.drupal/views_slideshow_cycle2 : exact version constraints (1.x-dev) should be avoided if the package follows semant
ic versioning
require.drush/drush : exact version constraints (9.7.2) should be avoided if the package follows semantic versioning
require.mnsami/composer-custom-directory-installer : exact version constraints (1.1.1) should be avoided if the package fol
lows semantic versioning
require.npm-asset/slick-slider : exact version constraints (1.8.2) should be avoided if the package follows semantic versio
ning
require.oomphinc/composer-installers-extender : exact version constraints (1.1.2) should be avoided if the package follows semantic versioning
require.platformsh/config-reader : exact version constraints (2.3.1) should be avoided if the package follows semantic versioning
require.symfony/event-dispatcher : exact version constraints (4.3.4 as 3.4.99) should be avoided if the package follows semantic versioning
require.vakata/jstree : exact version constraints (3.3.10) should be avoided if the package follows semantic versioning
require.vlucas/phpdotenv : exact version constraints (2.6.1) should be avoided if the package follows semantic versioning
require.webflo/drupal-finder : exact version constraints (1.2.0) should be avoided if the package follows semantic versioning
require.webmozart/path-util : exact version constraints (2.3.0) should be avoided if the package follows semantic versioning
require.zaporylie/composer-drupal-optimizations : exact version constraints (1.1.1) should be avoided if the package follows semantic versioning
Checking platform settings: OK
Checking git settings: OK
Checking http connectivity to packagist: OK
Checking https connectivity to packagist: OK
Checking github.com rate limit: OK
Checking disk free space: OK
Checking pubkeys:
Tags Public Key Fingerprint: 57815BA2 7E54DC31 7ECC7CC5 573090D0  87719BA6 8F3BB723 4E5D42D0 84A14642
Dev Public Key Fingerprint: 4AC45767 E5EC2265 2F0C1167 CBBB8A2B  0C708369 153E328C AD90147D AFE50952
OK
Checking composer version: OK
Composer version: 2.0.0-RC1
PHP version: 7.3.23
PHP binary path: /usr/local/bin/php
OpenSSL version: OpenSSL 1.1.0l  10 Sep 2019

When I run this command:

composer require "cweagans/composer-patches:^1.7" -vvv

I get the following output:

Loading config file ./composer.json
Checked CA file /etc/ssl/certs/ca-certificates.crt: valid
Executing command (/app): git branch --no-color --no-abbrev -v
Executing command (/app): git rev-list master..AXLPORTAL-1815-composer2
Executing command (/app): git rev-list develop..AXLPORTAL-1815-composer2
Reading /var/www/.composer/composer.json
Loading config file /var/www/.composer/composer.json
Reading /app/vendor/composer/installed.json
Reading /var/www/.composer/vendor/composer/installed.json
Loading plugin Composer\Installers\Plugin
The "cweagans/composer-patches" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match yo
ur Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "oomphinc/composer-installers-extender" plugin was skipped because it requires a Plugin API version ("^1.0") that does
not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading plugin Dealerdirect\Composer\Plugin\Installers\PHPCodeSniffer\Plugin
The "drupal/console-extend-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match
 your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading plugin GrumPHP\Composer\GrumPHPPlugin
The "zaporylie/composer-drupal-optimizations" plugin was skipped because it requires a Plugin API version ("^1.1") that doe
s not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading plugin Axelerant\DbDocker\Plugin
The "drupal-composer/drupal-scaffold" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not
match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "mnsami/composer-custom-directory-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that
does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "hirak/prestissimo" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not match your Com
poser installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Running 2.0.0-RC1 (2020-09-10 15:39:45) with PHP 7.3.23 on Linux / 4.19.76-linuxkit
Downloading https://packages.drupal.org/8/packages.json
[200] https://packages.drupal.org/8/packages.json
Writing /var/www/.composer/cache/repo/https---packages.drupal.org-8/packages.json into cache
Downloading https://asset-packagist.org/packages.json
[200] https://asset-packagist.org/packages.json
Writing /var/www/.composer/cache/repo/https---asset-packagist.org/packages.json into cache
Downloading https://asset-packagist.org/p/provider-latest/6f7c208a3f09d46049c69af2a1a28f5a9a0766abc8aed6f1295c2159de83e0ef.
json
Downloading https://asset-packagist.org/p/provider-latest/6f7c208a3f09d46049c69af2a1a28f5a9a0766abc8aed6f1295c2159de83e0ef.
json
Downloading https://asset-packagist.org/p/provider-latest/6f7c208a3f09d46049c69af2a1a28f5a9a0766abc8aed6f1295c2159de83e0ef.
json


  [Composer\Downloader\TransportException]
  Operation timed out after 60001 milliseconds with 1539849 out of 5969934 bytes received

Exception trace:
 () at phar:///usr/local/bin/composer/src/Composer/Util/Http/CurlDownloader.php:276
 Composer\Util\Http\CurlDownloader->tick() at phar:///usr/local/bin/composer/src/Composer/Util/HttpDownloader.php:307
 Composer\Util\HttpDownloader->countActiveJobs() at phar:///usr/local/bin/composer/src/Composer/Util/HttpDownloader.php:275
 Composer\Util\HttpDownloader->wait() at phar:///usr/local/bin/composer/src/Composer/Util/HttpDownloader.php:85
 Composer\Util\HttpDownloader->get() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:1071
 Composer\Repository\ComposerRepository->fetchFile() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:971
 Composer\Repository\ComposerRepository->loadProviderListings() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:542
 Composer\Repository\ComposerRepository->whatProvides() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:365
 Composer\Repository\ComposerRepository->loadPackages() at phar:///usr/local/bin/composer/src/Composer/Repository/RepositorySet.php:170
 Composer\Repository\RepositorySet->findPackages() at phar:///usr/local/bin/composer/src/Composer/Package/Version/VersionSelector.php:71
 Composer\Package\Version\VersionSelector->findBestCandidate() at phar:///usr/local/bin/composer/src/Composer/Command/InitCommand.php:735
 Composer\Command\InitCommand->findBestVersionAndNameForPackage() at phar:///usr/local/bin/composer/src/Composer/Command/InitCommand.php:437
 Composer\Command\InitCommand->determineRequirements() at phar:///usr/local/bin/composer/src/Composer/Command/RequireCommand.php:188
 Composer\Command\RequireCommand->execute() at phar:///usr/local/bin/composer/vendor/symfony/console/Command/Command.php:245
 Symfony\Component\Console\Command\Command->run() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:835
 Symfony\Component\Console\Application->doRunCommand() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:185
 Symfony\Component\Console\Application->doRun() at phar:///usr/local/bin/composer/src/Composer/Console/Application.php:309
 Composer\Console\Application->doRun() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:117
 Symfony\Component\Console\Application->run() at phar:///usr/local/bin/composer/src/Composer/Console/Application.php:121
 Composer\Console\Application->run() at phar:///usr/local/bin/composer/bin/composer:61
 require() at /usr/local/bin/composer:24

require [--dev] [--dry-run] [--prefer-source] [--prefer-dist] [--fixed] [--no-suggest] [--no-progress] [--no-update] [--no-
install] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--with-dependencie
s] [--with-all-dependencies] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--prefer-stable] [--pref
er-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]
...

And I expected this to happen:

The command should have execeuted successfully.


The Linux workaround suggested here https://getcomposer.org/doc/articles/troubleshooting.md#operation-timed-out-ipv6-issues- didn't work.

closed time in 14 days

subhojit777

issue commentcomposer/composer

Timeout occurs when trying to download package using composer 2

I see that the problem is with slow network. I now noticed that 4.6MB out of 6 got downloaded - after the timeout increase.

subhojit777

comment created time in 14 days

issue openedcomposer/composer

Timeout occurs when trying to download package using composer 2

My composer.json:

{
    "name": "drupal-composer/drupal-project",
    "description": "Project template for Drupal 8 projects with composer",
    "type": "project",
    "license": "GPL-2.0-or-later",
    "authors": [
        {
            "name": "",
            "role": ""
        }
    ],
    "repositories": [
        {
            "type": "composer",
            "url": "https://packages.drupal.org/8"
        },
        {
            "type": "composer",
            "url": "https://asset-packagist.org"
        },
        {
            "type": "package",
            "package": {
                "name": "jaypan/jquery_colorpicker",
                "version": "master",
                "dist": {
                    "url": "https://www.eyecon.ro/colorpicker/colorpicker.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/font",
                "version": "4.13.1",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/font/releases/font_4.13.1.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/lineheight",
                "version": "1.0.4",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/lineheight/releases/lineheight_1.0.4.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/indent",
                "version": "4.11.4",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/indent/releases/indent_4.11.4.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/indentblock",
                "version": "4.11.4",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/indentblock/releases/indentblock_4.11.4.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "ckeditor-plugin/font",
                "version": "4.13.1",
                "type": "drupal-library",
                "dist": {
                    "url": "https://download.ckeditor.com/font/releases/font_4.13.1.zip",
                    "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
              "name": "ckeditor/dialogadvtab",
              "version": "4.8.0",
              "type": "drupal-library",
              "extra": {
                "installer-name": "ckeditor/plugins/dialogadvtab"
                },
              "dist": {
                "url": "https://download.ckeditor.com/dialogadvtab/releases/dialogadvtab_4.8.0.zip",
                "type": "zip"
                }
            }
        },
        {
            "type": "package",
            "package": {
                "name": "vakata/jstree",
                "version": "3.3.10",
                "type": "drupal-library",
                "dist": {
                    "url": "https://github.com/vakata/jstree/archive/3.3.10.zip",
                    "type": "zip"
                }
            }
        }
    ],
    "require": {
        "php": ">=7.3",
        "acquia/lightning": "^4.1",
        "bower-asset/jquery-simple-color": "1.2.2",
        "bower-asset/spectrum": "1.8.0",
        "ckeditor-plugin/font": "4.13.1",
        "ckeditor-plugin/indent": "4.11.4",
        "ckeditor-plugin/indentblock": "4.11.4",
        "ckeditor-plugin/lineheight": "1.0.4",
        "ckeditor/dialogadvtab": "4.8.0",
        "composer/installers": "1.9.0",
        "cweagans/composer-patches": "1.6.7",
        "drupal-composer/drupal-scaffold": "2.6.1",
        "drupal-pattern-lab/attach-library-twig-extension": "1.1.0",
        "drupal-pattern-lab/bem-twig-extension": "1.0.1",
        "drupal-pattern-lab/unified-twig-extensions": "0.1.0",
        "drupal/addtoany": "1.12.0",
        "drupal/admin_toolbar": "^2.3",
        "drupal/anchor_link": "1.6.0",
        "drupal/autosave_form": "1.1.0",
        "drupal/better_exposed_filters": "^4.0@alpha",
        "drupal/better_links": "1.0.0",
        "drupal/block_blacklist": "1.1.0",
        "drupal/blocktabs": "^1.0.0-beta3@beta",
        "drupal/cdn": "3.5.0",
        "drupal/ckeditor_advanced_tab": "1.0.0-rc3",
        "drupal/ckeditor_config": "2.3.0",
        "drupal/ckeditor_font": "1.1.0",
        "drupal/ckeditor_indentblock": "^1.0.0-beta2@beta",
        "drupal/ckeditor_lineheight": "1.1.0",
        "drupal/color_field": "2.3.0",
        "drupal/components": "1.1.0",
        "drupal/config_ignore": "2.2.0",
        "drupal/config_split": "1.4.0",
        "drupal/console": "1.9.4",
        "drupal/content_lock": "2.1.0",
        "drupal/copyright_block": "^1.0.0-rc3@RC",
        "drupal/cshs": "^1.2.0@beta",
        "drupal/devel": "2.1.0",
        "drupal/disqus": "^1.0@RC",
        "drupal/dropzonejs": "2.x-dev",
        "drupal/editor_advanced_link": "1.8.0",
        "drupal/entity_browser": "2.5.0",
        "drupal/entity_browser_block": "1.1.0",
        "drupal/entity_clone_entity_browser_block": "^1.0@beta",
        "drupal/entity_embed": "^1.0",
        "drupal/environment_indicator": "3.7.0",
        "drupal/eu_cookie_compliance": "1.9.0",
        "drupal/facebook_pixel": "^1.0.0-alpha4@alpha",
        "drupal/facets": "1.5.0",
        "drupal/field_group": "^3.1",
        "drupal/google_tag": "1.4.0",
        "drupal/header_and_footer_scripts": "2.2.0",
        "drupal/hotjar": "2.0-rc4",
        "drupal/hubspot_embed": "^1.0@RC",
        "drupal/hubspot_forms": "1.6.0",
        "drupal/jquery_colorpicker": "^2.0",
        "drupal/lightning_core": "5.2",
        "drupal/lightning_media": "^4.2",
        "drupal/linkedin_insights_tag": "1.0.0",
        "drupal/media_directories": "^2.0",
        "drupal/migrate_file": "1.1.0",
        "drupal/migrate_plus": "5.1.0",
        "drupal/migrate_tools": "4.5.0",
        "drupal/multiple_fields_remove_button": "^1.0@alpha",
        "drupal/node_read_time": "^1.2",
        "drupal/openapi_rest": "^2.0@RC",
        "drupal/paragraphs": "1.12.0",
        "drupal/paragraphs_features": "^1.11",
        "drupal/path_redirect_import": "^1.0@beta",
        "drupal/preview_link": "1.7.0",
        "drupal/publication_date": "^2.0@beta",
        "drupal/quick_node_clone": "1.12.0",
        "drupal/quicklink": "^1.3",
        "drupal/redirect": "1.6.0",
        "drupal/redis": "1.4.0",
        "drupal/response_code_condition": "1.0.0",
        "drupal/s3fs": "^3.0@alpha",
        "drupal/search_api_solr": "^4.1",
        "drupal/shield": "^1.4",
        "drupal/simple_sitemap": "^3.7",
        "drupal/slick": "^2.2",
        "drupal/slick_views": "2.3.0",
        "drupal/social_media_links_field": "2.6.0",
        "drupal/stage_file_proxy": "^1.0",
        "drupal/twig_field_value": "1.2.0",
        "drupal/twig_tweak": "2.6.0",
        "drupal/video_embed_field": "^2.0",
        "drupal/views_data_export": "^1.0@beta",
        "drupal/views_infinite_scroll": "^1.6",
        "drupal/views_slideshow": "4.7.0",
        "drupal/views_slideshow_cycle2": "1.x-dev",
        "drupal/yoast_seo": "^1.5",
        "drush/drush": "9.7.2",
        "mnsami/composer-custom-directory-installer": "1.1.1",
        "npm-asset/slick-slider": "1.8.2",
        "oomphinc/composer-installers-extender": "1.1.2",
        "platformsh/config-reader": "2.3.1",
        "symfony/event-dispatcher": "4.3.4 as 3.4.99",
        "vakata/jstree": "3.3.10",
        "vlucas/phpdotenv": "2.6.1",
        "webflo/drupal-finder": "1.2.0",
        "webmozart/path-util": "2.3.0",
        "zaporylie/composer-drupal-optimizations": "1.1.1"
    },
    "require-dev": {
        "axelerant/db-docker": "^1.0@beta",
        "axelerant/drupal-quality-checker": "^1.0",
        "friendsoftwig/twigcs": "^3.2",
        "squizlabs/php_codesniffer": "3.5.5"
    },
    "conflict": {
        "drupal/drupal": "*"
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "config": {
        "sort-packages": true
    },
    "autoload": {
        "classmap": [
            "scripts/composer/ScriptHandler.php"
        ],
        "files": ["load.environment.php"]
    },
    "scripts": {
        "pre-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "pre-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
        ],
        "post-install-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles",
            "bash post-install.sh"
        ],
        "post-update-cmd": [
            "DrupalProject\\composer\\ScriptHandler::createRequiredFiles",
            "bash post-install.sh"
        ]
    },
    "extra": {
        "enable-patching": true,
        "patches": {
            "drupal/lightning_media": {
                "Lightning Media bulk Media Upload should have option target media type": "web/modules/patch/lighting_media_bulk_upload.patch",
                "ligtning media Widget and entity browser not working with S3FS drupal 8": "https://www.drupal.org/files/issues/2020-08-20/3075986-14.patch"
            },
            "drupal/preview_link": {
                "Provide settings form for managing configuration with UI[https://www.drupal.org/project/preview_link/issues/3156692]": "https://www.drupal.org/files/issues/2020-09-27/preview-link-configure-expiry-days.patch"
            },
            "drupal/entity_browser": {
                "Entity browser file widget selection lost in paragraph when adding another paragraph[https://www.drupal.org/project/entity_browser/issues/2851580]": "https://www.drupal.org/files/issues/2020-06-05/2851580-88.patch"
            },
            "drupal/content_lock": {
                "Content Lock - Added content level lock, fixed Unlock button placement, Removed form operation condition breaking lock, Added lock message on layout page": "web/modules/patch/content-lock-custom.patch"
            },
            "drupal/paragraphs": {
                "Integrity constraint violation: 1048 Column 'langcode' cannot be null[https://www.drupal.org/project/paragraphs/issues/2901390]": "https://www.drupal.org/files/issues/2019-08-10/paragraphs-set_langcode_widgets-290139_updated.patch"
            },
            "drupal/disqus": {
                "Disqus migrate support is broken[https://www.drupal.org/project/disqus/issues/2879592]": "https://www.drupal.org/files/issues/disqus-migrate-support-2879592-14.patch"
            },
            "drupal/social_media_links": {
                "Mailto: Need to add Subject and Body values[https://www.drupal.org/project/social_media_links/issues/3102897]": "https://www.drupal.org/files/issues/2019-12-25/social_media_links_3102897.patch"
            },
            "drupal/core": {
                "Notice: Undefined property:[https://www.drupal.org/project/drupal/issues/3155815]": "https://www.drupal.org/files/issues/2020-06-30/Undefined_property_3155815.patch",
                "Undefined index: #parents FormState.php[https://www.drupal.org/project/drupal/issues/3027240]": "https://www.drupal.org/files/issues/2019-08-31/3027240-12.patch",
                "Notice: Undefined index: #type in processStates()[https://www.drupal.org/project/drupal/issues/2700667]": "https://www.drupal.org/files/issues/2020-03-11/2700667-104.patch",
                "'Negate' form value for condition plugins should be cast to boolean in validation.[https://www.drupal.org/project/drupal/issues/3114467]": "https://www.drupal.org/files/issues/2020-03-23/3114467-8.patch",
                "Argument 2 passed to Drupal\\jsonapi\\Routing\\Routes::Drupal\\jsonapi\\Routing\\{closure}()[https://www.drupal.org/project/drupal/issues/2996114]": "https://www.drupal.org/files/issues/2020-06-06/2996114-141.patch"
            },
            "drupal/block_blacklist": {
                "Error: Call to a member function label() on null[https://www.drupal.org/project/block_blacklist/issues/3168243]": "https://www.drupal.org/files/issues/2020-08-31/block_blacklist_3168243.patch"
            },
            "drupal/s3fs": {
                "Provide a module for serving agregated CSS and JSS from local public filesystem": "https://www.drupal.org/files/issues/2020-09-23/s3fs-serve-css-js-from-local-filesystem-3081756-5.patch"
            },
            "drupal/hotjar": {
                "Provide dynamic file stream wrapper validation on config form validation": "https://www.drupal.org/files/issues/2020-09-24/provide-dynamic-file-stream-wrapper-3172869-2.patch"
            }

        },
        "composer-exit-on-patch-failure": true,
        "patchLevel": {
            "drupal/core": "-p2"
        },
        "installer-types": [
            "npm-asset",
            "bower-asset"
        ],
        "installer-paths": {
            "web/core": ["type:drupal-core"],
            "web/libraries/ckeditor/plugins/{$name}": ["vendor:ckeditor-plugin"],
            "web/libraries/{$name}": [
                "type:bower-asset",
                "type:npm-asset",
                "type:drupal-library",
                "jaypan/jquery_colorpicker"
            ],
            "web/modules/contrib/{$name}": ["type:drupal-module"],
            "web/profiles/contrib/{$name}": ["type:drupal-profile"],
            "web/themes/contrib/{$name}": ["type:drupal-theme"],
            "drush/Commands/{$name}": ["type:drupal-drush"]
        },
        "drupal-scaffold": {
            "initial": {
                ".editorconfig": "../.editorconfig",
                ".gitattributes": "../.gitattributes"
            }
        }
    }
}

Output of composer diagnose:

The "cweagans/composer-patches" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match yo
ur Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "oomphinc/composer-installers-extender" plugin was skipped because it requires a Plugin API version ("^1.0") that does
not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "drupal/console-extend-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match
 your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "zaporylie/composer-drupal-optimizations" plugin was skipped because it requires a Plugin API version ("^1.1") that doe
s not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "drupal-composer/drupal-scaffold" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not
match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "mnsami/composer-custom-directory-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that
does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "hirak/prestissimo" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not match your Com
poser installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Checking composer.json: WARNING
require.bower-asset/jquery-simple-color : exact version constraints (1.2.2) should be avoided if the package follows semant
ic versioning
require.bower-asset/spectrum : exact version constraints (1.8.0) should be avoided if the package follows semantic versioni
ng
require.ckeditor-plugin/font : exact version constraints (4.13.1) should be avoided if the package follows semantic version
ing
require.ckeditor-plugin/indent : exact version constraints (4.11.4) should be avoided if the package follows semantic versi
oning
require.ckeditor-plugin/indentblock : exact version constraints (4.11.4) should be avoided if the package follows semantic
versioning
require.ckeditor-plugin/lineheight : exact version constraints (1.0.4) should be avoided if the package follows semantic ve
rsioning
require.ckeditor/dialogadvtab : exact version constraints (4.8.0) should be avoided if the package follows semantic version
ing
require.composer/installers : exact version constraints (1.9.0) should be avoided if the package follows semantic versionin
g
require.cweagans/composer-patches : exact version constraints (1.6.7) should be avoided if the package follows semantic ver
sioning
require.drupal-composer/drupal-scaffold : exact version constraints (2.6.1) should be avoided if the package follows semant
ic versioning
require.drupal-pattern-lab/attach-library-twig-extension : exact version constraints (1.1.0) should be avoided if the packa
ge follows semantic versioning
require.drupal-pattern-lab/bem-twig-extension : exact version constraints (1.0.1) should be avoided if the package follows
semantic versioning
require.drupal/addtoany : exact version constraints (1.12.0) should be avoided if the package follows semantic versioning
require.drupal/anchor_link : exact version constraints (1.6.0) should be avoided if the package follows semantic versioning
require.drupal/autosave_form : exact version constraints (1.1.0) should be avoided if the package follows semantic versioni
ng
require.drupal/better_links : exact version constraints (1.0.0) should be avoided if the package follows semantic versionin
g
require.drupal/block_blacklist : exact version constraints (1.1.0) should be avoided if the package follows semantic versio
ning
require.drupal/cdn : exact version constraints (3.5.0) should be avoided if the package follows semantic versioning
require.drupal/ckeditor_advanced_tab : exact version constraints (1.0.0-rc3) should be avoided if the package follows semantic versioning
require.drupal/ckeditor_config : exact version constraints (2.3.0) should be avoided if the package follows semantic versio
ning
require.drupal/ckeditor_font : exact version constraints (1.1.0) should be avoided if the package follows semantic versioni
ng
require.drupal/ckeditor_lineheight : exact version constraints (1.1.0) should be avoided if the package follows semantic ve
rsioning
require.drupal/color_field : exact version constraints (2.3.0) should be avoided if the package follows semantic versioning
require.drupal/components : exact version constraints (1.1.0) should be avoided if the package follows semantic versioning
require.drupal/config_ignore : exact version constraints (2.2.0) should be avoided if the package follows semantic versioni
ng
require.drupal/config_split : exact version constraints (1.4.0) should be avoided if the package follows semantic versionin
g
require.drupal/console : exact version constraints (1.9.4) should be avoided if the package follows semantic versioning
require.drupal/content_lock : exact version constraints (2.1.0) should be avoided if the package follows semantic versionin
g
require.drupal/devel : exact version constraints (2.1.0) should be avoided if the package follows semantic versioning
require.drupal/dropzonejs : exact version constraints (2.x-dev) should be avoided if the package follows semantic versionin
g
require.drupal/editor_advanced_link : exact version constraints (1.8.0) should be avoided if the package follows semantic v
ersioning
require.drupal/entity_browser : exact version constraints (2.5.0) should be avoided if the package follows semantic version
ing
require.drupal/entity_browser_block : exact version constraints (1.1.0) should be avoided if the package follows semantic v
ersioning
require.drupal/environment_indicator : exact version constraints (3.7.0) should be avoided if the package follows semantic versioning
require.drupal/eu_cookie_compliance : exact version constraints (1.9.0) should be avoided if the package follows semantic v
ersioning
require.drupal/facets : exact version constraints (1.5.0) should be avoided if the package follows semantic versioning
require.drupal/google_tag : exact version constraints (1.4.0) should be avoided if the package follows semantic versioning
require.drupal/header_and_footer_scripts : exact version constraints (2.2.0) should be avoided if the package follows seman
tic versioning
require.drupal/hotjar : exact version constraints (2.0-rc4) should be avoided if the package follows semantic versioning
require.drupal/hubspot_forms : exact version constraints (1.6.0) should be avoided if the package follows semantic versioni
ng
require.drupal/lightning_core : exact version constraints (5.2) should be avoided if the package follows semantic versionin
g
require.drupal/linkedin_insights_tag : exact version constraints (1.0.0) should be avoided if the package follows semantic
versioning
require.drupal/migrate_file : exact version constraints (1.1.0) should be avoided if the package follows semantic versionin
g
require.drupal/migrate_plus : exact version constraints (5.1.0) should be avoided if the package follows semantic versionin
g
require.drupal/migrate_tools : exact version constraints (4.5.0) should be avoided if the package follows semantic versioni
ng
require.drupal/paragraphs : exact version constraints (1.12.0) should be avoided if the package follows semantic versioning
require.drupal/preview_link : exact version constraints (1.7.0) should be avoided if the package follows semantic versionin
g
require.drupal/quick_node_clone : exact version constraints (1.12.0) should be avoided if the package follows semantic vers
ioning
require.drupal/redirect : exact version constraints (1.6.0) should be avoided if the package follows semantic versioning
require.drupal/redis : exact version constraints (1.4.0) should be avoided if the package follows semantic versioning
require.drupal/response_code_condition : exact version constraints (1.0.0) should be avoided if the package follows semanti
c versioning
require.drupal/slick_views : exact version constraints (2.3.0) should be avoided if the package follows semantic versioning
require.drupal/social_media_links_field : exact version constraints (2.6.0) should be avoided if the package follows semant
ic versioning
require.drupal/twig_field_value : exact version constraints (1.2.0) should be avoided if the package follows semantic versi
oning
require.drupal/twig_tweak : exact version constraints (2.6.0) should be avoided if the package follows semantic versioning
require.drupal/views_slideshow : exact version constraints (4.7.0) should be avoided if the package follows semantic versio
ning
require.drupal/views_slideshow_cycle2 : exact version constraints (1.x-dev) should be avoided if the package follows semant
ic versioning
require.drush/drush : exact version constraints (9.7.2) should be avoided if the package follows semantic versioning
require.mnsami/composer-custom-directory-installer : exact version constraints (1.1.1) should be avoided if the package fol
lows semantic versioning
require.npm-asset/slick-slider : exact version constraints (1.8.2) should be avoided if the package follows semantic versio
ning
require.oomphinc/composer-installers-extender : exact version constraints (1.1.2) should be avoided if the package follows semantic versioning
require.platformsh/config-reader : exact version constraints (2.3.1) should be avoided if the package follows semantic versioning
require.symfony/event-dispatcher : exact version constraints (4.3.4 as 3.4.99) should be avoided if the package follows semantic versioning
require.vakata/jstree : exact version constraints (3.3.10) should be avoided if the package follows semantic versioning
require.vlucas/phpdotenv : exact version constraints (2.6.1) should be avoided if the package follows semantic versioning
require.webflo/drupal-finder : exact version constraints (1.2.0) should be avoided if the package follows semantic versioning
require.webmozart/path-util : exact version constraints (2.3.0) should be avoided if the package follows semantic versioning
require.zaporylie/composer-drupal-optimizations : exact version constraints (1.1.1) should be avoided if the package follows semantic versioning
Checking platform settings: OK
Checking git settings: OK
Checking http connectivity to packagist: OK
Checking https connectivity to packagist: OK
Checking github.com rate limit: OK
Checking disk free space: OK
Checking pubkeys:
Tags Public Key Fingerprint: 57815BA2 7E54DC31 7ECC7CC5 573090D0  87719BA6 8F3BB723 4E5D42D0 84A14642
Dev Public Key Fingerprint: 4AC45767 E5EC2265 2F0C1167 CBBB8A2B  0C708369 153E328C AD90147D AFE50952
OK
Checking composer version: OK
Composer version: 2.0.0-RC1
PHP version: 7.3.23
PHP binary path: /usr/local/bin/php
OpenSSL version: OpenSSL 1.1.0l  10 Sep 2019

When I run this command:

composer require "cweagans/composer-patches:^1.7" -vvv

I get the following output:

Loading config file ./composer.json
Checked CA file /etc/ssl/certs/ca-certificates.crt: valid
Executing command (/app): git branch --no-color --no-abbrev -v
Executing command (/app): git rev-list master..AXLPORTAL-1815-composer2
Executing command (/app): git rev-list develop..AXLPORTAL-1815-composer2
Reading /var/www/.composer/composer.json
Loading config file /var/www/.composer/composer.json
Reading /app/vendor/composer/installed.json
Reading /var/www/.composer/vendor/composer/installed.json
Loading plugin Composer\Installers\Plugin
The "cweagans/composer-patches" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match yo
ur Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "oomphinc/composer-installers-extender" plugin was skipped because it requires a Plugin API version ("^1.0") that does
not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading plugin Dealerdirect\Composer\Plugin\Installers\PHPCodeSniffer\Plugin
The "drupal/console-extend-plugin" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match
 your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading plugin GrumPHP\Composer\GrumPHPPlugin
The "zaporylie/composer-drupal-optimizations" plugin was skipped because it requires a Plugin API version ("^1.1") that doe
s not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Loading plugin Axelerant\DbDocker\Plugin
The "drupal-composer/drupal-scaffold" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not
match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "mnsami/composer-custom-directory-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that
does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "hirak/prestissimo" plugin was skipped because it requires a Plugin API version ("^1.0.0") that does not match your Com
poser installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
Running 2.0.0-RC1 (2020-09-10 15:39:45) with PHP 7.3.23 on Linux / 4.19.76-linuxkit
Downloading https://packages.drupal.org/8/packages.json
[200] https://packages.drupal.org/8/packages.json
Writing /var/www/.composer/cache/repo/https---packages.drupal.org-8/packages.json into cache
Downloading https://asset-packagist.org/packages.json
[200] https://asset-packagist.org/packages.json
Writing /var/www/.composer/cache/repo/https---asset-packagist.org/packages.json into cache
Downloading https://asset-packagist.org/p/provider-latest/6f7c208a3f09d46049c69af2a1a28f5a9a0766abc8aed6f1295c2159de83e0ef.
json
Downloading https://asset-packagist.org/p/provider-latest/6f7c208a3f09d46049c69af2a1a28f5a9a0766abc8aed6f1295c2159de83e0ef.
json
Downloading https://asset-packagist.org/p/provider-latest/6f7c208a3f09d46049c69af2a1a28f5a9a0766abc8aed6f1295c2159de83e0ef.
json


  [Composer\Downloader\TransportException]
  Operation timed out after 60001 milliseconds with 1539849 out of 5969934 bytes received

Exception trace:
 () at phar:///usr/local/bin/composer/src/Composer/Util/Http/CurlDownloader.php:276
 Composer\Util\Http\CurlDownloader->tick() at phar:///usr/local/bin/composer/src/Composer/Util/HttpDownloader.php:307
 Composer\Util\HttpDownloader->countActiveJobs() at phar:///usr/local/bin/composer/src/Composer/Util/HttpDownloader.php:275
 Composer\Util\HttpDownloader->wait() at phar:///usr/local/bin/composer/src/Composer/Util/HttpDownloader.php:85
 Composer\Util\HttpDownloader->get() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:1071
 Composer\Repository\ComposerRepository->fetchFile() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:971
 Composer\Repository\ComposerRepository->loadProviderListings() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:542
 Composer\Repository\ComposerRepository->whatProvides() at phar:///usr/local/bin/composer/src/Composer/Repository/ComposerRepository.php:365
 Composer\Repository\ComposerRepository->loadPackages() at phar:///usr/local/bin/composer/src/Composer/Repository/RepositorySet.php:170
 Composer\Repository\RepositorySet->findPackages() at phar:///usr/local/bin/composer/src/Composer/Package/Version/VersionSelector.php:71
 Composer\Package\Version\VersionSelector->findBestCandidate() at phar:///usr/local/bin/composer/src/Composer/Command/InitCommand.php:735
 Composer\Command\InitCommand->findBestVersionAndNameForPackage() at phar:///usr/local/bin/composer/src/Composer/Command/InitCommand.php:437
 Composer\Command\InitCommand->determineRequirements() at phar:///usr/local/bin/composer/src/Composer/Command/RequireCommand.php:188
 Composer\Command\RequireCommand->execute() at phar:///usr/local/bin/composer/vendor/symfony/console/Command/Command.php:245
 Symfony\Component\Console\Command\Command->run() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:835
 Symfony\Component\Console\Application->doRunCommand() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:185
 Symfony\Component\Console\Application->doRun() at phar:///usr/local/bin/composer/src/Composer/Console/Application.php:309
 Composer\Console\Application->doRun() at phar:///usr/local/bin/composer/vendor/symfony/console/Application.php:117
 Symfony\Component\Console\Application->run() at phar:///usr/local/bin/composer/src/Composer/Console/Application.php:121
 Composer\Console\Application->run() at phar:///usr/local/bin/composer/bin/composer:61
 require() at /usr/local/bin/composer:24

require [--dev] [--dry-run] [--prefer-source] [--prefer-dist] [--fixed] [--no-suggest] [--no-progress] [--no-update] [--no-
install] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--with-dependencie
s] [--with-all-dependencies] [--ignore-platform-req IGNORE-PLATFORM-REQ] [--ignore-platform-reqs] [--prefer-stable] [--pref
er-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]
...

And I expected this to happen:

The command should have execeuted successfully.


The Linux workaround suggested here https://getcomposer.org/doc/articles/troubleshooting.md#operation-timed-out-ipv6-issues- didn't work.

created time in 15 days

issue openedsubhojit777/questionnaire-backend

Participant always sees the first question after login

Steps to replicate:

  1. Presenter is on third question
  2. Open a new participant screen
  3. Do the login
  4. The participant sees the first question. One should see the third question

created time in 21 days

push eventsubhojit777/questionnaire-backend

Subhojit Paul

commit sha 9ea3ff9170bd13fda798d09298f393993f7f68c6

answers.create event

view details

Subhojit Paul

commit sha ec1ebda9a489cbe08ea4bfc09cd120c4b3c66a50

handle answers.create request and response

view details

Subhojit Paul

commit sha 223f36bdba0487a5ae3cf9616ac8e8d70d27079c

commom implementation of parse_request

view details

push time in 21 days

starteddbrgn/tealdeer

started time in 24 days

push eventsubhojit777/questionnaire-frontend

Subhojit Paul

commit sha dcee6ddfb012e48d0be0e4aef34272a5cbae2ecb

update ws response handler as per backend changes

view details

Subhojit Paul

commit sha bc984bfd3567b45766fcb44611da07de8b2027c7

add default handler for ws event

view details

push time in a month

push eventsubhojit777/questionnaire-backend

Subhojit Paul

commit sha 1ce53a035d7b51f15a93084c5d1a303e20408028

remove WIP code

view details

push time in a month

push eventsubhojit777/questionnaire-backend

Subhojit Paul

commit sha 27f2b7bf2ce95c6b8e79218d689fbd61c5879770

consistent way of sending response

view details

Subhojit Paul

commit sha d55bccc65a38151d9874a64c56fc9ed207c988d6

typed response

view details

Subhojit Paul

commit sha 7256ec562ceaac092ab10f44d303453322c6ef6d

WIP

view details

push time in a month

startedstarship/starship

started time in 2 months

startedsharkdp/bat

started time in 2 months

startedzaiste/zaiste.net

started time in 2 months

push eventsubhojit777/questionnaire-frontend

Subhojit Paul

commit sha d1e6712e52a29dbf00849d905f63f94460228b9e

fix - server unable to parse data

view details

Subhojit Paul

commit sha 2d9c6427239422ea5b6c9cd86abc1f76a1aff30f

update UI based on event type

view details

push time in 2 months

create barnchsubhojit777/questionnaire-backend

branch : 43-sync-screen-pt2

created branch time in 2 months

startedvinayak-mehta/present

started time in 2 months

startedsastejugaad/brahmos

started time in 2 months

more