square/keywhiz-fs 111

A DEPRECATED file-system client for Keywhiz

spiffe/spiffe-example 50

Code for various SPIFFE and SPIRE demos

riyazdf/dockercon-workshop 32

Dockercon 2016 Security Workshop

riyazdf/consoleJSON 18

Pretty printing JSON in the browser console

endophage/conman 1

Container Manager

riyazdf/BartFinder 1

Finds BART trips given start and end stations, and a time. Uses BeautifulSoup.

cyli/docker 0

Docker - the open-source application container engine

kevintee/Yelp-Dataset 0

riyazdf/authz-plugin 0

A simple Docker authZ plugin using the v2 architecture. Blocks all docker volume commands.

issue commentlibra/libra

[vm][mempool] Transaction Expiration Logic in Move

thanks @sblackshear, that covers the use case perfectly! Another use case would be to have pre-signed transactions that move large chunks of funds to another key if you suspect compromise (though the key revocation / rotation is cleaner).

In both scenarios, having pre-signed transactions can enable very fast response times, and not having to access keys (which may take much more time depending on how the keys are stored / constructed)


comment created time in 7 days

PR opened linuxkit/linuxkit

Remove riyazdf from MAINTAINERS

I'd like to formally step down as a maintainer, as I haven't been as involved as of late -- exciting to see all of the progress :)

Signed-off-by: Riyaz Faizullabhoy

- A picture of a cute animal (not mandatory but encouraged) image

+0 -6

0 comment

1 changed file

pr created time in 2 months

create barnchriyazdf/linuxkit

branch : riyazdf-maintainer

created branch time in 2 months

Pull request review commentlibra/libra

[transaction-builder] key rotation builder takes bytes instead of add…

 pub fn encode_rotate_consensus_pubkey_script(new_key: Vec<u8>) -> Script { }  /// Encode a program that rotates the sender's authentication key to `new_key`.-pub fn rotate_authentication_key_script(new_key: AccountAddress) -> Script {+pub fn rotate_authentication_key_script(new_key: Vec<u8>) -> Script {

nit: thoughts on renaming this to new_key_hash and specifying the kind of hashed bytes we expect here? Just to make it explicit that we should not pass a raw public key.


comment created time in 3 months