profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/raszi/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
KARASZI István raszi Budapest, Hungary, Europe https://raszi.hu/

raszi/colorize 66

Log colorizer perl script

raszi/cleanup_vendor 11

Vendor directory cleanup tool

raszi/async 1

Async utilities for node and the browser

raszi/bigfish_payment 1

Rails module for Bigfish Payment Gateway

raszi/calendar_date_select 1

A popular and flexible JavaScript DatePicker for RubyOnRails (and others)

raszi/clasp 1

🔗 Command Line Apps Script Projects

gabealmer/github-changelog 0

GitHub changelog

janosmeszaros/github-changelog 0

GitHub changelog

mcbuddha/github-changelog 0

GitHub changelog

PR merged raszi/mrkt

chore(deps-dev): update rubocop requirement from ~> 1.20.0 to ~> 1.21.0 dependencies ruby

Updates the requirements on rubocop to permit the latest version. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/rubocop/rubocop/releases">rubocop's releases</a>.</em></p> <blockquote> <h2>RuboCop 1.21</h2> <h3>New features</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/7849">#7849</a>: Add new <code>Lint/AmbiguousOperatorPrecedence</code> cop. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9061">#9061</a>: Add new <code>Lint/IncompatibleIoSelectWithFiberScheduler</code> cop. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> </ul> <h3>Bug fixes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10067">#10067</a>: Fix an error for <code>Lint/NumberConversion</code> when using nested number conversion methods. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10054">#10054</a>: Fix a false positive for <code>Layout/SpaceAroundOperators</code> when match operators between <code><<</code> and <code>+=</code>. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10061">#10061</a>: Fix a false positive for <code>Style/RedundantSort</code> when using <code>size</code> method in the block. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10063">#10063</a>: Fix a false positive for <code>Layout/SingleLineBlockChain</code> when method call chained on a new line after a single line block with trailing dot. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10064">#10064</a>: Fix <code>Style/ExplicitBlockArgument</code> corrector assuming any existing block argument was named <code>block</code>. (<a href="https://github.com/byroot"><code>@​byroot</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10070">#10070</a>: Fix a false positive for <code>Style/MutableConstant</code> when using non-interpolated heredoc in Ruby 3.0. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> </ul> <h3>Changes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9674">#9674</a>: Disable <code>Style/AsciiComments</code> by default. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10051">#10051</a>: Improve the messaging for <code>Style/Documentation</code> to be more clear about what class/module needs documentation. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10074">#10074</a>: Update <code>Naming/InclusiveLanguage</code> to be disabled by default. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10068">#10068</a>: Mark <code>Style/AndOr</code> as unsafe auto-correction. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/rubocop/rubocop/blob/master/CHANGELOG.md">rubocop's changelog</a>.</em></p> <blockquote> <h2>1.21.0 (2021-09-13)</h2> <h3>New features</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/7849">#7849</a>: Add new <code>Lint/AmbiguousOperatorPrecedence</code> cop. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9061">#9061</a>: Add new <code>Lint/IncompatibleIoSelectWithFiberScheduler</code> cop. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> </ul> <h3>Bug fixes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10067">#10067</a>: Fix an error for <code>Lint/NumberConversion</code> when using nested number conversion methods. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10054">#10054</a>: Fix a false positive for <code>Layout/SpaceAroundOperators</code> when match operators between <code><<</code> and <code>+=</code>. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10061">#10061</a>: Fix a false positive for <code>Style/RedundantSort</code> when using <code>size</code> method in the block. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10063">#10063</a>: Fix a false positive for <code>Layout/SingleLineBlockChain</code> when method call chained on a new line after a single line block with trailing dot. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10064">#10064</a>: Fix <code>Style/ExplicitBlockArgument</code> corrector assuming any existing block argument was named <code>block</code>. ([<a href="https://github.com/byroot"><code>@​byroot</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10070">#10070</a>: Fix a false positive for <code>Style/MutableConstant</code> when using non-interpolated heredoc in Ruby 3.0. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> </ul> <h3>Changes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9674">#9674</a>: Disable <code>Style/AsciiComments</code> by default. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10051">#10051</a>: Improve the messaging for <code>Style/Documentation</code> to be more clear about what class/module needs documentation. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10074">#10074</a>: Update <code>Naming/InclusiveLanguage</code> to be disabled by default. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10068">#10068</a>: Mark <code>Style/AndOr</code> as unsafe auto-correction. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/rubocop/rubocop/commit/25112e6cbc5198ee5c19cbc3d443524d79e4b609"><code>25112e6</code></a> Cut 1.21</li> <li><a href="https://github.com/rubocop/rubocop/commit/45938837b05bd74ff77f291272ebba6f499c8d3e"><code>4593883</code></a> Update Changelog</li> <li><a href="https://github.com/rubocop/rubocop/commit/f7c21e171da086c751261b45cdceb79c25ee8f39"><code>f7c21e1</code></a> [Fix <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9061">#9061</a>] Add new <code>Lint/IncompatibleIoSelectWithFiberScheduler</code> cop</li> <li><a href="https://github.com/rubocop/rubocop/commit/d199e94330def75672c13049253e38fc92a419eb"><code>d199e94</code></a> Update <code>Naming/InclusiveLanguage</code> to be disabled by default.</li> <li><a href="https://github.com/rubocop/rubocop/commit/eac703f9095df73584ac3befcecd9b459e1dde40"><code>eac703f</code></a> [Fix <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10070">#10070</a>] Fix a false positive for <code>Style/MutableConstant</code></li> <li><a href="https://github.com/rubocop/rubocop/commit/6d1ce3b6c58d1e775a60f55dcaee8c44a9784f7d"><code>6d1ce3b</code></a> Mark <code>Style/AndOr</code> as unsafe auto-correction</li> <li><a href="https://github.com/rubocop/rubocop/commit/1ad1f1296db95ba1e72a03916be2471616dfa733"><code>1ad1f12</code></a> Fix an error for <code>Lint/NumberConversion</code></li> <li><a href="https://github.com/rubocop/rubocop/commit/b9de8e89283fbf5e6a22b2ade9ac8bef97942df1"><code>b9de8e8</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10064">#10064</a> from casperisfine/explicit-block-corrector</li> <li><a href="https://github.com/rubocop/rubocop/commit/e44b0a82467b30c3c578373e3666a7e8051f8373"><code>e44b0a8</code></a> Style/ExplicitBlockArgument: do not assume the block parameter name</li> <li><a href="https://github.com/rubocop/rubocop/commit/8585c7587067dcbd9266d06967c73e4ca662e172"><code>8585c75</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10063">#10063</a> from koic/fix_a_false_positive_for_layout_single_li...</li> <li>Additional commits viewable in <a href="https://github.com/rubocop/rubocop/compare/v1.20.0...v1.21.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

You can trigger a rebase of this PR by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+4 -4

0 comment

2 changed files

dependabot[bot]

pr closed time in 3 days

push eventraszi/mrkt

dependabot[bot]

commit sha e163575acfd79ed6607d51b167b668eea79e751b

chore(deps-dev): update rubocop requirement from ~> 1.20.0 to ~> 1.21.0 Updates the requirements on [rubocop](https://github.com/rubocop/rubocop) to permit the latest version. - [Release notes](https://github.com/rubocop/rubocop/releases) - [Changelog](https://github.com/rubocop/rubocop/blob/master/CHANGELOG.md) - [Commits](https://github.com/rubocop/rubocop/compare/v1.20.0...v1.21.0) --- updated-dependencies: - dependency-name: rubocop dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>

view details

KARASZI István

commit sha 46d1805fb244879e88e89f23973706998ffa207a

Merge pull request #92 from raszi/dependabot/bundler/rubocop-1.21.0 chore(deps-dev): update rubocop requirement from ~> 1.20.0 to ~> 1.21.0

view details

push time in 3 days

PullRequestReviewEvent

push eventraszi/mrkt

dependabot[bot]

commit sha 6b7532fe00828cc74c6487d2bee1ffe0f5f3ec75

chore(deps): bump faraday from 1.7.1 to 1.7.2 Bumps [faraday](https://github.com/lostisland/faraday) from 1.7.1 to 1.7.2. - [Release notes](https://github.com/lostisland/faraday/releases) - [Changelog](https://github.com/lostisland/faraday/blob/main/CHANGELOG.md) - [Commits](https://github.com/lostisland/faraday/compare/v1.7.1...v1.7.2) --- updated-dependencies: - dependency-name: faraday dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com>

view details

KARASZI István

commit sha 2139ed718f6c5f86333dc11bb2f3fa8a26ea21bd

Merge pull request #91 from raszi/dependabot/bundler/faraday-1.7.2 chore(deps): bump faraday from 1.7.1 to 1.7.2

view details

push time in 3 days

PR merged raszi/mrkt

chore(deps): bump faraday from 1.7.1 to 1.7.2 dependencies ruby

Bumps faraday from 1.7.1 to 1.7.2. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/lostisland/faraday/releases">faraday's releases</a>.</em></p> <blockquote> <h2>v1.7.2</h2> <h2>Fixes</h2> <ul> <li>Fix deprecation warning when providing basic auth in url (<a href="https://github-redirect.dependabot.com/lostisland/faraday/issues/1323">#1323</a>, <a href="https://github.com/iMacTia"><code>@​iMacTia</code></a>)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/lostisland/faraday/commit/d881f163c0b8e0bb2dcb31185cb52cb1c8aee225"><code>d881f16</code></a> Version bump to 1.7.2</li> <li><a href="https://github.com/lostisland/faraday/commit/18ba248d14a00f5f8969cdf8dbf474b99c737ab0"><code>18ba248</code></a> Fix deprecation warning (<a href="https://github-redirect.dependabot.com/lostisland/faraday/issues/1323">#1323</a>)</li> <li>See full diff in <a href="https://github.com/lostisland/faraday/compare/v1.7.1...v1.7.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

You can trigger a rebase of this PR by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 days

PullRequestReviewEvent

push eventraszi/cleanup_vendor

KARASZI István

commit sha dcbba0f5b72ba7374b2c3409cc96557bf0292c03

Update dependabot settings

view details

push time in 4 days

push eventraszi/mrkt

KARASZI István

commit sha cca537c2fa45753b7856c0afc2d475f679038e59

Update dependabot settings

view details

push time in 4 days

push eventraszi/cleanup_vendor

dependabot[bot]

commit sha e15ba61708e55d12fe1d96b05bcd9f153a089888

Bump pry-doc from 1.1.0 to 1.2.0 Bumps [pry-doc](https://github.com/pry/pry-doc) from 1.1.0 to 1.2.0. - [Release notes](https://github.com/pry/pry-doc/releases) - [Changelog](https://github.com/pry/pry-doc/blob/master/CHANGELOG.md) - [Commits](https://github.com/pry/pry-doc/compare/v1.1.0...v1.2.0) --- updated-dependencies: - dependency-name: pry-doc dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>

view details

KARASZI István

commit sha a2e6d3ed6ef0913ff680dae010869b4c5b994b31

Merge pull request #71 from raszi/dependabot/bundler/pry-doc-1.2.0 Bump pry-doc from 1.1.0 to 1.2.0

view details

push time in 4 days

PR merged raszi/cleanup_vendor

Bump pry-doc from 1.1.0 to 1.2.0 dependencies ruby

Bumps pry-doc from 1.1.0 to 1.2.0. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/pry/pry-doc/blob/master/CHANGELOG.md">pry-doc's changelog</a>.</em></p> <blockquote> <h3>[v1.2.0][v1.2.0] (March 2, 2021)</h3> <ul> <li>Added Ruby 3.0 support (<a href="https://github-redirect.dependabot.com/pry/pry-doc/pull/107">#107</a>)</li> <li>Fixed the <code>pry is deprecated, use pry_instance instead</code> deprecation warning (<a href="https://github-redirect.dependabot.com/pry/pry-doc/pull/111">#111</a>)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/pry/pry-doc/commit/31ca6c4d4fef901172659dae2d3b7dbf1ec97afc"><code>31ca6c4</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/pry/pry-doc/issues/108">#108</a> from pry/release-1-2-0</li> <li><a href="https://github.com/pry/pry-doc/commit/f3bfe493cccd75cb2e3dfc58f95c43e96f2291e2"><code>f3bfe49</code></a> Release v1.2.0</li> <li><a href="https://github.com/pry/pry-doc/commit/dd3c67e03532628ed6f358dc667c1b5d11d16444"><code>dd3c67e</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/pry/pry-doc/issues/109">#109</a> from pry/ruby-3-0-testing</li> <li><a href="https://github.com/pry/pry-doc/commit/b0dd715a9856ad9fed83b00cee78a0f5d13b1733"><code>b0dd715</code></a> circleci: test against Ruby 3.0</li> <li><a href="https://github.com/pry/pry-doc/commit/74e637a803f08b2b4cbe462e5bda6b01f23a5c5b"><code>74e637a</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/pry/pry-doc/issues/117">#117</a> from andrehjr/update-glob-method</li> <li><a href="https://github.com/pry/pry-doc/commit/8c26ff62b55fe31524c8bd9383f6210ce553345a"><code>8c26ff6</code></a> change glob -> mkdir as glob was moved into dir.rb</li> <li><a href="https://github.com/pry/pry-doc/commit/8ca61fd09de448941eaeb5f295aca36cc9291a8d"><code>8ca61fd</code></a> Update README installation (<a href="https://github-redirect.dependabot.com/pry/pry-doc/issues/115">#115</a>)</li> <li><a href="https://github.com/pry/pry-doc/commit/b1f9747a05e8888f741b9a1afeee1088b8a6e454"><code>b1f9747</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/pry/pry-doc/issues/111">#111</a> from pry/deprecation-warning-fix</li> <li><a href="https://github.com/pry/pry-doc/commit/c35854c17f1934ea6c90a6ca3b8bf478fad72015"><code>c35854c</code></a> Fix the <code>pry is deprecated, use pry_instance instead</code> warning</li> <li><a href="https://github.com/pry/pry-doc/commit/0834ee140b3a585c766c50129d1a4f9bafd41e24"><code>0834ee1</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/pry/pry-doc/issues/110">#110</a> from pry/changelog-fix</li> <li>Additional commits viewable in <a href="https://github.com/pry/pry-doc/compare/v1.1.0...v1.2.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+2 -2

0 comment

1 changed file

dependabot[bot]

pr closed time in 4 days

PullRequestReviewEvent

push eventraszi/cleanup_vendor

dependabot[bot]

commit sha f198ca1393cdf26407f93e5e3bfc900e24e7babc

Update rubocop requirement from ~> 1.20.0 to ~> 1.21.0 Updates the requirements on [rubocop](https://github.com/rubocop/rubocop) to permit the latest version. - [Release notes](https://github.com/rubocop/rubocop/releases) - [Changelog](https://github.com/rubocop/rubocop/blob/master/CHANGELOG.md) - [Commits](https://github.com/rubocop/rubocop/compare/v1.20.0...v1.21.0) --- updated-dependencies: - dependency-name: rubocop dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>

view details

KARASZI István

commit sha e1c570b20896b919aae25b6f198debe1de88cdb4

Merge pull request #70 from raszi/dependabot/bundler/rubocop-1.21.0 Update rubocop requirement from ~> 1.20.0 to ~> 1.21.0

view details

push time in 4 days

PR merged raszi/cleanup_vendor

Update rubocop requirement from ~> 1.20.0 to ~> 1.21.0 dependencies ruby

Updates the requirements on rubocop to permit the latest version. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/rubocop/rubocop/releases">rubocop's releases</a>.</em></p> <blockquote> <h2>RuboCop 1.21</h2> <h3>New features</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/7849">#7849</a>: Add new <code>Lint/AmbiguousOperatorPrecedence</code> cop. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9061">#9061</a>: Add new <code>Lint/IncompatibleIoSelectWithFiberScheduler</code> cop. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> </ul> <h3>Bug fixes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10067">#10067</a>: Fix an error for <code>Lint/NumberConversion</code> when using nested number conversion methods. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10054">#10054</a>: Fix a false positive for <code>Layout/SpaceAroundOperators</code> when match operators between <code><<</code> and <code>+=</code>. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10061">#10061</a>: Fix a false positive for <code>Style/RedundantSort</code> when using <code>size</code> method in the block. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10063">#10063</a>: Fix a false positive for <code>Layout/SingleLineBlockChain</code> when method call chained on a new line after a single line block with trailing dot. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10064">#10064</a>: Fix <code>Style/ExplicitBlockArgument</code> corrector assuming any existing block argument was named <code>block</code>. (<a href="https://github.com/byroot"><code>@​byroot</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10070">#10070</a>: Fix a false positive for <code>Style/MutableConstant</code> when using non-interpolated heredoc in Ruby 3.0. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> </ul> <h3>Changes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9674">#9674</a>: Disable <code>Style/AsciiComments</code> by default. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10051">#10051</a>: Improve the messaging for <code>Style/Documentation</code> to be more clear about what class/module needs documentation. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10074">#10074</a>: Update <code>Naming/InclusiveLanguage</code> to be disabled by default. (<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>)</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10068">#10068</a>: Mark <code>Style/AndOr</code> as unsafe auto-correction. (<a href="https://github.com/koic"><code>@​koic</code></a>)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/rubocop/rubocop/blob/master/CHANGELOG.md">rubocop's changelog</a>.</em></p> <blockquote> <h2>1.21.0 (2021-09-13)</h2> <h3>New features</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/7849">#7849</a>: Add new <code>Lint/AmbiguousOperatorPrecedence</code> cop. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9061">#9061</a>: Add new <code>Lint/IncompatibleIoSelectWithFiberScheduler</code> cop. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> </ul> <h3>Bug fixes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10067">#10067</a>: Fix an error for <code>Lint/NumberConversion</code> when using nested number conversion methods. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10054">#10054</a>: Fix a false positive for <code>Layout/SpaceAroundOperators</code> when match operators between <code><<</code> and <code>+=</code>. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10061">#10061</a>: Fix a false positive for <code>Style/RedundantSort</code> when using <code>size</code> method in the block. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10063">#10063</a>: Fix a false positive for <code>Layout/SingleLineBlockChain</code> when method call chained on a new line after a single line block with trailing dot. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10064">#10064</a>: Fix <code>Style/ExplicitBlockArgument</code> corrector assuming any existing block argument was named <code>block</code>. ([<a href="https://github.com/byroot"><code>@​byroot</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10070">#10070</a>: Fix a false positive for <code>Style/MutableConstant</code> when using non-interpolated heredoc in Ruby 3.0. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> </ul> <h3>Changes</h3> <ul> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9674">#9674</a>: Disable <code>Style/AsciiComments</code> by default. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10051">#10051</a>: Improve the messaging for <code>Style/Documentation</code> to be more clear about what class/module needs documentation. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10074">#10074</a>: Update <code>Naming/InclusiveLanguage</code> to be disabled by default. ([<a href="https://github.com/dvandersluis"><code>@​dvandersluis</code></a>][])</li> <li><a href="https://github-redirect.dependabot.com/rubocop/rubocop/pull/10068">#10068</a>: Mark <code>Style/AndOr</code> as unsafe auto-correction. ([<a href="https://github.com/koic"><code>@​koic</code></a>][])</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/rubocop/rubocop/commit/25112e6cbc5198ee5c19cbc3d443524d79e4b609"><code>25112e6</code></a> Cut 1.21</li> <li><a href="https://github.com/rubocop/rubocop/commit/45938837b05bd74ff77f291272ebba6f499c8d3e"><code>4593883</code></a> Update Changelog</li> <li><a href="https://github.com/rubocop/rubocop/commit/f7c21e171da086c751261b45cdceb79c25ee8f39"><code>f7c21e1</code></a> [Fix <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/9061">#9061</a>] Add new <code>Lint/IncompatibleIoSelectWithFiberScheduler</code> cop</li> <li><a href="https://github.com/rubocop/rubocop/commit/d199e94330def75672c13049253e38fc92a419eb"><code>d199e94</code></a> Update <code>Naming/InclusiveLanguage</code> to be disabled by default.</li> <li><a href="https://github.com/rubocop/rubocop/commit/eac703f9095df73584ac3befcecd9b459e1dde40"><code>eac703f</code></a> [Fix <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10070">#10070</a>] Fix a false positive for <code>Style/MutableConstant</code></li> <li><a href="https://github.com/rubocop/rubocop/commit/6d1ce3b6c58d1e775a60f55dcaee8c44a9784f7d"><code>6d1ce3b</code></a> Mark <code>Style/AndOr</code> as unsafe auto-correction</li> <li><a href="https://github.com/rubocop/rubocop/commit/1ad1f1296db95ba1e72a03916be2471616dfa733"><code>1ad1f12</code></a> Fix an error for <code>Lint/NumberConversion</code></li> <li><a href="https://github.com/rubocop/rubocop/commit/b9de8e89283fbf5e6a22b2ade9ac8bef97942df1"><code>b9de8e8</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10064">#10064</a> from casperisfine/explicit-block-corrector</li> <li><a href="https://github.com/rubocop/rubocop/commit/e44b0a82467b30c3c578373e3666a7e8051f8373"><code>e44b0a8</code></a> Style/ExplicitBlockArgument: do not assume the block parameter name</li> <li><a href="https://github.com/rubocop/rubocop/commit/8585c7587067dcbd9266d06967c73e4ca662e172"><code>8585c75</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubocop/rubocop/issues/10063">#10063</a> from koic/fix_a_false_positive_for_layout_single_li...</li> <li>Additional commits viewable in <a href="https://github.com/rubocop/rubocop/compare/v1.20.0...v1.21.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+4 -4

0 comment

2 changed files

dependabot[bot]

pr closed time in 4 days

PullRequestReviewEvent

created tagraszi/mrkt

tagv1.2.0

This gem provides some level of abstraction to Marketo REST APIs.

created time in 6 days

created tagraszi/mrkt

tagv1.1.1

This gem provides some level of abstraction to Marketo REST APIs.

created time in 6 days

push eventraszi/mrkt

KARASZI István

commit sha 3c8bfe46d08657b495f5ecf02007cabacd8a7241

Bump mrkt to 1.2.0

view details

push time in 6 days

PR merged raszi/mrkt

Bump faraday from 1.7.0 to 1.7.1 dependencies ruby

Bumps faraday from 1.7.0 to 1.7.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/lostisland/faraday/releases">faraday's releases</a>.</em></p> <blockquote> <h2>v1.7.1</h2> <h2>Fixes</h2> <ul> <li>Respect the params_encoder in Faraday::Adapter::Test (<a href="https://github-redirect.dependabot.com/lostisland/faraday/issues/1316">#1316</a>, <a href="https://github.com/yykamei"><code>@​yykamei</code></a>)</li> </ul> <h2>Deprecations</h2> <ul> <li>Deprecate Authorization helpers in Faraday::Connection (<a href="https://github-redirect.dependabot.com/lostisland/faraday/issues/1306">#1306</a>, <a href="https://github.com/iMacTia"><code>@​iMacTia</code></a>)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/lostisland/faraday/blob/main/CHANGELOG.md">faraday's changelog</a>.</em></p> <blockquote> <h1>Faraday Changelog</h1> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/lostisland/faraday/commit/a84e6b4dba31612c95b69ea446884139d41cda4b"><code>a84e6b4</code></a> Version bump to 1.7.1</li> <li><a href="https://github.com/lostisland/faraday/commit/8f32d7d59d187ecacf610bbb9c096640c0fa5a31"><code>8f32d7d</code></a> Respect the <code>params_encoder</code> in <code>Faraday::Adapter::Test</code> (<a href="https://github-redirect.dependabot.com/lostisland/faraday/issues/1316">#1316</a>)</li> <li><a href="https://github.com/lostisland/faraday/commit/fa612a060adffd2d7bdb73e46610f4f8aec09220"><code>fa612a0</code></a> [1.x] Deprecate Authorization helpers in Faraday::Connection (<a href="https://github-redirect.dependabot.com/lostisland/faraday/issues/1306">#1306</a>)</li> <li>See full diff in <a href="https://github.com/lostisland/faraday/compare/v1.7.0...v1.7.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 12 days

push eventraszi/mrkt

dependabot[bot]

commit sha 24d4686fabb6178ea8dce406904636d81c049479

Bump faraday from 1.7.0 to 1.7.1 Bumps [faraday](https://github.com/lostisland/faraday) from 1.7.0 to 1.7.1. - [Release notes](https://github.com/lostisland/faraday/releases) - [Changelog](https://github.com/lostisland/faraday/blob/main/CHANGELOG.md) - [Commits](https://github.com/lostisland/faraday/compare/v1.7.0...v1.7.1) --- updated-dependencies: - dependency-name: faraday dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com>

view details

KARASZI István

commit sha 1d51729c1ae91208c2e9f3e87bf585c21344886c

Merge pull request #90 from raszi/dependabot/bundler/faraday-1.7.1 Bump faraday from 1.7.0 to 1.7.1

view details

push time in 12 days

PullRequestReviewEvent

pull request commentlaravel/framework

[8.x] Handle Query Builder supported arrays

I cannot leave the old tests untouched since that is using mocking and the old implementation has changed and therefore the old tests are failing because the mocks were written for the old implementation.

raszi

comment created time in 13 days

pull request commentlaravel/framework

[8.x] Handle Query Builder supported arrays

The original functionality will be the same, but as I tried to explain the tests of the original behavior were tested with mocks, and since the implementation was changed therefore the mocking needed to be updated as well, otherwise the old tests would fail.

Since new tests were also required and I wanted to tests all the old functionality with the new behavior, therefore I implemented the new tests by introducing a data provider to the tests.

What would be your proposal if I wanted to test everything that the old tests were testing with the new functionality? Copy down all the old tests in this PR and then open a new PR where I introduce the data provider to the test methods and remove the duplication?

raszi

comment created time in 13 days

issue openedlaravel/framework

Illuminate\Testing\PendingCommand::doesntExpectOutput() does not accept patterns

<!-- DO NOT THROW THIS AWAY --> <!-- Fill out the FULL versions with patch versions -->

  • Laravel Version: v8.58.0
  • PHP Version: 7.4.16
  • Database Driver & Version: does not matter

Description:

If in your console command you are writing multiple lines to the output then the only chance to write a proper test for it is to use the Mockery::pattern() method to create and match patterns:

Working code

public function test(): void
{
    $this->artisan('command')->expectsOutput(Mockery::pattern('/foo.*?bar/s'));
}

It works as expected but Illuminate\Testing\PendingCommand::doesntExpectOutput() uses the not expected value as the key of an associative array which makes it impossible to use Mockery::pattern().

Steps To Reproduce:

Example code:

public function test(): void
{
    $this->artisan('command')->doesntExpectOutput(Mockery::pattern('/foo.*?bar/s'));
}

This will throw an error like:

ErrorException: Illegal offset type

/path/to/source/vendor/laravel/framework/src/Illuminate/Testing/PendingCommand.php:144
/path/to/source/tests/ExampleTest.php:15

created time in 16 days

pull request commentlaravel/framework

[8.x] Handle Query Builder supported arrays

The previous tests should be changed at least on some level since the internal behavior was changed and therefore the mocking should be also modified to follow that. Read the old tests will be affected at least on some level.

I can remove the data provider related changes from this merge request and then open a separate merge request to add that, but if both will be accepted then what is the point?

raszi

comment created time in 16 days

pull request commentlaravel/framework

[8.x] Handle Query Builder supported arrays

Well, I think more tests are better. :)

I did not really change the tests themselves just introduced a data provider that changes the behavior of tests and covers both cases.

raszi

comment created time in 18 days

delete branch raszi/framework

delete branch : patch-1

delete time in 19 days

push eventraszi/framework

KARASZI István

commit sha ab3b480d8384dbcb2357466f0a7455fa9781cc5d

Fix array syntax

view details

push time in 19 days

PR opened laravel/framework

Feature/has in database

Related to #37823

With this addition, the users could test the database entries not just on equivalency but also on various conditions that the query builder also supports.

Previously this assertion would throw an error since the error message generation would fetch the entries in the database but the condition building there isn't complete and only expects equivalency.

$this->assertDatabaseHas($tableName, [
    ['field_a', '=', 'value'],
    ['field_b', '<>', '']
]);

End users could write assertions where they expect a field to be different from something, like when changing a status or generating a new random id, or incrementing a field, etc.

It also keeps backward compatible with the associative array condition:

$this->assertDatabaseHas($tableName, [
    'field_a' => 'value_a',
    'field_a' => 'value_b'
]);
+134 -76

0 comment

2 changed files

pr created time in 19 days

create barnchraszi/framework

branch : feature/has-in-database

created branch time in 19 days

push eventraszi/cleanup_vendor

dependabot[bot]

commit sha e665824c551132deecd2906a3e587dd61e299d5e

Update rubocop requirement from ~> 1.19.0 to ~> 1.20.0 Updates the requirements on [rubocop](https://github.com/rubocop/rubocop) to permit the latest version. - [Release notes](https://github.com/rubocop/rubocop/releases) - [Changelog](https://github.com/rubocop/rubocop/blob/master/CHANGELOG.md) - [Commits](https://github.com/rubocop/rubocop/compare/v1.19.1...v1.20.0) --- updated-dependencies: - dependency-name: rubocop dependency-type: direct:development update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>

view details

KARASZI István

commit sha 45157c92fb3fc48ae52442e6b67c8e6bd39ceb01

Merge pull request #69 from raszi/dependabot/bundler/rubocop-1.20.0 Update rubocop requirement from ~> 1.19.0 to ~> 1.20.0

view details

push time in 19 days