profile
viewpoint
Ramy Tamer ramytamer Alexandria - Egypt http://ramytamer.com Software engineer by night, Dragons trainer by day.

AhmedAtef07/JavaCompiler 8

Syntax Directed Translation Scheme to convert Java code to Java bytecode, performing necessary lexical, syntax and static semantic analysis (such as type checking and Expressions Evaluation).

ramytamer/php-google-session 3

Simple web application demonstrated in a session was held by google in faculty of engineering - Alexandria University

ramytamer/Game-Of-Mazes 2

Game of thrones styled maze game in javascript and enchant.js

Ahmed-Emad/Elmod 1

Andriod application whose main target is to make people faster in Math calculations.

Rubikal/Ceres-FE 1

The Frontend for Ceres (Rubikal's Food Delivery App) ⚛️🍖

amrsekilly/Ceres-BE 0

The Elixir BE for Rubikal's food delivery app

inside-track/itk_health_checkex 0

Elixir / Plug based Health Checker

startedbobvanderlinden/probot-auto-merge

started time in 12 days

issue commentlaravel-notification-channels/fcm

Can't require the package with kreait/laravel-firebase version 2.1

@atymic I opened a PR #36; Can you take a look at it when you have a chance?

Thanks :)

ramytamer

comment created time in a month

push eventramytamer/fcm

Ramy Tamer

commit sha 92fb17825afbe28ec51ce05791d26719aaab856c

Upgrade kreait/laravel-firebase composer constraint version.

view details

push time in a month

push eventramytamer/fcm

Ramy Tamer

commit sha e9be54d604ea1b025b7d477b531616a4f6aa80f4

Upgrade kreait/laravel-firebase composer constraint version.

view details

push time in a month

fork ramytamer/fcm

Firebase Cloud Messaging (FCM) notifications channel for Laravel

https://laravel-notification-channels.com/

fork in a month

issue commentlaravel-notification-channels/fcm

Can't require the package with laravel-firebase version 2.1

@nemesiscb Same issue,

here is the output when I tried to execute: composer require laravel-notification-channels/fcm:~2.0

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for laravel-notification-channels/fcm ~2.0 -> satisfiable by laravel-notification-channels/fcm[2.0.0, 2.0.1, 2.0.2].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Conclusion: install kreait/laravel-firebase 1.x-dev
    - Installation request for kreait/laravel-firebase ^2.1 -> satisfiable by kreait/laravel-firebase[2.1.0].


Installation failed, reverting ./composer.json to its original content.

and here is with specific version: composer require laravel-notification-channels/fcm:2.0.2

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - laravel-notification-channels/fcm 2.0.2 requires kreait/laravel-firebase ^1.3 -> satisfiable by kreait/laravel-firebase[1.x-dev].
    - Installation request for laravel-notification-channels/fcm 2.0.2 -> satisfiable by laravel-notification-channels/fcm[2.0.2].
    - Installation request for kreait/laravel-firebase ^2.1 -> satisfiable by kreait/laravel-firebase[2.1.0].


Installation failed, reverting ./composer.json to its original content.

I still think the problem is the require part here; I think it might need to be "kreait/laravel-firebase": "~1.3 || ~2.1", instead of just "kreait/laravel-firebase": "^1.3", (not sure though)

ramytamer

comment created time in a month

issue openedlaravel-notification-channels/fcm

Can't require the package with laravel-firebase version 2.1

I am using kreait/laravel-firebase:^2.1 in my project and whenever I try to composer require laravel-notification-channels/fcm I get an error because of the dependency version defined in the package composer.json

Here is what I get when I run: composer require laravel-notification-channels/fcm:^2.0

./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for laravel-notification-channels/fcm ^2.0 -> satisfiable by laravel-notification-channels/fcm[2.0.0, 2.0.1, 2.0.2].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Conclusion: install kreait/laravel-firebase 1.x-dev
    - Installation request for kreait/laravel-firebase ^2.1 -> satisfiable by kreait/laravel-firebase[2.1.0].


Installation failed, reverting ./composer.json to its original content.

And this is what I get if I didn't specify the version: composer require laravel-notification-channels/fcm

Using version ^2.0 for laravel-notification-channels/fcm
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for laravel-notification-channels/fcm ^2.0 -> satisfiable by laravel-notification-channels/fcm[2.0.0, 2.0.1, 2.0.2].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Can only install one of: kreait/laravel-firebase[1.x-dev, 2.1.0].
    - Conclusion: install kreait/laravel-firebase 1.x-dev
    - Installation request for kreait/laravel-firebase ^2.1 -> satisfiable by kreait/laravel-firebase[2.1.0].


Installation failed, reverting ./composer.json to its original content.

I am not sure what should be the appropriate solution here, should we allow version 2.1.0 for laravel-firebase in the composer.json file of the package?

I can open a PR for this fix if that would solve this issue.

created time in a month

startedsplewis/csgo-pug-setup

started time in 2 months

startedfzaninotto/Faker

started time in 2 months

more