profile
viewpoint
Nick Fix njfix6 Correlated Labs Minneapolis, MN, USA nickfix.me Engineering @limebike. Alum of the University of Minnesota, Twin Cities.

njfix6/bitbucket-build-status-notifier-plugin 0

Notify Bitbucket Cloud with the Jenkins CI build status information.

njfix6/carbon 0

🎨 Create and share beautiful images of your source code

njfix6/clouddriver 0

read and write operations across cloud providers

njfix6/datadogpy 0

The Datadog Python library

issue commentauth0/auth0-react

Build error - `Argument of type 'unknown' is not assignable to parameter of type 'Error`

@adamjmcgrath I have a fix for this issue and wondering if I could make a PR. Last time I tried it seemed like I didn't have access.

njfix6

comment created time in 5 days

IssuesEvent

issue closedauth0/auth0-react

Component definition is missing display name

Please do not report security vulnerabilities here. The Responsible Disclosure Program details the procedure for disclosing security issues.

Thank you in advance for helping us to improve this library! Please read through the template below and answer all relevant questions. Your additional work here is greatly appreciated and will help us respond as quickly as possible. For general support or usage questions, use the Auth0 Community or Auth0 Support. Finally, to avoid duplicates, please search existing Issues before submitting one here.

By submitting an Issue to this repository, you agree to the terms within the Auth0 Code of Conduct.

Describe the problem

After upgrading react, typescript, next, and auth0-react, I am running into a build issue where the following errors are being thrown.


/dev/auth0-react/src/with-auth0.tsx
  28:52  error  Component definition is missing display name  react/display-name

/dev/auth0-react/__tests__/helpers.tsx
  9:41  error  Component definition is missing display name  react/display-name

What was the expected behavior?

I would expect the build to compile properly.

Reproduction

Detail the steps taken to reproduce this error, and whether this issue can be reproduced consistently or if it is intermittent. Note: If clear, reproducable steps or the smallest sample app demonstrating misbehavior cannot be provided, we may not be able to follow up on this bug report.

  • Install next@^12.0.4, typescript@^4.5.2, @auth0/auth0-react@v1.8.0, and react@^17.0.2
  • run next build

Can the behavior be reproduced using the React SDK Playground?

If so, provide steps:

Where applicable, please include:

  • The smallest possible sample app that reproduces the undesirable behavior
  • Log files (redact/remove sensitive information)
  • Application settings (redact/remove sensitive information)
  • clientId and domain (these are publicly available)
  • Screenshots

Environment

Please provide the following:

  • Version of auth0-react used: 1.8.0
  • Which browsers have you tested in? N/A
  • Which framework are you using, if applicable (Angular, React, etc): React
  • Other modules/plugins/libraries that might be involved:

closed time in 5 days

njfix6
IssuesEvent

issue closedauth0/auth0-react

Component definition is missing display name

Please do not report security vulnerabilities here. The Responsible Disclosure Program details the procedure for disclosing security issues.

Thank you in advance for helping us to improve this library! Please read through the template below and answer all relevant questions. Your additional work here is greatly appreciated and will help us respond as quickly as possible. For general support or usage questions, use the Auth0 Community or Auth0 Support. Finally, to avoid duplicates, please search existing Issues before submitting one here.

By submitting an Issue to this repository, you agree to the terms within the Auth0 Code of Conduct.

Describe the problem

After upgrading react, typescript, next, and auth0-react, I am running into a build issue where the following errors are being thrown.


/dev/auth0-react/src/with-auth0.tsx
  28:52  error  Component definition is missing display name  react/display-name

/dev/auth0-react/__tests__/helpers.tsx
  9:41  error  Component definition is missing display name  react/display-name

What was the expected behavior?

I would expect the build to compile properly.

Reproduction

Detail the steps taken to reproduce this error, and whether this issue can be reproduced consistently or if it is intermittent. Note: If clear, reproducable steps or the smallest sample app demonstrating misbehavior cannot be provided, we may not be able to follow up on this bug report.

  • Install next@^12.0.4, typescript@^4.5.2, @auth0/auth0-react@v1.8.0, and react@^17.0.2
  • run next build

Can the behavior be reproduced using the React SDK Playground?

If so, provide steps:

Where applicable, please include:

  • The smallest possible sample app that reproduces the undesirable behavior
  • Log files (redact/remove sensitive information)
  • Application settings (redact/remove sensitive information)
  • clientId and domain (these are publicly available)
  • Screenshots

Environment

Please provide the following:

  • Version of auth0-react used: 1.8.0
  • Which browsers have you tested in? N/A
  • Which framework are you using, if applicable (Angular, React, etc): React
  • Other modules/plugins/libraries that might be involved:

closed time in 5 days

njfix6

issue openedauth0/auth0-react

Component definition is missing display name

Please do not report security vulnerabilities here. The Responsible Disclosure Program details the procedure for disclosing security issues.

Thank you in advance for helping us to improve this library! Please read through the template below and answer all relevant questions. Your additional work here is greatly appreciated and will help us respond as quickly as possible. For general support or usage questions, use the Auth0 Community or Auth0 Support. Finally, to avoid duplicates, please search existing Issues before submitting one here.

By submitting an Issue to this repository, you agree to the terms within the Auth0 Code of Conduct.

Describe the problem

After upgrading react, typescript, next, and auth0-react, I am running into a build issue where the following errors are being thrown.


/dev/auth0-react/src/with-auth0.tsx
  28:52  error  Component definition is missing display name  react/display-name

/dev/auth0-react/__tests__/helpers.tsx
  9:41  error  Component definition is missing display name  react/display-name

What was the expected behavior?

I would expect the build to compile properly.

Reproduction

Detail the steps taken to reproduce this error, and whether this issue can be reproduced consistently or if it is intermittent. Note: If clear, reproducable steps or the smallest sample app demonstrating misbehavior cannot be provided, we may not be able to follow up on this bug report.

  • Install next@^12.0.4, typescript@^4.5.2, @auth0/auth0-react@v1.8.0, and react@^17.0.2
  • run next build

Can the behavior be reproduced using the React SDK Playground?

If so, provide steps:

Where applicable, please include:

  • The smallest possible sample app that reproduces the undesirable behavior
  • Log files (redact/remove sensitive information)
  • Application settings (redact/remove sensitive information)
  • clientId and domain (these are publicly available)
  • Screenshots

Environment

Please provide the following:

  • Version of auth0-react used:
  • Which browsers have you tested in?
  • Which framework are you using, if applicable (Angular, React, etc):
  • Other modules/plugins/libraries that might be involved:

created time in 5 days

issue commentgetsentry/sentry-javascript

Attempted import error: 'withSentry' is not exported from '@sentry/nextjs'.

What was the resolution for the issue? I am running into this as well.

HarshaDW

comment created time in 6 days

more