profile
viewpoint
Gaetano Checinski nikhedonia LoopPerfect London LoopPerfect.com Founder of @LoopPerfect , Mathematician & Software Architect.

LoopPerfect/buckaroo 739

The decentralized package manager for C++ and friends 🏝️

LoopPerfect/conduit 126

High Performance Streams Based on Coroutine TS ⚡

LoopPerfect/satori 14

An HTTP server library in C++

LoopPerfect/buckaroo-recipes 6

The official book of recipes for Buckaroo 📒

nikhedonia/acted 1

actor library for javascript

nikhedonia/docker-cling 1

dockerized c++ interpreter based on clang

buildinfer/buildinfer.github.io 0

Website for BuildInfer 🌍

nikhedonia/array-from 0

A ponyfill for the ES 2015 `Array.from()`

nikhedonia/art 0

Retained mode vector drawing API designed for multiple output modes. There's also a built-in SVG parser.

nikhedonia/asio 0

Asio C++ Library

startedbrianberns/AlgEff

started time in 2 days

startedstarfucker/starfucker

started time in 3 days

startedonivim/oni2

started time in 10 days

starteduber/makisu

started time in 11 days

startedxgenecloud/xgenecloud

started time in 24 days

startedIamMohitM/Graph-Based-Image-Segmentation

started time in 25 days

startedtaichi-dev/taichi

started time in 25 days

startedparthmaul/onomancer

started time in a month

startedaxboe/liburing

started time in a month

startedBareflank/hypervisor

started time in a month

startedCEA-LIST/Cingulata

started time in a month

issue commentLoopPerfect/buckaroo

buck run :app is not working as it should. When I run the command (after quickstart) parsing of buck files and building is successful. But after that instead of showing the output it shows "file not found : link"

thanks. My guess is it cant find your linker. If I recall correctly the linker under windows is just called "link". I'd suggest you open an issue https://github.com/facebuck/buck

AyusDas

comment created time in a month

issue commentLoopPerfect/buckaroo

buck run :app is not working as it should. When I run the command (after quickstart) parsing of buck files and building is successful. But after that instead of showing the output it shows "file not found : link"

Not able to reproduce, can we have more info about your system? - eg.:

  • OS
  • buck version
  • how did you install buck
  • jvm version

I suspect that this is an issue with your buck installation

AyusDas

comment created time in a month

startedanandpawara/Real_Time_Image_Animation

started time in a month

issue commentnikhedonia/ProxyTalk

todo update deps

another

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

new

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

blub

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

lol

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

lol

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

dasd

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

dsdsa

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

aaa

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

2

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

another

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

blub

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

another

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

dsad

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

hah

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

lol

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

jklj

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

hjkjkh

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

blub

nikhedonia

comment created time in 2 months

issue commentnikhedonia/ProxyTalk

todo update deps

blub

nikhedonia

comment created time in 2 months

IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia
IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia
IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia
IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia
IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia
IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia
IssuesEvent

issue closednikhedonia/ProxyTalk

todo update deps

closed time in 2 months

nikhedonia

issue openednikhedonia/ProxyTalk

todo update deps

created time in 2 months

startedcnlohr/rawdrawandroid

started time in 2 months

push eventLoopPerfect/buckaroo

Gaetano Checinski

commit sha 184d78cc345704b0c70928ea2826a0079ae7fe31

remove ssh prefix and update nuget.config

view details

Gaetano Checinski

commit sha 6e7ff66196d3bd6c4022cac8d544fea35e191b40

Merge pull request #365 from LoopPerfect/fix/ssh remove ssh prefix and update nuget.config

view details

Gaetano Checinski

commit sha 1718925c188042c5a0ff11cc374f4d9e4a769125

Merge branch 'master' into feat/multi-manifest

view details

push time in 2 months

push eventLoopPerfect/buckaroo

Gaetano Checinski

commit sha 57c0b9ec16be2ae2aeed41ab521fbf992b8d91b7

adds manifestType

view details

push time in 2 months

create barnchLoopPerfect/buckaroo

branch : feat/multi-manifest

created branch time in 2 months

fork nikhedonia/create-react-app

Set up a modern web app by running one command.

https://create-react-app.dev

fork in 2 months

IssuesEvent

issue commentLoopPerfect/buckaroo

Loading macros from buckaroo dependencies

hmm i'm pretty sure that worked in the past. I'll try to reproduce this on my machine later.. @njlr do you think there was a breaking API change in Buck or Buckaroo?

roey-e

comment created time in 2 months

issue closedLoopPerfect/buckaroo

How to add specific version on a specific branch of git repo?

How are you supposed to buckaroo add a certain commit version of a github package? The [@<version>] just doesn't work, except when the [@<version>] is a tag.

So, here's an example: $ buckaroo add github.com/SFML/SFML@50e173e403ef8912e3d8ac3c7ab3e27e32243339 Error in Ln: 1 Col: 28 add github.com/SFML/SFML@50e173e403ef8912e3d8ac3c7ab3e27e32243339                                                ^ Expecting: decimal digit, end of input, whitespace, '--cache-first', '--verbose' or '.'

This is the commit: https://github.com/SFML/SFML/commit/50e173e403ef8912e3d8ac3c7ab3e27e32243339

As of right now, this is completely unusable.

Arch Linux 5.6.3-arch1-1

closed time in 3 months

SeanRamey

issue closedLoopPerfect/buckaroo

installing a package

Installed buckaroo and was now in the process of installing a package but it just show this weird error below.

Error in Ln: 1 Col: 9 install ericniebler/range-v3 ^ Expecting: end of input, '--cache-first' or '--verbose'

I have everything installed. My OS is Deepin and the default python system version is 2.7 but i also have 3 installed. should i change the python version to make it work or???????

closed time in 3 months

jim4067

issue closedLoopPerfect/buckaroo

No usable version of libssl found

<!--- Provide a general summary of the issue in the Title above -->

Description

<!--- Provide a more detailed introduction to the issue itself, and why you consider it to be a bug --> I'm trying to start using this but I can't add a dependency because no usable version of libssl found.

Expected Behavior

<!--- Tell us what should happen --> As a "standalone executable" it would work on a typical ubuntu system.

Actual Behavior

<!--- Tell us what happens instead --> Returned error: No usable version of the libssl was found

Steps to Reproduce

<!--- Provide a link to a live example, or an unambiguous set of steps to --> <!--- reproduce this bug. Include code to reproduce, if relevant -->

  1. buckaroo init
  2. buckaroo add buckaroo add github.com/wxWidgets/wxWidgets@tag=v2.8.12

image

Context

<!--- How has this bug affected you? What were you trying to accomplish? --> I am trying to take an old cmake project out of the stone age but I couldn't get dependencies to resolve on Windows (I may log a bug for that later) and I can't seem to get it to work on my linux system either.

Your Environment

<!--- Include as many relevant details about the environment you experienced the bug in -->

  • Version used: 2.2.0
  • Operating System and Architecture: Ubuntu 19.10, x64

closed time in 3 months

joe-sonrichard

fork nikhedonia/ksm

A fast, hackable and simple x64 VT-x hypervisor for Windows and Linux. Builtin userspace sandbox and introspection engine.

https://asamy.github.io/ksm/

fork in 3 months

issue commentLoopPerfect/buckaroo

installing a package

Hey thanks for taking Buckaroo for a spin! packages are added via the add command followed by a URI eg.:

buckaroo add github.com/buckaroo-pm/ericniebler-range-v3@branch=master

Python is not used by buckaroo but might be needed by one of the dependencies.

jim4067

comment created time in 3 months

issue commentLoopPerfect/buckaroo

add support for git sparse-checkout

This is how one can initialize a git repository and fetch just a subset of files:

git clone only one folder:
git init
git remote add origin $GIT_URL
git checkout -b master
git config core.sparsecheckout true
echo include/* >> .git/info/sparse-checkout #pattern 
git pull origin master --depth=N  # branch which you want to pull
nikhedonia

comment created time in 3 months

startedtfhe/tfhe

started time in 3 months

issue commentLoopPerfect/buckaroo

No usable version of libssl found

hmm... As far as I remember sfml doesn't have libssl as a dependency.

Could you post your buckaroo.toml and buckaroo.lock.toml (if available)?

joe-sonrichard

comment created time in 3 months

issue commentLoopPerfect/buckaroo

No usable version of libssl found

Thanks for opening your issue. First of all: buckaroo needs a buckaroo.toml to be present in the project's repository. It doesn't look like wxWidget has not been ported yet.

Some libraries have been ported to buckaroo and are available here: https://github.com/buckaroo-pm

Regarding the error message, I think we should provide an explanation why no version could be found.

joe-sonrichard

comment created time in 3 months

issue commentLoopPerfect/buckaroo

How to add specific version on a specific branch of git repo?

Thanks for opening this issue.

Buckaroo currently uses a slightly more verbose syntax of @revision=<HASH> and can only install packages that have a buckaroo.toml in it's repository.

We forked SFML and added a buckaroo.toml here: https://github.com/buckaroo-pm/SFML

Hence you can install it via:

buckaroo add github.com/buckaroo-pm/SFML@revision=cb1fecade04b317eb763ad8b07f288319ce4e9a1

or

buckaroo add github.com/buckaroo-pm/SFML@branch=master
SeanRamey

comment created time in 3 months

starteddfranx/SPIRV-VM

started time in 3 months

startedshuveb/io_uring-by-example

started time in 3 months

more