profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/mackworth/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.

mackworth/cTiVo 210

TiVo Show Downloads for MacOS

mackworth/MediaInfoKit 5

An OS X wrapper of mediainfo lib for Objective-C and Swift projects

mackworth/tivodecode-ng 1

The "next generation" of tivodecode, to handle transport streams. Not fully working yet.

mackworth/Apple-Boost-BuildScript 0

Script for building Boost for Apple platforms (iOS, iOS Simulator, tvOS, tvOS Simulator, OS X)

mackworth/BEMSimpleLineGraph 0

Elegant Line Graphs for iOS. (Charting library)

mackworth/ccextractor 0

CCExtractor - Carlos' version (mainstream).

mackworth/CocoaLumberjack 0

A fast & simple, yet powerful & flexible logging framework for Mac and iOS

mackworth/Core-Data-Editor 0

Core Data Editor lets you easily view, edit and analyze applications‘ data. Core Data Editor is compatible with Mac and iOS applications and supports XML, SQLite and binary stores, visualizes all relationships and is able to edit the data and generate Objective-C code for the data model.

mackworth/ImportPhotoFolders 0

Import a folder hierarchy as albums into OS X Photos.

mackworth/ingredient-phrase-tagger 0

Fork of the NY Times tagger with improved testing, bugfixes

issue commentmmshivesh/Python-Nova.novaextension

How to run python with nova?

Any suggestion on how to get it to be interactive? (e.g. I'd like to run pub

ma3252788

comment created time in a month

fork mackworth/ingredient-phrase-tagger

Fork of the NY Times tagger with improved testing, bugfixes

https://zestfuldata.com

fork in 2 months

issue commentmackworth/cTiVo

File downloads but doesn't encode

So, you've got two unusual things happening with that download.
From the logs

2021-07-28 20:04:04:222 -[NSString(Helpers) setXAttr:toValue:]@175>XAttr error 2 for setting com.ctivo.filecomplete to 433250 for file /Volumes/Elements 12TB/zctivotemp/bufferJeopardy! - S37E178 - LeVar Burton.mpg
2021-07-28 21:07:23:057 -[MTAppDelegate launchPseudoEvent]@444>Looks like cTiVo was frozen out for 34 seconds

The first one is an OS error while trying to mark the file as complete. That could indicate your system needs to be rebooted, or that you're having hardware trouble with the drive itself. Secondly, your system froze up for 30 seconds a couple minutes later. So I'd first reboot, then maybe run a disk test. If that's ok, just try the download again.

I note also that you're doing a lot of retries for Transport v Program. Did you configure your system to force PS on certain channels? It seems to try PS every time and after failing, then doing TS and succeeding.

rqchin

comment created time in 2 months

issue commentmackworth/cTiVo

Constant restarts with Mac Big Sur

Good to hear!

slodiver

comment created time in 3 months

issue closedmackworth/cTiVo

Constant restarts with Mac Big Sur

Hello... I have been having problems getting my Tivo recordings over to my Mac (2019 3GHz 6-core Intel Core I5 with 40GB of RAM) ever since I upgraded to macOS Catalina. I thought that it might fix itself when I upgraded to Big Sur, but it hasn't. I did a complete erase and install but I did save my settings. CTivo is the only program that creates this crash. I have been using CTivo with great success for quite some time and would love to see this resolved. I've attached my most recent error log. It seems to trigger a kernel panic but I can't figure it out. Can you help? Thanks! Chad

Error log.txt

closed time in 3 months

slodiver

issue commentmackworth/cTiVo

Constant restarts with Mac Big Sur

Just going back through old issues; any luck here?

slodiver

comment created time in 3 months

issue commentmackworth/cTiVo

closed captions in transcoding

Good to hear.

petersbar

comment created time in 3 months

issue closedmackworth/cTiVo

closed captions in transcoding

I am sure this is not an "issue" but user error. my recording on tivo has no captions but when transcoded to the mac using cTivo, it has them.

the only option I saw was to "export captions" which was checked off. please help this user :)

closed time in 3 months

petersbar

issue closedmackworth/cTiVo

De-Sync'ing Video/Audio

Exporting Tivo Hallmark recordings from Romeo to CTivo - format ProRes LT to new Mac mini. latest Apple OS (apple silicon) Edit with Final Cut Pro to cut out commercials. "share" to .mp3 file for use in Plex server/client

Output progressively looses video/audio sync as you go from the start to end of the movie.

Anyone familiar with this condition (and maybe a solution). The problem has way too many variables to figure it out from scratch. Especially if someone has already been through it...

closed time in 3 months

bop3162

issue commentmackworth/cTiVo

De-Sync'ing Video/Audio

So, I take it this is resolved?

bop3162

comment created time in 3 months

issue commentmackworth/cTiVo

Downloads have serious audio and visual glitches

Oh, another suggestion if you still have the older TiVo. Transfer the files to that one to see if you get a successful download from there

dono16874

comment created time in 3 months

issue commentmackworth/cTiVo

Downloads have serious audio and visual glitches

Not really. You could check your signal strength in the TiVo help menus, but I'm hearing the Edge appears to be problematic for downloads, creating damaged files much more often. Frankly, TiVo no longer seems to care about the DVR business.

There is some more discussion here about errors.

You say all downloads. Is that true for your local channels as well as cable-only ones? Look in Edit Channels, are all the channels TS?

There's some speculation that this is due to too fast a download from the Echo. If you want to give it a try, I could create a version that tries slower speeds.

dono16874

comment created time in 3 months

issue commentmackworth/cTiVo

closed captions in transcoding

First, even if your TiVo isn't showing captions, the show apparently has them; cTiVo can't create them.

More surprising would be if it's running the caption task, even when export captions is off. I note that there are several places to control that, at the application level, the subscription level, and the individual download, so check that the Subtitle checkbox is off in the Download Queue (middle table in main window). If Subtitle column is not visible, you may have to turn on this column by control-clicking in the header of the table.

If it is turned off there and you're getting captions in the downloaded file, then go to Preferences, set DebugLevel to Major and download another show. When complete, go to Help>Show logs in Finder. Then Control-Click on the log folder, choose Compress. Then post that compressed file as an attachment to this issue on GitHub's website (don't use the Reply to email, as it deletes attachments). That will enable me to see what's going on with your system.

petersbar

comment created time in 3 months