profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/kenangundogan/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Kenan Gündoğan kenangundogan Habertuk, Bloomberght, Showtv istanbul/Turkey https://www.behance.net/kenangundogan ui / ux designer & developer linkedin.com/in/kenangundogan

kenangundogan/fontisto 448

The iconic font and CSS toolkit. Fontisto gives you scalable vector icons that can instantly be customized: size, color, drop shadow and anything that can be done with the power of CSS.

kenangundogan/flexible-grid 154

Flexible grid layouts to get you familiar with building within the flexible grid system.(HTML, CSS, SASS, SCSS)

kenangundogan/madosel 38

Modasel is a family of responsive front-end frameworks that make it easy to design beautiful responsive websites, apps that look amazing on any device. Madosel is semantic, readable, flexible, and completely customizable.

volkansengul/react-example-todo 32

React Example Todo Application

kenangundogan/gulpSassCompiler 7

Gulp Sass/Scss Compiler (autoprefix, sourcemaps, minify, file-rename, browser-sync)

kenangundogan/Smart-Float-Grid-Framework 3

Simple grid layouts to get you familiar with building within the "GRID FRAMEWORK (FLOAT)" grid system.

kenangundogan/SmartFlex-Flex-Grid-Framework 3

Simple grid layouts to get you familiar with building within the "SMART FLEX" grid system.

kenangundogan/javascript-accordion 2

Javascript accordion - tiny and simple.

kenangundogan/fontisto-browser-extension 1

Fontisto Browser Extension

kenangundogan/javascript-navigation-tabs 1

Javascript navigation tabs - tiny and simple.

startedumutyaldiz/webpackes6toes5

started time in 4 days

PR merged kenangundogan/madosel

Bump style-loader from 2.0.0 to 3.0.0 dependencies

Bumps style-loader from 2.0.0 to 3.0.0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/style-loader/releases">style-loader's releases</a>.</em></p> <blockquote> <h2>v3.0.0</h2> <h2><a href="https://github.com/webpack-contrib/style-loader/compare/v2.0.0...v3.0.0">3.0.0</a> (2021-06-24)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported <code>Node.js</code> version is <code>12.13.0</code></li> <li>minimum supported <code>webpack</code> version is <code>5.0.0</code></li> <li>the <code>modules.namedExport</code> option was removed, you don't need it anymore, because we respect the <code>modules.namedExport</code> option from <code>css-loader</code> (we just reexport all from <code>css-loader</code>), just remove it</li> <li>the <code>styleTag</code> value of the <code>injectType</code> (default value) option earlier uses singleton style tag by default for IE8-IE9 due limitations (<a href="https://www.telerik.com/blogs/internet-explorer-css-limits">more information</a>), in this release we have disabled this behavior, because these versions of IE are outdated, if you don't support these browsers this change does not affect you, if you require to support IE8-IE9, you can return old behaviour by setting <code>autoStyleTag</code> value for the <code>injectType</code> option (do the same for <code>lazyStyleTag</code>, i.e. change it to <code>lazyAutoStyleTag</code>)</li> </ul> <h3>Features</h3> <ul> <li>added <code>autoStyleTag</code> and <code>lazyAutoStyleTag</code> values for the <code>injectType</code> option for compatibility of work modern and IE8-IE9 browsers</li> <li>added <code>styleTagTransform</code> option for custom processing style tags (useful if you need ponyfill CSS custom properties for IE8-IE10)</li> <li>reduce size of generated code</li> <li>reduce deps</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/style-loader/blob/master/CHANGELOG.md">style-loader's changelog</a>.</em></p> <blockquote> <h2><a href="https://github.com/webpack-contrib/style-loader/compare/v2.0.0...v3.0.0">3.0.0</a> (2021-06-24)</h2> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported <code>Node.js</code> version is <code>12.13.0</code></li> <li>minimum supported <code>webpack</code> version is <code>5.0.0</code></li> <li>the <code>modules.namedExport</code> option was removed, you don't need it anymore, because we respect the <code>modules.namedExport</code> option from <code>css-loader</code> (we just reexport all from <code>css-loader</code>), just remove it</li> <li>the <code>styleTag</code> value of the <code>injectType</code> (default value) option earlier uses singleton style tag by default for IE8-IE9 due limitations (<a href="https://www.telerik.com/blogs/internet-explorer-css-limits">more information</a>), in this release we have disabled this behavior, because these versions of IE are outdated, if you don't support these browsers this change does not affect you, if you require to support IE8-IE9, you can return old behaviour by setting <code>autoStyleTag</code> value for the <code>injectType</code> option (do the same for <code>lazyStyleTag</code>, i.e. change it to <code>lazyAutoStyleTag</code>)</li> </ul> <h3>Features</h3> <ul> <li>added <code>autoStyleTag</code> and <code>lazyAutoStyleTag</code> values for the <code>injectType</code> option for compatibility of work modern and IE8-IE9 browsers</li> <li>added <code>styleTagTransform</code> option for custom processing style tags (useful if you need ponyfill CSS custom properties for IE8-IE10)</li> <li>reduce size of generated code</li> <li>reduce deps</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/webpack-contrib/style-loader/commit/1556c0b16a7e16b255d85f7a25ed95bb16a01471"><code>1556c0b</code></a> chore(release): 3.0.0</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/5238a1591baab9649a34faac1e879a6dbd7f7305"><code>5238a15</code></a> refactor: next (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/501">#501</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/99c6500bc27a48a7442168dca3f26d04f2da95b5"><code>99c6500</code></a> ci: update nodejs.yml (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/515">#515</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/aee299784bc35defb62c7d2d1aec695c62ae0b78"><code>aee2997</code></a> chore: update deps (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/516">#516</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/0b9ec95755c2d2c03b36d6f9f505c3d4f244e5fb"><code>0b9ec95</code></a> chore: fix typo (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/512">#512</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/7cfe35e27333138a06f353744fabcd51fd53a884"><code>7cfe35e</code></a> chore: update deps and fix audit (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/514">#514</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/d9eee64336b786d1b6fd50cb893ab5ef57bc2bda"><code>d9eee64</code></a> docs: recommend (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/507">#507</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/d34313a89c7bbc60aa3890af583f9fd6a32e5392"><code>d34313a</code></a> docs: fix link on webpack-dll-plugins (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/500">#500</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/6134c6e3909c988cef06c36810e013fbd9064d7b"><code>6134c6e</code></a> chore(deps): update (<a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/499">#499</a>)</li> <li><a href="https://github.com/webpack-contrib/style-loader/commit/256b1c38b6a729df3516e722173288d146676482"><code>256b1c3</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/webpack-contrib/style-loader/issues/492">#492</a> from webpack-contrib/ci-updated</li> <li>Additional commits viewable in <a href="https://github.com/webpack-contrib/style-loader/compare/v2.0.0...v3.0.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 months

push eventkenangundogan/madosel

dependabot[bot]

commit sha e88798d092c2c88d4b623a103971336757eaa49d

Bump style-loader from 2.0.0 to 3.0.0 Bumps [style-loader](https://github.com/webpack-contrib/style-loader) from 2.0.0 to 3.0.0. - [Release notes](https://github.com/webpack-contrib/style-loader/releases) - [Changelog](https://github.com/webpack-contrib/style-loader/blob/master/CHANGELOG.md) - [Commits](https://github.com/webpack-contrib/style-loader/compare/v2.0.0...v3.0.0) --- updated-dependencies: - dependency-name: style-loader dependency-type: direct:development update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Kenan Gündoğan

commit sha 7f4890ad50bd7e0330efba07b41d2f9bdc899c62

Merge pull request #31 from kenangundogan/8ca2dependabot/npm_and_yarn/style-loader-3.0.0 Bump style-loader from 2.0.0 to 3.0.0

view details

push time in 3 months

push eventkenangundogan/madosel

dependabot[bot]

commit sha f3db9206f2b3968f8fd77380583b37d493e1c202

Bump mini-css-extract-plugin from 1.6.2 to 2.0.0 Bumps [mini-css-extract-plugin](https://github.com/webpack-contrib/mini-css-extract-plugin) from 1.6.2 to 2.0.0. - [Release notes](https://github.com/webpack-contrib/mini-css-extract-plugin/releases) - [Changelog](https://github.com/webpack-contrib/mini-css-extract-plugin/blob/master/CHANGELOG.md) - [Commits](https://github.com/webpack-contrib/mini-css-extract-plugin/compare/v1.6.2...v2.0.0) --- updated-dependencies: - dependency-name: mini-css-extract-plugin dependency-type: direct:development update-type: version-update:semver-major ... Signed-off-by: dependabot[bot] <support@github.com>

view details

Kenan Gündoğan

commit sha 733e80dce5a46e69e3928cd1ea9ddf9de313915e

Merge pull request #32 from kenangundogan/b599dependabot/npm_and_yarn/mini-css-extract-plugin-2.0.0 Bump mini-css-extract-plugin from 1.6.2 to 2.0.0

view details

push time in 3 months

PR merged kenangundogan/madosel

Bump mini-css-extract-plugin from 1.6.2 to 2.0.0 dependencies

Bumps mini-css-extract-plugin from 1.6.2 to 2.0.0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/mini-css-extract-plugin/releases">mini-css-extract-plugin's releases</a>.</em></p> <blockquote> <h2>v2.0.0</h2> <h2><a href="https://github.com/webpack-contrib/mini-css-extract-plugin/compare/v1.6.2...v2.0.0">2.0.0</a> (2021-06-30)</h2> <h3>NOTES</h3> <p>In the current release we have fixed many problems with <code>publicPath</code>, previously to generate relative URLs inside CSS files developers use different hacks: <code>publicPath: ''</code>, <code>publicPath: '../'</code>, using relative <code>../../</code> in the <code>outputPath</code> option for <code>file-loader</code> and etc. Now you don't need it anymore. Webpack v5 uses <code>publicPath: "auto"</code> by default, which means to always generate relative URLs, and now <code>mini-css-extract-plugin</code> does the same.</p> <p><strong>We strongly recommend use <code>auto</code> value by default (except when using CDN).</strong></p> <p><strong>We also want to show you that the <a href="https://github.com/webpack-contrib/file-loader"><code>file-loader</code></a> and <a href="https://github.com/webpack-contrib/url-loader"><code>url-loader</code></a> are outdated, please migrate on <a href="https://webpack.js.org/guides/asset-modules/">Asset Modules</a>.</strong></p> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported <code>Node.js</code> version is <code>12.13.0</code></li> <li>minimum supported <code>webpack</code> version is <code>5.0.0</code></li> <li>the <code>modules.namedExport</code> option was removed, you don't need it anymore, because we respect the <code>modules.namedExport</code> option from <code>css-loader</code>, just remove it</li> <li>the <code>publicPath</code> option no longer automatically adds <code>/</code> (trailing slash), you need to specify, you need to specify it yourself if it is absent, i.e. if you have <code>publicPath: "/my/public/path"</code> replace it with <code>publicPath: "/my/public/path/"</code></li> </ul> <h3>Bug Fixes</h3> <ul> <li>generating correct relative <code>url()</code> for assets inside CSS files when you use <code>publicPath: "auto"</code> (default value)</li> </ul> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/webpack-contrib/mini-css-extract-plugin/blob/master/CHANGELOG.md">mini-css-extract-plugin's changelog</a>.</em></p> <blockquote> <h2><a href="https://github.com/webpack-contrib/mini-css-extract-plugin/compare/v1.6.2...v2.0.0">2.0.0</a> (2021-06-30)</h2> <h3>NOTES</h3> <p>In the current release we have fixed many problems with <code>publicPath</code>, previously to generate relative URLs inside CSS files developers use different hacks: <code>publicPath: ''</code>, <code>publicPath: '../'</code>, using relative <code>../../</code> in the <code>outputPath</code> option for <code>file-loader</code> and etc. Now you don't need it anymore. Webpack v5 uses <code>publicPath: "auto"</code> by default, which means to always generate relative URLs, and now <code>mini-css-extract-plugin</code> does the same.</p> <p><strong>We strongly recommend use <code>auto</code> value by default (except when using CDN).</strong></p> <p><strong>We also want to show you that the <a href="https://github.com/webpack-contrib/file-loader"><code>file-loader</code></a> and <a href="https://github.com/webpack-contrib/url-loader"><code>url-loader</code></a> are outdated, please migrate on <a href="https://webpack.js.org/guides/asset-modules/">Asset Modules</a>.</strong></p> <h3>⚠ BREAKING CHANGES</h3> <ul> <li>minimum supported <code>Node.js</code> version is <code>12.13.0</code></li> <li>minimum supported <code>webpack</code> version is <code>5.0.0</code></li> <li>the <code>modules.namedExport</code> option was removed, you don't need it anymore, because we respect the <code>modules.namedExport</code> option from <code>css-loader</code>, just remove it</li> <li>the <code>publicPath</code> option no longer automatically adds <code>/</code> (trailing slash), you need to specify, you need to specify it yourself if it is absent, i.e. if you have <code>publicPath: "/my/public/path"</code> replace it with <code>publicPath: "/my/public/path/"</code></li> </ul> <h3>Bug Fixes</h3> <ul> <li>generating correct relative <code>url()</code> for assets inside CSS files when you use <code>publicPath: "auto"</code> (default value)</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/webpack-contrib/mini-css-extract-plugin/commit/794b60228d9800c7812e206953066197b486cf3d"><code>794b602</code></a> chore(release): 2.0.0</li> <li><a href="https://github.com/webpack-contrib/mini-css-extract-plugin/commit/f6223b60bc6118d92193a92761882ac4592b94c1"><code>f6223b6</code></a> fix: engines field (<a href="https://github-redirect.dependabot.com/webpack-contrib/mini-css-extract-plugin/issues/777">#777</a>)</li> <li><a href="https://github.com/webpack-contrib/mini-css-extract-plugin/commit/935add45621394fdd2cf3d7b60a304ae428ca38a"><code>935add4</code></a> refactor: reduce deps</li> <li><a href="https://github.com/webpack-contrib/mini-css-extract-plugin/commit/35a9efec217017b65f3b1fe849c8a5e396e8f309"><code>35a9efe</code></a> refactor!: next</li> <li>See full diff in <a href="https://github.com/webpack-contrib/mini-css-extract-plugin/compare/v1.6.2...v2.0.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 3 months