profile
viewpoint

Ask questionsAttributeError: module 'pykwalify.core' has no attribute 'yaml'

Hello, it looks like pykwalify has had a new release (1.8) which is breaking my tavern build with the following error:

ve/lib/python3.8/site-packages/tavern/schemas/files.py:16: in <module>
    core.yaml.safe_load = functools.partial(yaml.load, Loader=IncludeLoader)
E   AttributeError: module 'pykwalify.core' has no attribute 'yaml'

It looks like pykwalify has dropped/changed their default yaml parser which may be the culprit?

Could we maybe get tavern pinned to pykwalify 1.7 until it's fixed?

https://github.com/Grokzen/pykwalify/releases https://github.com/taverntesting/tavern/blob/master/setup.cfg#L34

taverntesting/tavern

Answer questions Safihre

Thank you! Happily running again.

useful!

Related questions

No questions were found.
source:https://uonfu.com/
Github User Rank List