profile
viewpoint

Ask questionsnightly version fails: invalid version 3 on git_proxy_options; class=Invalid (3)

On FreeBSD 12 amd64 rust-nightly-1.38.0.20190811_1 fails:

$ cargo build
    Updating crates.io index
error: failed to load source for a dependency on `image`

Caused by:
  Unable to update registry `https://github.com/rust-lang/crates.io-index`

Caused by:
  failed to fetch `https://github.com/rust-lang/crates.io-index`

Caused by:
  invalid version 3 on git_proxy_options; class=Invalid (3)

Project: https://github.com/Twinklebear/bspline

rust-lang/rust

Answer questions yurivict

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239785

useful!

Related questions

Spurious NaNs produced by trig functions with valid inputs on Windows GNU toolchains hot 2
using 'cargo install xsv' on windows 10 triggers rustc internal error hot 1
chain() make collect very slow hot 1
if/while Some(n) = &mut foo sugar will leak a temporary mutable borrow to current scope in particular situation hot 1
build an empty project failed (undefined reference to `__onexitbegin') hot 1
Invalid collision with TryFrom implementation? hot 1
Crater runs for Rust 1.38.0 hot 1
Spurious NaNs produced by trig functions with valid inputs on Windows GNU toolchains hot 1
under latest MinGW, cannot link with C code using stdout hot 1
Archive all nightlies hot 1
Building LLVM with Clang fails hot 1
Internal compiler error: can't buffer lints after HIR lowering hot 1
Tracking issue for `Option::contains` and `Result::contains` hot 1
async fn + rustfmt don't "just work" inside of RLS hot 1
Some closures are not inlined in release mode hot 1
Github User Rank List