profile
viewpoint

Ask questionsRemove python 2.7 as requirement from the README.md

Python 2.7 is dead. No "if"s, no "but"s, no "we're keeping it around because...": it's well and truly dead,

Given that it got killed on January first, 2020, which is nearing two months ago, can we remove it from the README.md as a valid requirement? (as well as everywhere else it's still being referenced?)

nodejs/node-gyp

Answer questions rvagg

Yeah, it's still on 5.0.5 and unfortunately people are still directed here for details on what to install with native addons. Maybe once we get npm out with ^5.1.0 we can start being more aggressive with our README?

useful!

Related questions

Error: `gyp` failed with exit code: 1 at ChildProcess.onCpExit hot 2
node-gyp: EPERM: operation not permitted, read hot 2
Visual Studio finder is doing a case-sensitive path check hot 2
node-gyp rebuild failed hot 1
Node gyp build fails on node v12.1.0 hot 1
node-pre-gyp build fail error while installing with `npm install` or `npm install -d` hot 1
Is this an Issue with MACOS catalina? hot 1
gyp ERR! stack Error: `make` failed with exit code: 2 hot 1
gyp ERR! stack Error: `make` failed with exit code: 2 hot 1
Is this an Issue with MACOS catalina? hot 1
Is this an Issue with MACOS catalina? hot 1
Not able to build in osx 10.14.2 with java 10.0.1 hot 1
npm install error on windows 10 hot 1
TypeError: '>=' not supported between instances of 'tuple' and 'str' hot 1
Breaks with VS2019 installed hot 1
Github User Rank List