profile
viewpoint

Ask questionsError: "Could not load any valid magic files"

We have user reports of failures on Fedora 30 and Debian 9.11 with Error: "Could not load any valid magic files".

Are there some extra dependencies that need to be installed for some distributions?

mscdex/mmmagic

Answer questions mscdex

The only "dependency" is that any custom (including OS-provided) magic database file be compatible with the version of libmagic included in mmmagic. If the built-in magic database file is used, there should be no issue.

You might also check that there isn't something like a MAGIC environment variable set which could override the magic database file being used.

useful!

Related questions

No questions were found.
Github User Rank List