profile
viewpoint

Ask questionsparsing fails when %YAML version is 1.2

Go-yaml fails to parse the following YAML 1.2 document with the error "found incompatible YAML document". It currently fails for any version other than 1.1.

%YAML 1.2
--- text
go-yaml/yaml

Answer questions niemeyer

Will certainly take that idea into account, thanks for suggesting it.

useful!

Related questions

v3 panics on bad input hot 1
v3 equivalent of v2's MapSlice and MapItem? hot 1
unmarshal with comments provide wrong structure hot 1
Head comments in list elements misplaced hot 1
source:https://uonfu.com/
Github User Rank List