profile
viewpoint

Ask questions ReferenceError: SHA-1 for file [(...).png] is not computed

[0] sha1 3aabc4bf20662c004fea1fc5fada45d88cb21c74 file [...]/src/parallaximage/ParallaxImage.js
[0] sha1 48bd39bdb03d630a2cb85c12c736d2fb74392609 file [...]/src/utils/animations.js
[0] sha1 1e735cdb78d49457628797acfbfcfdc958c9e0e9 file [...]/node_modules/react-native-svg/index.js
[0] sha1 null file [...]/assets/bitcoin-large.png
[0] sha1 null file [...]/assets/campaign-lime.png
[0] sha1 null file [...]/assets/campaign-orange.png
[0] sha1 null file [...]/assets/campaign-pink.png
[0] sha1 null file [...]/assets/campaign-cyan.png

output for: console.log('sha1', sha1, 'file', filename) at /node_modules/metro/src/node-haste/DependencyGraph.js:257

There is no sha1 generated for png and jpg files after react native upgrade, not sure how to fix that

rn-cli-config.js

// const path = require('path')
// const cwd = path.resolve(__dirname)

module.exports = {
  // transformer: {
  //   babelTransformerPath: path.resolve(__dirname, './config/transformers.js'),
  // },
  resolver: {
    sourceExts: ['jsx', 'js'],
    assetExts: ['png', 'jpg']
  },
  // projectRoot: cwd
}
facebook/metro

Answer questions tkulpa

it was related to project packager start command that was yarn build:tsc && node_modules/.bin/concurrently 'react-native start' 'npm run copy -- --watch' 'npm run watch:tsc after starting everything separately everything is fine And it worked for react native 0.57 version and happens on 0.59.8

useful!

Related questions

i have local javascript library How do i config metro.config.js hot 2
`SHA-1 for file ... is not computed` when using `resolver.resolveRequest` hot 1
metro-config sharedBlacklist regexp without scape "\" hot 1
Follow symlinks? hot 1
`SHA-1 for file ... is not computed` when using `resolver.resolveRequest` hot 1
metro-config sharedBlacklist regexp without scape "\" hot 1
bundleReleaseJsAndAssets slow for react-native 0.60 / node v12 combo hot 1
Error: Cannot find module 'metro/src/DeltaBundler/Worker' hot 1
concurrent builds fail due to shared use of /tmp/metro-cache/ hot 1
metro-config sharedBlacklist regexp without scape "\" hot 1
Minification can break code (but cannot be disabled?) hot 1
Error: Cannot find module 'metro/src/DeltaBundler/Worker' hot 1
RN - Error: jest-haste-map: @providesModule naming collision hot 1
Couldn't find preset "module:metro-react-native-babel-preset" when running jest hot 1
metro-config sharedBlacklist regexp without scape "\" hot 1
source:https://uonfu.com/
Github User Rank List