Ask questionsConsider adding scan
scan(_:combine:) not making the cut on the grounds of offering low utility. Is it possible for it to find a place here?
Answer questions pyrtsa
scan can be taken as a name of art (also used by Combine framework), but this might be a good opportunity to consider the term
reductions which is more noun-like, pairs up nicely with
reduce, is also used elsewhere, and has been proposed and supported in the past for Swift.
The term scan is established e.g. in Haskell, but in Haskell what we call reduce is known by a different name too: it's a fold.
Related questionsNo questions were found.