profile
viewpoint

Ask questionsAngular 10. CommonJS or AMD dependencies can cause optimization bailouts

After update to angular 10. I got this warning.

WARNING in ...\projects\client\src\app\localization.ts depends on devextreme/localization/globalize/date. CommonJS or AMD dependencies can cause optimization bailouts.

after read link "https://angular.io/guide/build#configuring-commonjs-dependencies" i made this

	"build": {
		"builder": "@angular-devkit/build-ng-packagr:build",
		"options": {
			"allowedCommonJsDependencies": [
				"lodash",
				"devextreme-angular",
				"devextreme",
				"@firebase",
				"@angular/fire",
				"devexpress-richedit",
				"x-data-spreadsheet"
			],
			"tsConfig": "projects/core/tsconfig.lib.json",
			"project": "projects/core/ng-package.json"
		}
	}

But this don`t help me.

What i doing wrong?

angular/angular-cli

Answer questions alan-agius4

@BlindDespair, let's continue tracking this https://github.com/angular/angular-cli/issues/18058 since it's has more details. @ahmadmu, see https://github.com/angular/angular-cli/issues/18057

useful!
source:https://uonfu.com/
answerer
Alan Agius alan-agius4 Malta Angular Team, Loves TypeScript, Build Tools, Food, Beer & Coffee 🇲🇹
Github User Rank List