profile
viewpoint

Ask questions3.8 Support

I have a test runner that uses Pyre as an option for type-checking, ptr. I put up a diff to move CI to start using official 3.8 for test running on travis and this results in the expected ValueError:

raise ValueError(
ValueError: LibCST can only parse code using one of the following versions of Python's grammar: 3.5, 3.6, 3.7. More versions may be supported by future releases.
  • CI Job: https://travis-ci.com/facebookincubator/ptr/jobs/247724096

What is there an expected timeframe for 3.8 support? I will have the tool not run pyre for now in >=3.8. What's the thoughts on possibly adding a section to the README explaining the 3.8 support plans with 3.8 being an official version now?

Instagram/LibCST

Answer questions bgw

Not sure why mentioning this in a comment auto-closed on merge

:laughing:

Screenshot from 2019-10-28 17-20-48

Certain keywords, like "closes" and "fixes" can be used to auto-close issues, however github isn't context sensitive. https://help.github.com/en/github/managing-your-work-on-github/closing-issues-using-keywords

useful!

Related questions

No questions were found.
Github User Rank List