profile
viewpoint

Ask questionsAAD Domain Service create/update fails with Request_InvalidDataContractVersion

Bug Report

  • import path: "github.com/Azure/azure-sdk-for-go/services/domainservices/mgmt/2017-06-01/aad"
  • SDK version: v24.1.0
  • go version go1.11.4 darwin/amd64

I'm trying to create a Azure AD Domain Service resource, but the API returns Request_InvalidDataContractVersion while using the azure-sdk-for-go@v24.1.0

/subscriptions/{subscriptionid}/resourceGroups/{resourceGroup}/providers/Microsoft.AAD/domainServices/{domainServiceName}?api-version=2017-06-01

{
	"odata.error": {
		"code": "Request_InvalidDataContractVersion",
		"message": {
			"lang": "en",
			"value": "The specified api-version is invalid. The value must exactly match a supported version."
		}
	}
}
Azure/azure-sdk-for-go

Answer questions tiwood

West Europe

useful!

Related questions

SDK equivalent for CLI "az aks install-connector" hot 1
storage.ManagementPoliciesClient.CreateOrUpdate Failed with RequestIsNotValidJson hot 1
Authentication example needed hot 1
`go get` latest fails due to UUID usage hot 1
[Recovery Services] Vague error messages when updating a policy hot 1
Cannot unmarshal ServicePrincipalListResult in call to graphrbac client.List hot 1
[Recovery Services] Vague error messages when updating a policy hot 1
go get module no matching versions for query "latest hot 1
Key Management API for Function App hot 1
Application insights frustration hot 1
Github User Rank List