profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/gekola/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.

gekola/openwhisk_docker_samples 10

Sample docker actions for IBM OpenWhisk

azhi/BSUIR_labs 1

Repo for university labs

gekola/acts_as_follower 0

A Gem to add Follow functionality for models

gekola/apulse 0

PulseAudio emulation for ALSA

gekola/bower-ui-grid 0

Bower package for UI Grid

gekola/bsuir-fp 0

BSUIR Functional Programming labs

gekola/capistrano-unicorn 0

Capistrano integration for Unicorn!

push eventgekola/overload

Nick H

commit sha 67717659a864400792a32c9d4c1d6dffb357b23a

dev-db/clickhouse fix protobuf dependency

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 3794fc152460404deedb3a63f7418441331babbd

dev-db/clickhouse add protobuf dependency

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha fe878dd4cfa2db71e6dc906341de5679169b29e5

dev-db/clickhouse add grpc dependency

view details

push time in 2 months

PR opened vaeth/mv-overlay

app-text/stardict: fix enchant dependency

With enchant:2 the following error occurs during configuration phase:

checking for enchant >= 1.2.0... no
configure: error: Enchant library not found or too old. Use --disable-spell to build without spell plugin.
configure: error: ./configure failed for dict
+2 -2

0 comment

2 changed files

pr created time in 2 months

push eventgekola/mv-overlay

Nick H

commit sha 0c86a570f56de6249131cdbe94481e6a657a0538

app-text/stardict: fix enchant dependency With enchant:2 the following error occurs: checking for enchant >= 1.2.0... no configure: error: Enchant library not found or too old. Use --disable-spell to build without spell plugin. configure: error: ./configure failed for dict

view details

push time in 2 months

create barnchgekola/mv-overlay

branch : stardict-fix-enchant

created branch time in 2 months

fork gekola/mv-overlay

The mv overlay for gentoo

fork in 2 months

issue closedgekola/overload

ungoogled-chromium build error: "import node" failed

I failed to build ungoogled-chromium-80.0.3987.149_p1

Error message was File "/var/tmp/portage/www-client/ungoogled-chromium-80.0.3987.149_p1/work/chromium-80.0.3987.149/third_party/devtools-frontend/src/scripts/build/../devtools_paths.py", line 43, in node_path import node ImportError: No module named node

Probably we should add something into BDEPEND ? Where is the source python package?

closed time in 2 months

krisk0

push eventgekola/xlsxwriter-rb

Nick H

commit sha 39c044e2a7a9fb35ab1bb36ffed701cc61e05009

Update travis-ci config

view details

push time in 2 months

delete branch gekola/xlsxwriter-rb

delete branch : dependabot/add-v2-config-file

delete time in 2 months

push eventgekola/xlsxwriter-rb

Nick H

commit sha bc993546929e40a2700b751bc77f1137a27d1d44

Update README

view details

push time in 2 months

push eventgekola/xlsxwriter-rb

Nick H

commit sha 6cdfbae7184f57e7d93d69260ab144c4d74ce264

Update travis-ci config

view details

push time in 2 months

PR closed gekola/xlsxwriter-rb

Upgrade to GitHub-native Dependabot dependencies

Dependabot Preview will be shut down on August 3rd, 2021. In order to keep getting Dependabot updates, please merge this PR and migrate to GitHub-native Dependabot before then.

Dependabot has been fully integrated into GitHub, so you no longer have to install and manage a separate app. This pull request migrates your configuration from Dependabot.com to a config file, using the new syntax. When merged, we'll swap out dependabot-preview (me) for a new dependabot app, and you'll be all set!

With this change, you'll now use the Dependabot page in GitHub, rather than the Dependabot dashboard, to monitor your version updates, and you'll configure Dependabot through the new config file rather than a UI.

If you've got any questions or feedback for us, please let us know by creating an issue in the dependabot/dependabot-core repository.

Learn more about migrating to GitHub-native Dependabot

Please note that regular @dependabot commands do not work on this pull request.

+12 -0

1 comment

1 changed file

dependabot-preview[bot]

pr closed time in 2 months

PR closed gekola/xlsxwriter-rb

[Security] Update rubyzip requirement from ~> 1.2 to ~> 2.3 dependencies security

⚠️ Dependabot Preview has been deactivated ⚠️

This pull request was created by Dependabot Preview, and you've upgraded to Dependabot. This means it won't respond to dependabot commands nor will it be automatically closed if a new version is found.

If you close this pull request, Dependabot will re-create it the next time it checks for updates and everything will work as expected.


Updates the requirements on rubyzip to permit the latest version. <details> <summary>Vulnerabilities fixed</summary> <p><em>Sourced from <a href="https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubyzip/CVE-2019-16892.yml">The Ruby Advisory Database</a>.</em></p> <blockquote> <p><strong>Denial of Service in rubyzip ("zip bombs")</strong> In Rubyzip before 1.3.0, a crafted ZIP file can bypass application checks on ZIP entry sizes because data about the uncompressed size can be spoofed. This allows attackers to cause a denial of service (disk consumption).</p> <p>Patched versions: >= 1.3.0 Unaffected versions: none</p> </blockquote> </details> <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/rubyzip/rubyzip/releases">rubyzip's releases</a>.</em></p> <blockquote> <h2>v2.3.2</h2> <p>No release notes provided.</p> <h2>v2.3.1</h2> <p>This is a "dummy" release to warn about breaking changes coming in version 3.0.</p> <h2>v2.3.0</h2> <ul> <li>Fix frozen string literal error <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/431">#431</a></li> <li>Set <code>OutputStream.write_buffer</code>'s buffer to binmode <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/439">#439</a></li> <li>Upgrade rubocop and fix various linting complaints <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/437">#437</a> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/440">#440</a></li> </ul> <p>Tooling:</p> <ul> <li>Add a <code>bin/console</code> script for development <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/420">#420</a></li> <li>Update rake requirement (development dependency only) to fix a security alert.</li> </ul> <h2>v2.2.0</h2> <ul> <li>Add support for decompression plugin gems <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/427">#427</a></li> </ul> <h2>v2.1.0</h2> <ul> <li>Fix (at least partially) the <code>restore_times</code> and <code>restore_permissions</code> options to <code>Zip::File.new</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/413">#413</a> <ul> <li>Previously, neither option did anything, regardless of what it was set to. We have therefore defaulted them to <code>false</code> to preserve the current behavior, for the time being. If you have explicitly set either to <code>true</code>, it will now have an effect.</li> <li>Fix handling of UniversalTime (<code>mtime</code>, <code>atime</code>, <code>ctime</code>) fields. <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/421">#421</a></li> <li>Previously, <code>Zip::File</code> did not pass the options to <code>Zip::Entry</code> in some cases. <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/423">#423</a></li> <li>Note that <code>restore_times</code> in this release does nothing on Windows and only restores <code>mtime</code>, not <code>atime</code> or <code>ctime</code>.</li> </ul> </li> <li>Allow <code>Zip::File.open</code> to take an options hash like <code>Zip::File.new</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/418">#418</a></li> <li>Always print warnings with <code>warn</code>, instead of a mix of <code>puts</code> and <code>warn</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/416">#416</a></li> <li>Create temporary files in the system temporary directory instead of the directory of the zip file <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/411">#411</a></li> <li>Drop unused <code>tmpdir</code> requirement <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/411">#411</a></li> </ul> <p>Tooling</p> <ul> <li>Move CI to xenial and include jruby on JDK11 <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/419/files">#419</a></li> </ul> <h2>v2.0.0</h2> <p>Security</p> <ul> <li>Default the <code>validate_entry_sizes</code> option to <code>true</code>, so that callers can trust an entry's reported size when using <code>extract</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/403">#403</a> <ul> <li>This option defaulted to <code>false</code> in 1.3.0 for backward compatibility, but it now defaults to <code>true</code>. If you are using an older version of ruby and can't yet upgrade to 2.x, you can still use 1.3.0 and set the option to <code>true</code>.</li> </ul> </li> </ul> <p>Tooling / Documentation</p> <ul> <li>Remove test files from the gem to avoid problems with antivirus detections on the test files <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/405">#405</a> / <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/384">#384</a></li> <li>Drop support for unsupported ruby versions <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/406">#406</a></li> </ul> <h2>v1.3.0</h2> <p>Security</p> <ul> <li>Add <code>validate_entry_sizes</code> option so that callers can trust an entry's reported size when using <code>extract</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/403">#403</a> <ul> <li>This option defaults to <code>false</code> for backward compatibility in this release, but you are strongly encouraged to set it to <code>true</code>. It will default to <code>true</code> in rubyzip 2.0.</li> </ul> </li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/rubyzip/rubyzip/blob/master/Changelog.md">rubyzip's changelog</a>.</em></p> <blockquote> <h1>2.3.2 (2021-07-05)</h1> <ul> <li>A "dummy" release to warn about breaking changes coming in version 3.0. This updated version uses the Gem <code>post_install_message</code> instead of printing to <code>STDERR</code>.</li> </ul> <h1>2.3.1 (2021-07-03)</h1> <ul> <li>A "dummy" release to warn about breaking changes coming in version 3.0.</li> </ul> <h1>2.3.0 (2020-03-14)</h1> <ul> <li>Fix frozen string literal error <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/431">#431</a></li> <li>Set <code>OutputStream.write_buffer</code>'s buffer to binmode <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/439">#439</a></li> <li>Upgrade rubocop and fix various linting complaints <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/437">#437</a> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/440">#440</a></li> </ul> <p>Tooling:</p> <ul> <li>Add a <code>bin/console</code> script for development <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/420">#420</a></li> <li>Update rake requirement (development dependency only) to fix a security alert.</li> </ul> <h1>2.2.0 (2020-02-01)</h1> <ul> <li>Add support for decompression plugin gems <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/427">#427</a></li> </ul> <h1>2.1.0 (2020-01-25)</h1> <ul> <li>Fix (at least partially) the <code>restore_times</code> and <code>restore_permissions</code> options to <code>Zip::File.new</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/413">#413</a> <ul> <li>Previously, neither option did anything, regardless of what it was set to. We have therefore defaulted them to <code>false</code> to preserve the current behavior, for the time being. If you have explicitly set either to <code>true</code>, it will now have an effect.</li> <li>Fix handling of UniversalTime (<code>mtime</code>, <code>atime</code>, <code>ctime</code>) fields. <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/421">#421</a></li> <li>Previously, <code>Zip::File</code> did not pass the options to <code>Zip::Entry</code> in some cases. <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/423">#423</a></li> <li>Note that <code>restore_times</code> in this release does nothing on Windows and only restores <code>mtime</code>, not <code>atime</code> or <code>ctime</code>.</li> </ul> </li> <li>Allow <code>Zip::File.open</code> to take an options hash like <code>Zip::File.new</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/418">#418</a></li> <li>Always print warnings with <code>warn</code>, instead of a mix of <code>puts</code> and <code>warn</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/416">#416</a></li> <li>Create temporary files in the system temporary directory instead of the directory of the zip file <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/411">#411</a></li> <li>Drop unused <code>tmpdir</code> requirement <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/411">#411</a></li> </ul> <p>Tooling</p> <ul> <li>Move CI to xenial and include jruby on JDK11 <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/419/files">#419</a></li> </ul> <h1>2.0.0 (2019-09-25)</h1> <p>Security</p> <ul> <li>Default the <code>validate_entry_sizes</code> option to <code>true</code>, so that callers can trust an entry's reported size when using <code>extract</code> <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/403">#403</a> <ul> <li>This option defaulted to <code>false</code> in 1.3.0 for backward compatibility, but it now defaults to <code>true</code>. If you are using an older version of ruby and can't yet upgrade to 2.x, you can still use 1.3.0 and set the option to <code>true</code>.</li> </ul> </li> </ul> <p>Tooling / Documentation</p> <ul> <li>Remove test files from the gem to avoid problems with antivirus detections on the test files <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/405">#405</a> / <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/384">#384</a></li> <li>Drop support for unsupported ruby versions <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/pull/406">#406</a></li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/rubyzip/rubyzip/commit/2f1c1ea400a15ce3edf9b75e742595f0ee6e661d"><code>2f1c1ea</code></a> Move to using a post install message for 3.0 warning.</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/16de339666faa68aaa3a646f612eb63503a9a9ca"><code>16de339</code></a> Print banner text re v3.0.0 when <code>zip</code> is required.</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/84d7a66abc946ccc8ecb9b6bcf33a2a972501935"><code>84d7a66</code></a> Bump version number and Changelog.</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/3bc55a5d9880827ddca76de41004b5a82eb7642e"><code>3bc55a5</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/443">#443</a> from rubyzip/v2-3-0</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/69186f65cdaa69a46e32ab81661376d648f61566"><code>69186f6</code></a> Bump version to 2.3.0</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/516941bec56fbceaed8e75887247b74b97cbf341"><code>516941b</code></a> Update changelog for <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/439">#439</a> and <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/440">#440</a></li> <li><a href="https://github.com/rubyzip/rubyzip/commit/a64a14767dd458f8da6107721a428aa5e2b3f5c9"><code>a64a147</code></a> Bump rake version (development dependency)</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/4c789c28212f38216a88982ce52f0992b1853805"><code>4c789c2</code></a> Remove unused constant from <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/439">#439</a></li> <li><a href="https://github.com/rubyzip/rubyzip/commit/fabacf16333eb74a98f0cfa9b5a39e8d5b129304"><code>fabacf1</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/440">#440</a> from hainesr/rubocop-names</li> <li><a href="https://github.com/rubyzip/rubyzip/commit/b231b289987a595171aceedb941450e8620cf314"><code>b231b28</code></a> Merge pull request <a href="https://github-redirect.dependabot.com/rubyzip/rubyzip/issues/439">#439</a> from henkeinfo/binary-outstream-buffer</li> <li>Additional commits viewable in <a href="https://github.com/rubyzip/rubyzip/compare/v1.2.4...v2.3.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+3 -3

0 comment

2 changed files

dependabot-preview[bot]

pr closed time in 2 months

push eventgekola/xlsxwriter-rb

Nick H

commit sha a754b0bc0ec830bb7bf75805f387e5c264b8307e

Bump rubyzip

view details

push time in 2 months

push eventgekola/xlsxwriter-rb

Nick H

commit sha 3b8cbea2fdcbbc7b03f7c16eb752453b580a90ec

Dependabot

view details

push time in 2 months

push eventgekola/xlsxwriter-rb

Nick H

commit sha 71b66ce938d39468dd5741d0727e2e19e3ab743b

Bump libxlsxwriter to 1.0.0 Fix and add tests and add some more bindings

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 1f63edd1b0d1598a6b78ab64ae7a5c193a7e10ba

dev-python/cassandra-driver 3.25.0

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 37f49438edff8b614e871973963957acc624599f

app-emulation/docker-compose remove

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 94cbac70d38cb00a2ae4a86dc680158c7502ef99

dev-db/clickhouse remove 19.x

view details

Nick H

commit sha d3cd92442cd69b18304f6b357453875c63452372

dev-db/clickhous modernize 20.3.21.2

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 3fbc82740f6325a9910ec1fd6c84b080923dd9a8

dev-db/clickhouse 21.3.14.1

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 6abc64cc5b924fbafc50f358c720de986f8af9ea

www-client/firefox 78.12.0

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 5fd3f4e04efee6fd18d632086c280eed54961303

dev-python/rdflib remove

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 0c6cf7b5e9ef26151db55dd4be94f9847e9ffcab

dev-python/kaggle 1.5.12

view details

push time in 2 months

push eventgekola/overload

Nick H

commit sha 45f0a02c55caab6c8d5484252e71d7edc4ccb86a

www-client/ungoogled-chromium 91.0.4472.114_p1

view details

push time in 3 months

push eventgekola/overload

Nick H

commit sha 772cc5b15bd26d9e0a83892fbfae797e19af7000

www-client/firefox 78.11.0

view details

Nick H

commit sha 3f1cedd2416a331e69f396dba240addb987cc2d0

www-client/firefox 89.0.2

view details

push time in 3 months