profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/garethellis36/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.

garethellis36/crontab-schedule-generator 7

A simple PHP library for generating Crontab schedules with expressive PHP code.

garethellis36/mysql-slow-query-log-parser 7

PHP lib for parsing a MySQL slow query log

garethellis36/hamcrest-matchers 2

A set of custom Hamcrest matchers

garethellis36/advent-of-code-2015 1

My code for http://adventofcode.com/ 2015

garethellis36/app 0

CakePHP 3.0 application template

garethellis36/bakery 0

The Official CakePHP blog

garethellis36/barbellcalculator 0

Simple PHP lib for calculating the plates required to load a barbell

push eventsouth-midlands-powerlifting-association/smpa-website

Gareth Ellis

commit sha 12e1ac45c1f5327e91702e50061f04446c05f80d

Records update

view details

push time in 12 days

push eventsouth-midlands-powerlifting-association/smpa-website

Gareth Ellis

commit sha c0b1875ad338081e7226b24ea75e3cd2d86b6517

Records update

view details

push time in a month

issue openedkalessil/phpinspectionsea

Warn if using a dev dependency in non-dev code!

Hello :)

I'm not sure if what I am proposing is possible... but it would be awesome if it is.

We had a bug reach staging, which I luckily caught through manual smoke tests before it reached production: I had accidentally used a library that was only installed as a dependency of one of our require-dev dependencies, in application code. All our tests passed, so I assumed that all was well until I saw the error!

If there was a way for PhpStorm to warn me that I've done something idiotic at write-time, it would probably have stopped this from happening. Do you think it's possible?

created time in 2 months

issue closedRoave/SecurityAdvisories

Conflict with cakephp fork

We have forked CakePHP because we have several applications still going strong on the v2 line, which is now EOL. We wanted to update it to support PHP 8, so we forked it, got the tests passing on PHP 8, and now want to require it in our applications.

Just to confuse everyone further, we dropped all the Cake versioning and started our own semver again.

However, when I try to require it, I get:

  Problem 1
    - roave/security-advisories is locked to version dev-master and an update of this package was not requested.
    - roave/security-advisories dev-master conflicts with myorg/cakephp 1.1.0.
    - Root composer.json requires myorg/cakephp ^1.1 -> satisfiable by myorg/cakephp[1.1.0].

I notice that cakephp/cakephp <1.3.18 is in the list of packages in the conflict list of this repository. Is that causing this issue?

Our fork is in a repository on Private Packagist, and the only things in its own require are PHP, PHPUnit (v8), and Rector prefixed.

I guess this might be a composer (or a user understanding) problem rather than a roave/securityadvisories problem, but thought I'd ask for advice. Cheers!

closed time in 2 months

garethellis36

issue commentRoave/SecurityAdvisories

Conflict with cakephp fork

Yes, it replaces it. I've removed that and it's installing OK now. Thanks Marco 👍

garethellis36

comment created time in 2 months

issue openedRoave/SecurityAdvisories

Conflict with cakephp fork

We have forked CakePHP because we have several applications still going strong on the v2 line, which is now EOL. We wanted to update it to support PHP 8, so we forked it, got the tests passing on PHP 8, and now want to require it in our applications.

However, when I try to require it, I get:

  Problem 1
    - roave/security-advisories is locked to version dev-master and an update of this package was not requested.
    - roave/security-advisories dev-master conflicts with myorg/cakephp 1.1.0.
    - Root composer.json requires myorg/cakephp ^1.1 -> satisfiable by myorg/cakephp[1.1.0].

I notice that cakephp/cakephp <1.3.18 is in the list of packages in the conflict list of this repository. Is that causing this issue?

Our fork is in a repository on Private Packagist, and the only things in its own require are PHP, PHPUnit (v8), and Rector prefixed.

I guess this might be a composer (or a user understanding) problem rather than a roave/securityadvisories problem, but thought I'd ask for advice. Cheers!

created time in 2 months