profile
viewpoint
Eric Park ericswpark South Korea https://ericswpark.com Student developer

ericswpark/awipe 1

Android wiping app

ericswpark/shipper 1

Artifact release manager

BlissRoms/Documentation-release 0

Release repository for Team Bliss Documentation

ericswpark/anatole 0

Anatole is a minimalist two-column hugo theme based on farbox-theme-Anatole.

ericswpark/android-decrapifier 0

Java program to disable/remove Android bloatware

ericswpark/android_battery_check 0

Battery health tool for Android

ericswpark/android_device_samsung_frescolteskt 0

Device tree for Samsung Galaxy Note 3 Neo (frescolteskt)

GollumEvent

push eventericswpark/shipper

Eric Park

commit sha ac3c2db650974c484173b6f354489a6353569bf1

activate: fix latest version fetching mechanism

view details

push time in 9 days

push eventericswpark/shipper

Eric Park

commit sha 033dcb8e40bdde50791ce3b2742fffb6202a9f42

update-shipper: add activate file in current directory

view details

push time in 9 days

GollumEvent

push eventericswpark/shipper

Eric Park

commit sha 6fa5bc4b2d877acb3dfcb6e6636398db5b7c18de

Make update script executable

view details

push time in 9 days

push eventericswpark/shipper

Eric Park

commit sha b4c0031141af331a9836fa02b471f5b38f0b23c7

Ignore maintenance scripts from Docker copy

view details

Eric Park

commit sha 7e05f5de557c9cc84140bba2d84fc2c901a20873

Add updater script

view details

push time in 9 days

push eventericswpark/shipper

Eric Park

commit sha c58c104a0dd4bdcaf8b7f797838f869d10bb60ad

Add latest version alias to activate

view details

push time in 9 days

push eventericswpark/shipper

Eric Park

commit sha e1549096f53f2cd539680a9f036fae3e806ca592

Add setversion command to activate

view details

push time in 9 days

push eventericswpark/shipper

dependabot[bot]

commit sha 3c0a92423a02a8a9aa7f842dbd2b8e3e9b75da1d

build(deps): bump sentry-sdk from 1.4.3 to 1.5.0 Bumps [sentry-sdk](https://github.com/getsentry/sentry-python) from 1.4.3 to 1.5.0. - [Release notes](https://github.com/getsentry/sentry-python/releases) - [Changelog](https://github.com/getsentry/sentry-python/blob/master/CHANGELOG.md) - [Commits](https://github.com/getsentry/sentry-python/compare/1.4.3...1.5.0) --- updated-dependencies: - dependency-name: sentry-sdk dependency-type: direct:production update-type: version-update:semver-minor ... Signed-off-by: dependabot[bot] <support@github.com>

view details

push time in 12 days

PR merged ericswpark/shipper

build(deps): bump sentry-sdk from 1.4.3 to 1.5.0 dependencies python

Bumps sentry-sdk from 1.4.3 to 1.5.0. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/getsentry/sentry-python/releases">sentry-sdk's releases</a>.</em></p> <blockquote> <h2>1.5.0</h2> <ul> <li>Also record client outcomes for before send <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1211">#1211</a></li> <li>Add support for implicitly sized envelope items <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1229">#1229</a></li> <li>Fix integration with Apache Beam 2.32, 2.33 <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1233">#1233</a></li> <li>Remove Python 2.7 support for AWS Lambda layers in craft config <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1241">#1241</a></li> <li>Refactor Sanic integration for v21.9 support <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1212">#1212</a></li> <li>AWS Lambda Python 3.9 runtime support <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1239">#1239</a></li> <li>Fix "shutdown_timeout" typing <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1256">#1256</a></li> </ul> <p>Work in this release contributed by <a href="https://github.com/galuszkak"><code>@​galuszkak</code></a>, <a href="https://github.com/kianmeng"><code>@​kianmeng</code></a>, <a href="https://github.com/ahopkins"><code>@​ahopkins</code></a>, <a href="https://github.com/razumeiko"><code>@​razumeiko</code></a>, <a href="https://github.com/tomscytale"><code>@​tomscytale</code></a>, and <a href="https://github.com/seedofjoy"><code>@​seedofjoy</code></a>. Thank you for your contribution!</p> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/getsentry/sentry-python/blob/master/CHANGELOG.md">sentry-sdk's changelog</a>.</em></p> <blockquote> <h2>1.5.0</h2> <ul> <li>Also record client outcomes for before send <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1211">#1211</a></li> <li>Add support for implicitly sized envelope items <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1229">#1229</a></li> <li>Fix integration with Apache Beam 2.32, 2.33 <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1233">#1233</a></li> <li>Remove Python 2.7 support for AWS Lambda layers in craft config <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1241">#1241</a></li> <li>Refactor Sanic integration for v21.9 support <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1212">#1212</a></li> <li>AWS Lambda Python 3.9 runtime support <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1239">#1239</a></li> <li>Fix "shutdown_timeout" typing <a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1256">#1256</a></li> </ul> <p>Work in this release contributed by <a href="https://github.com/galuszkak"><code>@​galuszkak</code></a>, <a href="https://github.com/kianmeng"><code>@​kianmeng</code></a>, <a href="https://github.com/ahopkins"><code>@​ahopkins</code></a>, <a href="https://github.com/razumeiko"><code>@​razumeiko</code></a>, <a href="https://github.com/tomscytale"><code>@​tomscytale</code></a>, and <a href="https://github.com/seedofjoy"><code>@​seedofjoy</code></a>. Thank you for your contribution!</p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/getsentry/sentry-python/commit/293c8a40f9f490023720b3f9f094ce2aeba0aead"><code>293c8a4</code></a> release: 1.5.0</li> <li><a href="https://github.com/getsentry/sentry-python/commit/8699db7fc4abd1db4f55a2bde2c4869f8627ca57"><code>8699db7</code></a> meta: Changelog for 1.5.0</li> <li><a href="https://github.com/getsentry/sentry-python/commit/40a309a348a56b60a945de6efb68e8d0b79ca5a6"><code>40a309a</code></a> Fix "shutdown_timeout" typing (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1256">#1256</a>)</li> <li><a href="https://github.com/getsentry/sentry-python/commit/b0826feef2643321ce1281bacf85bfe8481bb187"><code>b0826fe</code></a> fix(tests): Pin more-itertools in tests for Python 3.5 compat (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1254">#1254</a>)</li> <li><a href="https://github.com/getsentry/sentry-python/commit/b2864068ea74111849f651ed6193c4cc843ff3ec"><code>b286406</code></a> feat(aws): AWS Lambda Python 3.9 runtime support (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1239">#1239</a>)</li> <li><a href="https://github.com/getsentry/sentry-python/commit/5d357d0a5a0fae0e1c237cd2105700b0cfda9812"><code>5d357d0</code></a> feat(sanic): Refactor Sanic integration for v21.9 support (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1212">#1212</a>)</li> <li><a href="https://github.com/getsentry/sentry-python/commit/dd0efc08414ee2ef1a5f22d2cc4e243b54a1b455"><code>dd0efc0</code></a> fix: Formatting</li> <li><a href="https://github.com/getsentry/sentry-python/commit/40ab71687c7efded16103544c4beecb2afc9a3b0"><code>40ab716</code></a> chore: fix typos (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1253">#1253</a>)</li> <li><a href="https://github.com/getsentry/sentry-python/commit/1ed232cff4c829471639be443b415e6dfbb2ddb9"><code>1ed232c</code></a> build(deps): bump checkouts/data-schemas from <code>c5f90f8</code> to <code>f0a57f2</code> (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1252">#1252</a>)</li> <li><a href="https://github.com/getsentry/sentry-python/commit/ed4ba68cad42ebfbab162b37bf7edad25ebeae55"><code>ed4ba68</code></a> build(craft): Remove Python 2.7 support for AWS Lambda layers (<a href="https://github-redirect.dependabot.com/getsentry/sentry-python/issues/1241">#1241</a>)</li> <li>Additional commits viewable in <a href="https://github.com/getsentry/sentry-python/compare/1.4.3...1.5.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 12 days

push eventericswpark/android_battery_check

Eric Park

commit sha 8ddd50fc8ff18d69b6162977b90266fc90ec2e9b

Add connection instructions

view details

push time in 13 days

push eventericswpark/shipper

dependabot[bot]

commit sha d41a3c516d026c9ce647cdd488d80a3f67e947d4

build(deps): bump celery from 5.2.0 to 5.2.1 Bumps [celery](https://github.com/celery/celery) from 5.2.0 to 5.2.1. - [Release notes](https://github.com/celery/celery/releases) - [Changelog](https://github.com/celery/celery/blob/master/Changelog.rst) - [Commits](https://github.com/celery/celery/compare/v5.2.0...v5.2.1) --- updated-dependencies: - dependency-name: celery dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com>

view details

push time in 13 days

PR merged ericswpark/shipper

build(deps): bump celery from 5.2.0 to 5.2.1 dependencies python

Bumps celery from 5.2.0 to 5.2.1. <details> <summary>Release notes</summary> <p><em>Sourced from <a href="https://github.com/celery/celery/releases">celery's releases</a>.</em></p> <blockquote> <h2>5.2.1</h2> <h2>What's Changed</h2> <ul> <li>[pre-commit.ci] pre-commit autoupdate by <a href="https://github.com/pre-commit-ci"><code>@​pre-commit-ci</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7054">celery/celery#7054</a></li> <li>Remove unused failing unittest by <a href="https://github.com/matusvalo"><code>@​matusvalo</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7058">celery/celery#7058</a></li> <li>add toml file path by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7060">celery/celery#7060</a></li> <li>Fix rstrip usage on bytes instance in ProxyLogger. by <a href="https://github.com/tim-schilling"><code>@​tim-schilling</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7057">celery/celery#7057</a></li> <li>Pass logfile to ExecStop in celery.service example systemd file by <a href="https://github.com/lafrech"><code>@​lafrech</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7055">celery/celery#7055</a></li> <li>Move pytest configuration from setup.cfg to pyproject.toml by <a href="https://github.com/matusvalo"><code>@​matusvalo</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7059">celery/celery#7059</a></li> <li>not needed as python 2 is not supported. by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7066">celery/celery#7066</a></li> <li>drop as we don't use travis anymore by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7068">celery/celery#7068</a></li> <li>simplejson is not used anymore by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7067">celery/celery#7067</a></li> <li>Change pytz>dev to a PEP 440 compliant pytz>0.dev.0 by <a href="https://github.com/frantisekz"><code>@​frantisekz</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7074">celery/celery#7074</a></li> <li>Remove dependency to case by <a href="https://github.com/matusvalo"><code>@​matusvalo</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7077">celery/celery#7077</a></li> <li>fix: task expiration is timezone aware if needed by <a href="https://github.com/gabor-boros"><code>@​gabor-boros</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7065">celery/celery#7065</a></li> <li>minor weaks to github actions by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7078">celery/celery#7078</a></li> <li>Fixes <a href="https://github-redirect.dependabot.com/celery/celery/issues/7052">#7052</a> gevent/eventlet 1 seconds latency by <a href="https://github.com/mrmaxi"><code>@​mrmaxi</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7089">celery/celery#7089</a></li> <li>[pre-commit.ci] pre-commit autoupdate by <a href="https://github.com/pre-commit-ci"><code>@​pre-commit-ci</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7093">celery/celery#7093</a></li> <li>pin redis below v4.0.0 for now to fix kombu by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7094">celery/celery#7094</a></li> <li>bump minimum kombu version to 5.2.2 by <a href="https://github.com/auvipy"><code>@​auvipy</code></a> in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7096">celery/celery#7096</a></li> </ul> <h2>New Contributors</h2> <ul> <li><a href="https://github.com/tim-schilling"><code>@​tim-schilling</code></a> made their first contribution in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7057">celery/celery#7057</a></li> <li><a href="https://github.com/lafrech"><code>@​lafrech</code></a> made their first contribution in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7055">celery/celery#7055</a></li> <li><a href="https://github.com/gabor-boros"><code>@​gabor-boros</code></a> made their first contribution in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7065">celery/celery#7065</a></li> <li><a href="https://github.com/mrmaxi"><code>@​mrmaxi</code></a> made their first contribution in <a href="https://github-redirect.dependabot.com/celery/celery/pull/7089">celery/celery#7089</a></li> </ul> <p><strong>Full Changelog</strong>: <a href="https://github.com/celery/celery/compare/v5.2.0...v5.2.1">https://github.com/celery/celery/compare/v5.2.0...v5.2.1</a></p> </blockquote> </details> <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/celery/celery/blob/master/Changelog.rst">celery's changelog</a>.</em></p> <blockquote> <h1>5.2.1</h1> <p>:release-date: 2021-11-16 8.55 P.M UTC+6:00 :release-by: Asif Saif Uddin</p> <ul> <li>Fix rstrip usage on bytes instance in ProxyLogger.</li> <li>Pass logfile to ExecStop in celery.service example systemd file.</li> <li>fix: reduce latency of AsyncResult.get under gevent (<a href="https://github-redirect.dependabot.com/celery/celery/issues/7052">#7052</a>)</li> <li>Limit redis version: <4.0.0.</li> <li>Bump min kombu version to 5.2.2.</li> <li>Change pytz>dev to a PEP 440 compliant pytz>0.dev.0.</li> <li>Remove dependency to case (<a href="https://github-redirect.dependabot.com/celery/celery/issues/7077">#7077</a>).</li> <li>fix: task expiration is timezone aware if needed (<a href="https://github-redirect.dependabot.com/celery/celery/issues/7065">#7065</a>).</li> <li>Initial testing of pypy-3.8 beta to CI.</li> <li>Docs, CI & tests cleanups.</li> </ul> <p>.. _version-5.2.0:</p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/celery/celery/commit/d32356c0e46eefecd164c55899f532c2fed2df57"><code>d32356c</code></a> Bump version: 5.2.0 → 5.2.1</li> <li><a href="https://github.com/celery/celery/commit/6842a786eeeb2d0f1fcd66408b72924b39e07836"><code>6842a78</code></a> Merge branch 'master' of <a href="https://github.com/celery/celery">https://github.com/celery/celery</a></li> <li><a href="https://github.com/celery/celery/commit/4c92cb745f658382a4eb4b94ba7938d119168165"><code>4c92cb7</code></a> changelog for v5.2.1</li> <li><a href="https://github.com/celery/celery/commit/83747fdbe8a751713f702bf765fef31d08229dd9"><code>83747fd</code></a> bump minimum kombu version to 5.2.2</li> <li><a href="https://github.com/celery/celery/commit/ddbb67c29dd1137805a2bdf2695cffdbb0d54efa"><code>ddbb67c</code></a> pin redis below v4.0.0 for now to fix kombu</li> <li><a href="https://github.com/celery/celery/commit/6b442eb3f2450ede1585e4bae37ee12e6d127947"><code>6b442eb</code></a> [pre-commit.ci] pre-commit autoupdate</li> <li><a href="https://github.com/celery/celery/commit/59f22712db8879e2fc016c5bed504ae49f0b05c1"><code>59f2271</code></a> [pre-commit.ci] auto fixes from pre-commit.com hooks</li> <li><a href="https://github.com/celery/celery/commit/cc5569222db3c1e5bee3a70d679f747940988fec"><code>cc55692</code></a> fix: reduce latency of AsyncResult.get under gevent (<a href="https://github-redirect.dependabot.com/celery/celery/issues/7052">#7052</a>)</li> <li><a href="https://github.com/celery/celery/commit/fe37cd834109810dc778845378880abdf7d08ff6"><code>fe37cd8</code></a> minor weaks to github actions (<a href="https://github-redirect.dependabot.com/celery/celery/issues/7078">#7078</a>)</li> <li><a href="https://github.com/celery/celery/commit/431f07d77289149b9064fdc36202a536f86f2994"><code>431f07d</code></a> fix: task expiration is timezone aware if needed (<a href="https://github-redirect.dependabot.com/celery/celery/issues/7065">#7065</a>)</li> <li>Additional commits viewable in <a href="https://github.com/celery/celery/compare/v5.2.0...v5.2.1">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 13 days

issue commentosxfuse/osxfuse

macFUSE kernel extension stops working until reload

@j-rahman I think your issue is slightly different from mine but possibly related. The kext unload command always works for me whenever I encounter this error.

I'm running macOS build 21A559, in case we're running different macOS builds and that's causing the discrepency. But I think this might be a separate issue altogether. In any case there are definite incompatibilities with Monterey and macFUSE as I haven't encountered this bug on Big Sur.

ericswpark

comment created time in 14 days

issue commentosxfuse/osxfuse

macFUSE kernel extension stops working until reload

@ericswpark The error message you are seeing is returned in case the macOS system function getvfsbyname() reports that the macFUSE VFS plugin ist not available. There is no code in the macFUSE kernel extension to unload the VFS plugin (without the kernel extension being unloaded). This means there is probably more to the story. Can you describe in as much detail as possible what you did leading up to seeing this error message?

It usually happens after some time has elapsed since the last mount that utilizes macFUSE.

For example, when I reboot my Mac and start using VeraCrypt and Cryptomator, everything will work for a while. I'll unmount everything, eject the external drive, and then put my Mac to sleep, although I'm not sure if this is the exact trigger for the problem. On wake, I re-connect the external drive, and try and re-mount the encrypted files using the encryption tools, and I usually encounter the error during this time.

Again, I'm not sure exactly when macFUSE will stop working. I've tried unmounting and remounting several times to get it to trigger on-demand but it doesn't happen at once. Usually it takes a bit of inactivity before the kernel extension acts up. Every time I've encountered this bug the unload command always worked and I could mount volumes properly after executing it.

ericswpark

comment created time in 14 days

push eventericswpark/shipper

dependabot[bot]

commit sha 50229d0315461c2c37fe412358f071eef3d18ead

build(deps): bump psycopg2-binary from 2.9.1 to 2.9.2 Bumps [psycopg2-binary](https://github.com/psycopg/psycopg2) from 2.9.1 to 2.9.2. - [Release notes](https://github.com/psycopg/psycopg2/releases) - [Changelog](https://github.com/psycopg/psycopg2/blob/master/NEWS) - [Commits](https://github.com/psycopg/psycopg2/commits) --- updated-dependencies: - dependency-name: psycopg2-binary dependency-type: direct:production update-type: version-update:semver-patch ... Signed-off-by: dependabot[bot] <support@github.com>

view details

push time in 17 days

PR merged ericswpark/shipper

build(deps): bump psycopg2-binary from 2.9.1 to 2.9.2 dependencies python

Bumps psycopg2-binary from 2.9.1 to 2.9.2. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/psycopg/psycopg2/blob/master/NEWS">psycopg2-binary's changelog</a>.</em></p> <blockquote> <h2>Current release</h2> <p>What's new in psycopg 2.9.2 ^^^^^^^^^^^^^^^^^^^^^^^^^^^</p> <ul> <li>Raise <code>ValueError</code> for dates >= Y10k (:ticket:<code>#1307</code>).</li> <li><code>~psycopg2.errorcodes</code> map and <code>~psycopg2.errors</code> classes updated to PostgreSQL 14.</li> <li>Add preliminary support for Python 3.11 (:tickets:<code>#1376, #1386</code>).</li> <li>Wheel package compiled against OpenSSL 1.1.1l and PostgreSQL 14.1 (:ticket:<code>#1388</code>).</li> </ul> <p>What's new in psycopg 2.9.1 ^^^^^^^^^^^^^^^^^^^^^^^^^^^</p> <p>Fix regression with named <code>sql.Placeholder</code> (:ticket:<code>#1291</code>).</p> <h2>What's new in psycopg 2.9</h2> <ul> <li><code>with connection</code> starts a transaction on autocommit transactions too (:ticket:<code>#941</code>).</li> <li>Timezones with fractional minutes are supported on Python 3.7 and following (:ticket:<code>#1272</code>).</li> <li>Escape table and column names in <code>~cursor.copy_from()</code> and <code>~cursor.copy_to()</code>.</li> <li>Connection exceptions with sqlstate <code>08XXX</code> reclassified as <code>~psycopg2.OperationalError</code> (a subclass of the previously used <code>~psycopg2.DatabaseError</code>) (:ticket:<code>#1148</code>).</li> <li>Include library dirs required from libpq to work around MacOS build problems (:ticket:<code>#1200</code>).</li> </ul> <p>Other changes:</p> <ul> <li>Dropped support for Python 2.7, 3.4, 3.5 (:tickets:<code>#1198, #1000, #1197</code>).</li> <li>Dropped support for mx.DateTime.</li> <li>Use <code>datetime.timezone</code> objects by default in datetime objects instead of <code>~psycopg2.tz.FixedOffsetTimezone</code>.</li> <li>The <code>psycopg2.tz</code> module is deprecated and scheduled to be dropped in the next major release.</li> <li>Provide :pep:<code>599</code> wheels packages (manylinux2014 tag) for i686 and x86_64 platforms.</li> <li>Provide :pep:<code>600</code> wheels packages (manylinux_2_24 tag) for aarch64 and ppc64le platforms.</li> <li>Wheel package compiled against OpenSSL 1.1.1k and PostgreSQL 13.3.</li> <li>Build system for Linux/MacOS binary packages moved to GitHub Actions.</li> </ul> <!-- raw HTML omitted --> </blockquote> <p>... (truncated)</p> </details> <details> <summary>Commits</summary> <ul> <li>See full diff in <a href="https://github.com/psycopg/psycopg2/commits">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

</details>

+1 -1

0 comment

1 changed file

dependabot[bot]

pr closed time in 17 days

issue commentosxfuse/osxfuse

Error: mount_macfuse: the macFUSE kernel extension is not loaded

@AlexC127, this might be a duplicate of #850. Can you check if the unload kext command in this comment works for you or not?

AlexC127

comment created time in 17 days

issue commentosxfuse/osxfuse

macFUSE kernel extension gets unloaded unexpectedly

Just found out that the kernel extension is loaded when the error occurs, as the output of kextstat shows:

  207    0 0xffffff7f997cb000 0x14000    0x14000    io.macfuse.filesystems.macfuse (2081.20) 7AF3B76F-9FED-3061-B34E-4765286F3749 <9 7 6 3 1>

Unloading the kernel extension fixes the error. You can unload the kext by running: sudo kextunload -b io.macfuse.filesystems.macfuse.

You do not need to re-load the kernel extension; it gets reloaded automatically when running any application that relies on macFUSE.

So it seems like the applications that depend on macFUSE are not happy because something is going wrong with the macFUSE kernel extension and therefore the applications think the kernel extension is not loaded at all. Unloading the kernel extension resets the bugged state and lets macFUSE work again.

ericswpark

comment created time in 17 days

delete branch ericswpark/anatole

delete branch : oldcontent

delete time in 19 days

GollumEvent
GollumEvent
GollumEvent

pull request commentlxndrblz/anatole

feat: old content warning

@lxndrblz wouldn't it be better to make it a pinned issue? Translators can't tack on translation commits to this PR unless they are a maintainer of the repository and getting all the translations in will take a lot of time unless we can contact all the previous translators. Since the feature is disabled by default I think translations will trickle in as people enable it and see that there is no translated string.

ericswpark

comment created time in 19 days

Pull request review commentlxndrblz/anatole

feat: old content warning

 a.btn {   padding: 0.5rem;   height: 1.5rem;   width: 2.5rem;+  height: 2.5rem;

Actually never mind, I thought it wasn't centered vertically in the screenshot but it is. I wonder if I only saw it on my machine but I remember the "!" symbol was not properly vertically centered in the circle.

ericswpark

comment created time in 20 days

PullRequestReviewEvent
PullRequestReviewEvent

Pull request review commentlxndrblz/anatole

feat: old content warning

 a.btn {   padding: 0.5rem;   height: 1.5rem;   width: 2.5rem;+  height: 2.5rem;

Hmm, then should we find a way to vertically center the "!" mark in the circle?

ericswpark

comment created time in 20 days

Pull request review commentlxndrblz/anatole

feat: old content warning

 a.btn {   padding: 0.5rem;   height: 1.5rem;   width: 2.5rem;+  height: 2.5rem;

@lxndrblz was this added by mistake? Now there are two height attributes

ericswpark

comment created time in 20 days

PullRequestReviewEvent
more