profile
viewpoint

dlahn/mattermost-server 0

Open source Slack-alternative in Golang and React - Mattermost

dlahn/mattermost-webapp 0

Webapp of Mattermost server: https://github.com/mattermost/mattermost-server

dlahn/openmrs-core 0

OpenMRS API and web application code

dlahn/presto-metrics 0

Presto metric collection library for Ruby

dlahn/uploadit 0

A configurable python script that automates the process of uploading a file and posting links to it on multiple social media sites.

delete branch forward3d/garrison

delete branch : dependabot/npm_and_yarn/moment-2.26.0

delete time in a month

push eventforward3d/garrison

dependabot-preview[bot]

commit sha 9723e543dca75e0e67a7be19f33ab49494257778

Bump moment from 2.25.3 to 2.26.0 Bumps [moment](https://github.com/moment/moment) from 2.25.3 to 2.26.0. - [Release notes](https://github.com/moment/moment/releases) - [Changelog](https://github.com/moment/moment/blob/develop/CHANGELOG.md) - [Commits](https://github.com/moment/moment/compare/2.25.3...2.26.0) Signed-off-by: dependabot-preview[bot] <support@dependabot.com>

view details

Dave Lahn

commit sha 1e77034a8334f1363080133b4afa83f53281f4b2

Merge pull request #191 from forward3d/dependabot/npm_and_yarn/moment-2.26.0 Bump moment from 2.25.3 to 2.26.0

view details

push time in a month

PR merged forward3d/garrison

Bump moment from 2.25.3 to 2.26.0 dependencies javascript

Bumps moment from 2.25.3 to 2.26.0. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/moment/moment/blob/develop/CHANGELOG.md">moment's changelog</a>.</em></p> <blockquote> <h3>2.26.0 <a href="https://gist.github.com/marwahaha/0725c40740560854a849b096ea7b7590">See full changelog</a></h3> <ul> <li>Release May 19, 2020</li> </ul> <p>TypeScript fixes and many locale improvements</p> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/moment/moment/commit/a0f3c74374b638b769d9ab1ae54ba5266ef0976f"><code>a0f3c74</code></a> Build 2.26.0</li> <li><a href="https://github.com/moment/moment/commit/baa798f8b3142b1859a473f96739f206f3832db8"><code>baa798f</code></a> Bump version to 2.26.0</li> <li><a href="https://github.com/moment/moment/commit/e0ceae09a30547fe995cf96c80b909c8171a414a"><code>e0ceae0</code></a> Update changelog for 2.26.0</li> <li><a href="https://github.com/moment/moment/commit/615212478ce087aeb995699ce5a827dab9daf9ec"><code>6152124</code></a> [tests] Get TS tests working on Windows with cross-env (<a href="https://github-redirect.dependabot.com/moment/moment/issues/5519">#5519</a>)</li> <li><a href="https://github.com/moment/moment/commit/4d0f390ffca3e558bf47a65942f2ca937f2c9b64"><code>4d0f390</code></a> [locale] zh-cn: Improve next/prev week (<a href="https://github-redirect.dependabot.com/moment/moment/issues/5447">#5447</a>)</li> <li><a href="https://github.com/moment/moment/commit/74210cd677c0e52a343b27a3054a7026c38e4789"><code>74210cd</code></a> [locale] ru: simplify regex</li> <li><a href="https://github.com/moment/moment/commit/315abe846d9333cc4cea2d7781365d12ca3da347"><code>315abe8</code></a> [locale] br: Add meridiem translation and correct quotemark (<a href="https://github-redirect.dependabot.com/moment/moment/issues/5433">#5433</a>)</li> <li><a href="https://github.com/moment/moment/commit/22bf4caafc98aba555d0c5fdf13a2fa37f9929df"><code>22bf4ca</code></a> [locale] tr: Add meridiem support (<a href="https://github-redirect.dependabot.com/moment/moment/issues/4701">#4701</a>)</li> <li><a href="https://github.com/moment/moment/commit/e3baef9ea95a46a2affe03e8fa607fffa921448a"><code>e3baef9</code></a> [locale] en-au: Sunday is first day of week (<a href="https://github-redirect.dependabot.com/moment/moment/issues/5264">#5264</a>)</li> <li><a href="https://github.com/moment/moment/commit/04b275c44e5ffd6b6936b82b59601f515b21b952"><code>04b275c</code></a> [locale] Fix Indian week start date and week number (<a href="https://github-redirect.dependabot.com/moment/moment/issues/5502">#5502</a>)</li> <li>Additional commits viewable in <a href="https://github.com/moment/moment/compare/2.25.3...2.26.0">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+5 -5

0 comment

2 changed files

dependabot-preview[bot]

pr closed time in a month

delete branch forward3d/garrison

delete branch : dependabot/bundler/websocket-driver-0.7.2

delete time in a month

push eventforward3d/garrison

dependabot-preview[bot]

commit sha e5c5917ced2aaf05270c29713d416bb873a3f706

Bump websocket-driver from 0.7.1 to 0.7.2 Bumps [websocket-driver](https://github.com/faye/websocket-driver-ruby) from 0.7.1 to 0.7.2. - [Release notes](https://github.com/faye/websocket-driver-ruby/releases) - [Changelog](https://github.com/faye/websocket-driver-ruby/blob/master/CHANGELOG.md) - [Commits](https://github.com/faye/websocket-driver-ruby/compare/0.7.1...0.7.2) Signed-off-by: dependabot-preview[bot] <support@dependabot.com>

view details

Dave Lahn

commit sha 6743f7bbba4d9efc913d4b3b66d587f869146c39

Merge pull request #192 from forward3d/dependabot/bundler/websocket-driver-0.7.2 Bump websocket-driver from 0.7.1 to 0.7.2

view details

push time in a month

PR merged forward3d/garrison

Bump websocket-driver from 0.7.1 to 0.7.2 dependencies ruby

Bumps websocket-driver from 0.7.1 to 0.7.2. <details> <summary>Changelog</summary> <p><em>Sourced from <a href="https://github.com/faye/websocket-driver-ruby/blob/master/CHANGELOG.md">websocket-driver's changelog</a>.</em></p> <blockquote> <h3>0.7.2 / 2020-05-22</h3> <ul> <li>Emit <code>ping</code> and <code>pong</code> events from the <code>Server</code> driver</li> <li>Handle draft-76 handshakes correctly if the request's body is a frozen string</li> </ul> </blockquote> </details> <details> <summary>Commits</summary> <ul> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/f882bc56d530564614c5ad81e61eb99c445bd99a"><code>f882bc5</code></a> Bump version to 0.7.2</li> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/46aafa4e9963c344775318e7a646fb4f6b9e7d29"><code>46aafa4</code></a> Set {source,target}_version to work with the current version of javac on macOS</li> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/db09a1af222e504ae85e9947cc8170fddedccd7a"><code>db09a1a</code></a> Update Ruby versions 2.4 to 2.7 on Travis</li> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/202e1800e0e948d83ec18368bdc6cd4651c36eb0"><code>202e180</code></a> Allow rack.input.read to return a frozen string</li> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/b00f58701ec008145d5075075d12271b762381db"><code>b00f587</code></a> Emit ping and pong events from the Server driver</li> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/d05eb72d2d815d4e1b54a115a8fd4c18606ef74a"><code>d05eb72</code></a> Mention license change in the changelog</li> <li><a href="https://github.com/faye/websocket-driver-ruby/commit/e568366f82ffd284208ad7b0081e09041e3354ec"><code>e568366</code></a> Formatting change: {...} should have spaces inside the braces</li> <li>See full diff in <a href="https://github.com/faye/websocket-driver-ruby/compare/0.7.1...0.7.2">compare view</a></li> </ul> </details> <br />

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


<details> <summary>Dependabot commands and options</summary> <br />

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

</details>

+1 -1

0 comment

1 changed file

dependabot-preview[bot]

pr closed time in a month

issue commentSceptre/sceptre

Could not connect to the endpoint URL

We are using the latest version (2.3.0). Mostly, nothing special. We have a few stack_output_external, but that's it. Most resolvers are just stack_output.

dlahn

comment created time in 2 months

issue commentSceptre/sceptre

Could not connect to the endpoint URL

Any idea how we can work around this? This is happening to us quite frequently.

dlahn

comment created time in 2 months

pull request commentlambci/docker-lambda

Fix GEM_PATH to use correct Ruby installation

This is 2.7. Is it different in this case?

dlahn

comment created time in 2 months

pull request commentlambci/docker-lambda

Fix GEM_PATH to use correct Ruby installation

It's not in the production version. Something weird is going on with the Ruby in the build container though. We are trying to use the following Dockerfile, and it fails to find the rake executable:

FROM lambci/lambda:build-ruby2.7

RUN yum install -y https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
RUN yum install -y https://apache.bintray.com/arrow/centos/7/apache-arrow-release-latest.rpm
RUN yum install -y --enablerepo=epel parquet-glib-devel

COPY Gemfile Gemfile
COPY Gemfile.lock Gemfile.lock

RUN bundle install --deployment

Gemfile

source 'https://rubygems.org'

gem 'red-parquet'

Gemfile.lock

GEM
  remote: https://rubygems.org/
  specs:
    extpp (0.0.8)
    gio2 (3.4.1)
      gobject-introspection (= 3.4.1)
    glib2 (3.4.1)
      native-package-installer (>= 1.0.3)
      pkg-config (>= 1.3.5)
    gobject-introspection (3.4.1)
      glib2 (= 3.4.1)
    native-package-installer (1.0.9)
    pkg-config (1.4.1)
    red-arrow (0.17.0)
      extpp (>= 0.0.7)
      gio2 (>= 3.3.6)
      native-package-installer
      pkg-config
    red-parquet (0.17.0)
      red-arrow (= 0.17.0)

PLATFORMS
  ruby

DEPENDENCIES
  red-parquet

BUNDLED WITH
   2.1.4
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/var/task/vendor/bundle/ruby/2.7.0/gems/red-parquet-0.17.0/dependency-check
rake
RUBYARCHDIR\=/var/task/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/red-parquet-0.17.0
RUBYLIBDIR\=/var/task/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/red-parquet-0.17.0
/var/lang/lib/ruby/2.7.0/rubygems.rb:275:in `find_spec_for_exe': can't find gem
rake (>= 0.a) with executable rake (Gem::GemNotFoundException)
	from /var/lang/lib/ruby/2.7.0/rubygems.rb:294:in `activate_bin_path'
	from /var/lang/bin/rake:23:in `<main>'

rake failed, exit code 1

Any ideas?

dlahn

comment created time in 2 months

issue commentlambci/docker-lambda

Ruby Build Images Missing Rake

PR: https://github.com/lambci/docker-lambda/pull/270

dlahn

comment created time in 2 months

push eventforward3d/docker-lambda

Dave Lahn

commit sha 326c926091655906acfbe61d3f40b7c0faf14573

Fix GEM_PATH to use correct Ruby installation

view details

push time in 2 months

issue openedlambci/docker-lambda

Ruby Build Images Missing Rake

rake is not available in the build images, but it is available in the runtime images.

└─(16:31:49 on master)──> docker run -it --rm lambci/lambda:build-ruby2.5 sh                                    
sh-4.2# rake
Traceback (most recent call last):
	2: from /var/lang/bin/rake:23:in `<main>'
	1: from /var/lang/lib/ruby/site_ruby/2.5.0/rubygems.rb:294:in `activate_bin_path'
/var/lang/lib/ruby/site_ruby/2.5.0/rubygems.rb:275:in `find_spec_for_exe': can't find gem rake (>= 0.a) with executable rake (Gem::GemNotFoundException)

This is present in 2.5 and 2.7.

created time in 2 months

push eventforward3d/docker-alpine-abuild

Dave Lahn

commit sha b564689272ae5cb8d9561df2879d0a466ac93a14

Bump Alpine to 3.11

view details

push time in 3 months

more