profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/Rahulsharma0810/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.
Rahul sharma Rahulsharma0810 Cloudcover Consultancy Pvt Ltd. New Delhi, India rvsharma.com Servers, Monitoring, Deployments, Security and etc. Around a tall guy.

Rahulsharma0810/Centos-Openvz-Deploy-web 3

For Easy Deployment of Openvz and Web Panel For Openvz in Centos

Rahulsharma0810/Ansible-Role-VestaCP 1

Install Vesta control Panel on Centos.

Rahulsharma0810/AWS-S3-Scanner 1

AWS S3 Bucket Object Scanner Lambda Function Written in Python and Terraform.

Rahulsharma0810/Centos-Lamp-For-Wordpress 1

setup wordpress quick in centos

Rahulsharma0810/GDocker-Dockerized-Ghost-CMS 1

GDocker is the easiest way to run Ghost in Docker from trusted sources and strong steering control on setup.

Rahulsharma0810/.tmux 0

🇫🇷 Oh my tmux! My self-contained, pretty & versatile tmux configuration made with ❤️

Rahulsharma0810/Ansible-Role-Composer 0

Role to install composer and dependencies in Debian and RPMs.

Rahulsharma0810/Ansible-Role-Epel 0

Install Epel Repo on Debian and RPMs.

Rahulsharma0810/Ansible-Role-EssentialsTools 0

Role to install essentials utilites and tools in Debian and Rpms.

issue openedgravitational/teleport

helm Nginx Ingress not working

Running Teleport on Kubernetes(MetalLB) using Helm chart vai argocd

project: default
source:
 repoURL: 'https://charts.releases.teleport.dev'
 targetRevision: 0.0.13
 helm:
   valueFiles:
     - values.yaml
   parameters:
     - name: config.auth_public_address
       value: auth.labs.example.com
     - name: config.public_address
       value: teleport.labs.example.com
     - name: ingress.enabled
       value: 'true'
     - name: license.enabled
       value: 'false'
     - name: service.type
       value: ClusterIP
     - name: config.teleport.proxy_service.enabled
       value: 'false'
   values: |-
     ingress:
       annotations:
         kubernetes.io/ingress.class: nginx
       hosts:
         teleport.labs.example.com:
         - /
       # Secrets must be manually created in the namespace
       tls:
        - secretName: ca-wildcard-letsencrypt-cert-secret
          hosts:
          - teleport.labs.example.com

     proxy:
       tls:
         # We assume that Teleport will handle TLS termination by default
         enabled: true
         # Set this to false if you want to use Teleport's generated self-signed certificates
         usetlssecret: true
         # tweak this if you have multiple proxies in a single namespace
         secretName: ca-wildcard-letsencrypt-cert-secret
 chart: teleport
destination:
 server: 'https://kubernetes.default.svc'
 namespace: teleport
syncPolicy:
 automated: {}
 syncOptions:
   - CreateNamespace=true
   - ApplyOutOfSyncOnly=true

What happened:

Nginx Giving 502 Error.

162021/09/24 16:45:08 [error] 288#288: *766416 connect() failed (111: Connection refused) while connecting to upstream, client: 10.244.0.1, server: teleport.labs.rvsharma.com, request: "HEAD / HTTP/2.0", upstream: "http://10.244.2.183:3080/", host: "teleport.labs.rvsharma.com"
2021/09/24 16:45:08 [error] 288#288: *766416 connect() failed (111: Connection refused) while connecting to upstream, client: 10.244.0.1, server: teleport.labs.rvsharma.com, request: "HEAD / HTTP/2.0", upstream: "http://10.244.2.183:3080/", host: "teleport.labs.rvsharma.com"
2021/09/24 16:45:08 [error] 288#288: *766416 connect() failed (111: Connection refused) while connecting to upstream, client: 10.244.0.1, server: teleport.labs.rvsharma.com, request: "HEAD / HTTP/2.0", upstream: "http://10.244.2.183:3080/", host: "teleport.labs.rvsharma.com"
10.244.0.1 - - [24/Sep/2021:16:45:08 +0000] "HEAD / HTTP/2.0" 502 0 "-" "curl/7.64.1" 44 0.005 [teleport-teleport-3080] [] 10.244.2.183:3080, 10.244.2.183:3080, 10.244.2.183:3080 0, 0, 0 0.000, 0.004, 0.000 502, 502, 502 d67b2b36e4f64a3246e8b8c10d259f8d

Reproduction Steps

Try to use the same values in bare metal Kubernetes cluster with helm.

created time in 11 hours

fork Rahulsharma0810/terragoat

TerraGoat is Bridgecrew's "Vulnerable by Design" Terraform repository. TerraGoat is a learning and training project that demonstrates how common configuration errors can find their way into production cloud environments.

https://www.bridgecrew.io/

fork in 4 days

issue commentmath-nao/certs

Cert is not issues

I actually migrated from GoDaddy DNS to GCP DNS and used cert manager.

Sent from my iPhone

On 19-Sep-2021, at 1:03 PM, Mathieu Naouache ***@***.***> wrote:

@Rahulsharma0810 any news? did you try with previous workaround or with latest version (without workaround)?

— You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub, or unsubscribe.

Rahulsharma0810

comment created time in 6 days

push eventRahulsharma0810/rvsharma.com

Rahul sharma

commit sha ff395e292d75241417c1a1bf02ade6703332acd3

pdf files

view details

push time in 15 days

push eventRahulsharma0810/rvsharma.com

Rahul sharma

commit sha 3e36c86762b0c2407ad959bbf672db9db0c0ad8e

pdf file

view details

push time in 15 days

push eventRahulsharma0810/rvsharma.com

Rahul sharma

commit sha d2459577b479f33533e6071602c3625b68c32dd7

pdf files

view details

push time in 15 days

push eventRahulsharma0810/rvsharma.com

Rahul sharma

commit sha 6cb3503531cf7dc9077f20b54a584ba20793a4c5

PDF files

view details

push time in 15 days

startedTheGU/gdrive-upload

started time in a month

fork Rahulsharma0810/charts

OpenEBS Helm Charts and other utilities

fork in a month

issue commentmath-nao/certs

Cert is not issues

  kubernetes.io/ingress.class: nginx
  # nginx.ingress.kubernetes.io/backend-protocol: "HTTPS"
  acme.kubernetes.io/enable: "true"
  acme.kubernetes.io/dns: "dns_gd"
  acme.kubernetes.io/cmd-to-use: "acme.sh --register-account -m me@rvsharma.com"
  nginx.ingress.kubernetes.io/rewrite-target: /```
Rahulsharma0810

comment created time in a month

issue openedmath-nao/certs

Cert is not issues

Version: 1.1.10
wait few seconds in case ingress rule is deployed at the same as it is in demo
Before script
Info: Initialize environment...
Info: No cmd args found
Info: Generate certs for dns: dns_gd, is_staging: false, is_debug: false, args: , cmd to use: acme.sh --register-account -m me@rvsharma.com, name: ca-kubedash-rvsharma-cert-secret, namespace: kubernetes-dashboard, domains: kubedash.labs.rvsharma.com
Info: Loading conf from secret...
Info: Invalid status code found: 404, configuration not loaded
[Tue Aug 17 10:13:08 UTC 2021] Create account key ok.
[Tue Aug 17 10:13:08 UTC 2021] No EAB credentials found for ZeroSSL, let's get one
[Tue Aug 17 10:13:09 UTC 2021] Registering account: https://acme.zerossl.com/v2/DV90
[Tue Aug 17 10:13:13 UTC 2021] Registered
[Tue Aug 17 10:13:13 UTC 2021] ACCOUNT_THUMBPRINT='lwwxDxUNfq2WUUxKGnVNSPdGeCAsIx7okXGgGzLHLJlxk'
Info: acme.sh return code: 0
Info: No certificate change, nothing to do
Exiting...
After script

On every cron pod it's returning the same output, with any ingress.

created time in a month

issue closedmath-nao/certs

Please update your account with an email address first

---
apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: kubernetes-dashboard-ingress
  namespace: kubernetes-dashboard
  annotations:
    kubernetes.io/ingress.class: nginx
    nginx.ingress.kubernetes.io/backend-protocol: "HTTPS"
    acme.kubernetes.io/enable: "true"
    acme.kubernetes.io/dns: "dns_gd"
    acme.kubernetes.io/cmd-to-use: "acme.sh --register-account -m me@example.com"
wait few seconds in case ingress rule is deployed at the same as it is in demo
Before script
Info: Initialize environment...
Info: No cmd to use found
Info: No cmd args found
Info: Generate certs for dns: dns_gd, is_staging: false, is_debug: false, args: , cmd to use: , name: ca-kubedash-example-cert-secret, namespace: kubernetes-dashboard, domains: kubedash.labs.example.com
Info: Loading conf from secret...
Info: Invalid status code found: 404, configuration not loaded
[Tue Aug 17 09:22:17 UTC 2021] Sleep 10 and retry.
[Tue Aug 17 09:22:28 UTC 2021] Using CA: https://acme.zerossl.com/v2/DV90
[Tue Aug 17 09:22:28 UTC 2021] Create account key ok.
[Tue Aug 17 09:22:28 UTC 2021] No EAB credentials found for ZeroSSL, let's get one
[Tue Aug 17 09:22:28 UTC 2021] acme.sh is using ZeroSSL as default CA now.
[Tue Aug 17 09:22:28 UTC 2021] Please update your account with an email address first.
[Tue Aug 17 09:22:28 UTC 2021] acme.sh --register-account -m my@example.com
[Tue Aug 17 09:22:28 UTC 2021] See: https://github.com/acmesh-official/acme.sh/wiki/ZeroSSL.com-CA
[Tue Aug 17 09:22:28 UTC 2021] Please add '--debug' or '--log' to check more details.
[Tue Aug 17 09:22:28 UTC 2021] See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh
Info: acme.sh return code: 1
Info: An acme.sh error occurred

closed time in a month

Rahulsharma0810

issue commentmath-nao/certs

Please update your account with an email address first

Never mind, the ingress annotations was not reloaded.

Rahulsharma0810

comment created time in a month

issue openedmath-nao/certs

Please update your account with an email address first

---
apiVersion: extensions/v1beta1
kind: Ingress
metadata:
  name: kubernetes-dashboard-ingress
  namespace: kubernetes-dashboard
  annotations:
    kubernetes.io/ingress.class: nginx
    nginx.ingress.kubernetes.io/backend-protocol: "HTTPS"
    acme.kubernetes.io/enable: "true"
    acme.kubernetes.io/dns: "dns_gd"
    acme.kubernetes.io/cmd-to-use: "acme.sh --register-account -m me@example.com"
wait few seconds in case ingress rule is deployed at the same as it is in demo
Before script
Info: Initialize environment...
Info: No cmd to use found
Info: No cmd args found
Info: Generate certs for dns: dns_gd, is_staging: false, is_debug: false, args: , cmd to use: , name: ca-kubedash-example-cert-secret, namespace: kubernetes-dashboard, domains: kubedash.labs.example.com
Info: Loading conf from secret...
Info: Invalid status code found: 404, configuration not loaded
[Tue Aug 17 09:22:17 UTC 2021] Sleep 10 and retry.
[Tue Aug 17 09:22:28 UTC 2021] Using CA: https://acme.zerossl.com/v2/DV90
[Tue Aug 17 09:22:28 UTC 2021] Create account key ok.
[Tue Aug 17 09:22:28 UTC 2021] No EAB credentials found for ZeroSSL, let's get one
[Tue Aug 17 09:22:28 UTC 2021] acme.sh is using ZeroSSL as default CA now.
[Tue Aug 17 09:22:28 UTC 2021] Please update your account with an email address first.
[Tue Aug 17 09:22:28 UTC 2021] acme.sh --register-account -m my@example.com
[Tue Aug 17 09:22:28 UTC 2021] See: https://github.com/acmesh-official/acme.sh/wiki/ZeroSSL.com-CA
[Tue Aug 17 09:22:28 UTC 2021] Please add '--debug' or '--log' to check more details.
[Tue Aug 17 09:22:28 UTC 2021] See: https://github.com/acmesh-official/acme.sh/wiki/How-to-debug-acme.sh
Info: acme.sh return code: 1
Info: An acme.sh error occurred

created time in a month

push eventRahulsharma0810/Planet-CyberSecurity

Rahul Sharma

commit sha 78aa83e85b4fce0d44ef99dfd894125740d9405d

Deep CIS Rules with Remediation

view details

push time in 2 months

startedreturntocorp/semgrep

started time in 3 months