profile
viewpoint

Phobetor/rabbitmq-supervisor-bundle 105

Symfony bundle to automatically create and update supervisor configurations for RabbitMQ consumer daemons

Phobetor/billomat 4

Billomat API Client

Phobetor/allegro-php 0

https://developer.allegro.pl/about Documentation is generated from [this](https://developer.allegro.pl/swagger.yaml) OpenAPI 3.0 specification file.

Phobetor/BeSimpleI18nRoutingBundle 0

Full routing internationalized on your Symfony project

Phobetor/billomat-bundle 0

A Symfony 2 bundle around the billomat API client

Phobetor/cache-bundle 0

Integrated Cache Bundle for Symfony

Phobetor/ebay-sdk-php 0

An eBay SDK for PHP. Use the eBay API in your PHP projects.

Phobetor/facebook-android-sdk 0

Used to integrate Android apps with Facebook Platform.

Phobetor/JMSSecurityExtraBundle 0

Enhances the Symfony2 Security Component with several new features

Phobetor/PackageGenerator 0

Generates a PHP SDK based on a WSDL, simple and powerful, WSDL to PHP

issue openedmichabbb/sdk-ebay-rest-finance

Update to API version `1.9.0`

The current eBay finances API version is 1.9.0. If this package is auto-generated, can you generate it again to update to the most current version of the API?

created time in 12 days

startedmaterial-foundation/material-tokens

started time in 24 days

push eventPhobetor/rabbitmq-supervisor-bundle

Phobetor

commit sha 403658fa88c1eb34becf73fd18d656d8d04a3dab

group consumers so supervisor sends signals in parallel

view details

push time in a month

push eventPhobetor/rabbitmq-supervisor-bundle

Phobetor

commit sha 7029eee103428f77def3002898722e28c0dbf825

wait for supervisord by default

view details

push time in a month

pull request commentliuggio/StatsDClientBundle

Added support for php8

For this bundle, you can use ^1.8@dev

As I wrote, this is not possible with symfony 3.

Here you can see the composer output for having symfony 3 and requiring liuggio/statsd-client-bundle >=1.7.0 (so basically all reasonable versions):

./composer.json has been updated
Running composer update liuggio/statsd-client-bundle
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - liuggio/statsd-client-bundle[dev-master, v1.8.0] require symfony/framework-bundle ^4.0 || ^5.0 -> found symfony/framework-bundle[v4.0.0-BETA1, ..., 4.4.x-dev, v5.0.0-BETA1, ..., 5.4.x-dev] but these were not loaded, likely because it conflicts with another require.
    - liuggio/statsd-client-bundle v1.7.0 requires symfony/framework-bundle ^2.3 -> found symfony/framework-bundle[v2.3.0, ..., 2.8.x-dev] but these were not loaded, likely because it conflicts with another require.
    - liuggio/statsd-client-bundle 1.8.x-dev is an alias of liuggio/statsd-client-bundle dev-master and thus requires it to be installed too.
    - Root composer.json requires liuggio/statsd-client-bundle >=1.7.0 -> satisfiable by liuggio/statsd-client-bundle[v1.7.0, v1.8.0, 1.8.x-dev (alias of dev-master)].

Installation failed

satisfiable by liuggio/statsd-client-bundle[v1.7.0, v1.8.0, 1.8.x-dev (alias of dev-master)] => checked 1.7, 1.8 and even dev-master.

All of them have requirements conflicting with symfony 3.

Conclusion:

Long story short: there is no way to use this package with symfony 3.* anymore. I need to fork it, allow symfony 3.* and then use that fork.

I did this now, and that works. I would still prefer a more backwards compatible release flow as I described above.

maxmilash

comment created time in a month

push eventPhobetor/StatsDClientBundle

Phobetor

commit sha 6dcb769baec93f6c8f6f5ba84fc0101a7b2df4e5

allow symfony 3.* as a dependency

view details

push time in a month

pull request commentliuggio/StatsDClientBundle

Added support for php8

It's just to push forward the ecosystem. It's better to keep only the actively maintained versions. In general I support this idea. There are some specifics with this bundle and its releases that make it a special case.

Anyone using an old version can just keep using old versions of this bundle as well. That is exactly the problem because it doesn't work.

Since 2018 the latest release version has been 1.7.0. Since then everyone using this bundle with symfony 3.* needs to use dev-master instead of a release version.

Now there is a new release version 1.8.0 which requires symfony >=4. So again, no luck for symfony 3.*.

The obvious solution would be: staying with dev-master and pinning the commit before the change that excluded symfony 3.x. But this is not working because composer is always looking at the newest commit of the used branch instead of the pinned commit when checking dependencies.

Long story short: there is no way to use this package with symfony 3.* anymore. I need to fork it, reset that fork to the last commit before the support dropping and then use that fork.

Just my two cents about keeping compatibility paths: In general in my opinion it would have been better practice to first deploy the functional changes, release that state as a new version and then in a second step do the upgrade-path-cutting operations and release another version. This could have been connected with a major version bump to keep a way open for later fixes on the old version.

maxmilash

comment created time in a month

fork Phobetor/StatsDClientBundle

Easily monitor your symfony2 production env., with ready-to-use stats.

fork in a month

delete branch Phobetor/google-api-php-client

delete branch : patch-1

delete time in a month

delete branch Phobetor/symfony

delete branch : ticket_28079

delete time in a month

pull request commentliuggio/StatsDClientBundle

Added support for php8

@garak Out of curiosity: why did you request to drop support for the old versions?

I know, they are not maintained anymore. But they do not pose any incompatibilities as far as I can see. So why build any walls that could prevent user from using the most current version of this bundle?

maxmilash

comment created time in a month

more