profile
viewpoint
If you are wondering where the data of this site comes from, please visit https://api.github.com/users/Lothiraldan/events. GitMemory does not store any data, but only uses NGINX to cache data for a period of time. The idea behind GitMemory is simply to give users a better reading experience.

comet-ml/comet-examples 83

Examples of Machine Learning code using Comet.ml

comet-ml/comet-for-mlflow 47

Comet-For-MLFlow Extension

Lothiraldan/balto 20

BAlto is a Language independent Test Orchestrator

comet-ml/co2-tracker-utils 2

CO2 Tracker helpers

comet-ml/comet-recipes 1

A collection of cookiecutter recipes for integrating ML frameworks with Comet in Python and R

comet-ml/fastai 1

The fastai deep learning library, plus lessons and and tutorials

comet-ml/websocket-client 1

websocket client for python

comet-ml/dulwich 0

Pure-Python Git implementation

push eventLothiraldan/litf

Boris Feld

commit sha a61f0d30a0a836376618636e00a8f389a70ec9d7

Simplify some test_result object definition

view details

push time in 14 days

startedrthoward/pydactory

started time in 14 days

push eventLothiraldan/bblfr_data

Boris Feld

commit sha 6054eed31edd7af95151dfcf3d25136e6f578bfa

Update Boris Feld profile

view details

push time in 15 days

create barnchLothiraldan/bblfr_data

branch : boris-feld-update-8-11-2021

created branch time in 15 days

fork Lothiraldan/endoflife.date

Informative site with EoL dates of everything

https://endoflife.date

fork in 15 days

PR opened Pithikos/python-websocket-server

Add minimum python version in setup.py

It looks like latest released version don't support Python 3.5 anymore. It is failing on line https://github.com/Pithikos/python-websocket-server/blob/master/websocket_server/websocket_server.py#L296 because it is using a f-string which is only available in Python 3.6+.

If it was intentional, this PR is adding the correct package metadata so pip can choose the right version depending on the user Python Version.

+1 -0

0 comment

1 changed file

pr created time in 19 days

push eventLothiraldan/python-websocket-server

Boris Feld

commit sha 032ca904c24c8539a1b70957f2d25ea8cebb1f3e

Add minimum python version in setup.py It looks like latest released version don't support Python 3.5 anymore. It is failing on line https://github.com/Pithikos/python-websocket-server/blob/master/websocket_server/websocket_server.py#L296 because it is using a f-string which is only available in Python 3.6+. If it was intentional, this PR is adding the correct package metadata so pip can choose the right version depending on the user Python Version.

view details

push time in 19 days

fork Lothiraldan/python-websocket-server

A simple fully working websocket-server in Python with no external dependencies

fork in 19 days

issue commentJulian/jsonschema

Fix packaging tags to drop Python version support

@tirkarthi Looks like you are correct, I also think the setup.cfg needs to be corrected.

Lothiraldan

comment created time in 23 days

issue commentp1c2u/openapi-spec-validator

openapi_spec_validator fails with jsonschema 4.0

Created a ticket to track the issue in jsonschema https://github.com/Julian/jsonschema/issues/845

svart-riddare

comment created time in 23 days

issue openedJulian/jsonschema

Packaging tags to drop Python version support

The recent release of JsonSchema 4.0.0 seems to drop support for Python 2 (and Python 3.5 also but it might been dropped before) but pip is having issues getting the right version depending on the Python version.

The correct information is in the setup.cfg https://github.com/Julian/jsonschema/blob/main/setup.cfg#L23

I think there are two issues for pip to pick the correct version based on the python version:

  • The python-requires seems to be correctly packaged in the file jsonschema-4.0.0.tar.gz but not in the file jsonschema-4.0.0-py3-none-any.whl. It looks like it's missing the correct metadata in the METADATA file. It should be a line similar to: Requires-Python: >=3.7
  • For pip to be able to get the correct package version, it needs at least two package versions with the proper package metadata https://packaging.python.org/guides/dropping-older-python-versions/#dropping-a-python-release. I would recommend releasing a version 3.2.1 with the following metadata: python_requires = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*".

I believe once both these actions are done, pip should be happy and users should get the proper version of jsonschema installed. I would be happy to help if needed.

created time in 23 days

issue commentp1c2u/openapi-spec-validator

openapi_spec_validator fails with jsonschema 4.0

Are you using Python 2 or Python 3.5 by any chance?

svart-riddare

comment created time in 23 days

pull request commentprotocolbuffers/protobuf

Add python-requires in setup.py

@aisk Sorry to ask, but where is the 4.0.0 version? I don't see it on Pypi nor see a tag or branch for 4.0.0.

aisk

comment created time in a month

pull request commentprotocolbuffers/protobuf

Add python-requires in setup.py

According to https://packaging.python.org/guides/dropping-older-python-versions/#dropping-a-python-release and adding such field on other project, I think we need a 3.17.4 release with the python_requires that includes Python 2 and then a release 3.18.1 that drops Python 2 support.

aisk

comment created time in a month

push eventLothiraldan/balto

Boris Feld

commit sha 6a4b57ebd95d5bc968f9d4057de81138d59dcae2

Remove old bit of CLI interface tests

view details

push time in a month

push eventLothiraldan/balto

Boris Feld

commit sha 7cea224019c491adac86751e1989ec87785fc5d3

Dependency updates

view details

push time in a month

startedvpelletier/pprofile

started time in 2 months

delete branch mlco2/codecarbon

delete branch : clean-requirements-dev

delete time in 2 months

push eventmlco2/codecarbon

vict0rsch

commit sha d0d2bf6f14da0e281b90db16788dac4e2da3f356

remove tensorflow&keras-tuner from dev reqs

view details

vict0rsch

commit sha 9221bb6345d5176d82a9310626093c84ed2aee38

add Python 3.9

view details

vict0rsch

commit sha f2e2520df7bff518bb6da4ad9490a5c816bd77f0

catch fuzzywuzzy warning

view details

vict0rsch

commit sha 6af17485ecd9ba387ddd1f93024bb003a33a8151

add 3.9 language classifier

view details

Boris Feld

commit sha 66c36a1199ddc447a281575158c132c538afe92f

Merge pull request #233 from mlco2/clean-requirements-dev Clean dev requirements + add 3.9 + catch fuzzywuzzy warning

view details

push time in 2 months

PR merged mlco2/codecarbon

Reviewers
Clean dev requirements + add 3.9 + catch fuzzywuzzy warning

Remove tensorflow and keras-tuner from requirements-dev.txt as they are only useful for the examples and present in examples/requirements-examples.txt

Also add Python 3.9 as Github Actions build target

Finally, catch fuzzywuzzy warning

+6 -4

0 comment

4 changed files

vict0rsch

pr closed time in 2 months

PullRequestReviewEvent

Pull request review commentmlco2/codecarbon

fix RAPL.end() unit

 from dataclasses import dataclass -from codecarbon.core.units import Energy+from codecarbon.core.units import Energy, Power, Time   @dataclass class RAPLFile:     name: str     path: str     energy_reading: Energy = Energy(0)-    power_measurement: float = 0+    power_measurement: float = 0  # kW

I think it is a good idea, mypy would be able to check for mixing of units. If we want to go further, we can even have a custom classes that don't wrapper float and convert them to float at the last moment.

vict0rsch

comment created time in 3 months

PullRequestReviewEvent